Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-03-04, 12:02 PM   #25
Corona688
Registered User
 
Join Date: Feb 2004
Posts: 93
Default Re: Redraw/repaint problem with FX 5200 and OpenGL

*bump*
Corona688 is offline   Reply With Quote
Old 04-14-04, 04:13 PM   #26
efx52u
Registered User
 
Join Date: Jan 2004
Posts: 16
Default Re: Redraw/repaint problem with FX 5200 and OpenGL

This is really frustrating. There's no way to know if Nvidia evens acknowledges this as a probem.

Anyway has any of the following helped for you:
Changing AGPGARTs?
Disabling SMP?
efx52u is offline   Reply With Quote
Old 04-14-04, 08:39 PM   #27
Corona688
Registered User
 
Join Date: Feb 2004
Posts: 93
Default Re: Redraw/repaint problem with FX 5200 and OpenGL

Quote:
Originally Posted by efx52u
This is really frustrating. There's no way to know if Nvidia evens acknowledges this as a probem.
After two months of trying to get their attention, I managed to get one official response: It was 'stop it'. Either they're working on it, or they don't care. Time will tell.

Disabling AGPGART, or at least nv-kernel's use of AGPGART helps somewhat, but the problem still exists, and it still occasionally gets into a state where I must ctrl-alt-f1, login to console, and kill the program using OpenGL to regain control of my desktop. I've heard reports that disabling SMP solves the problem, but that's not very helpful since I didn't buy an SMP system for the purpose of not using half of it.
Corona688 is offline   Reply With Quote
Old 05-18-04, 03:28 PM   #28
efx52u
Registered User
 
Join Date: Jan 2004
Posts: 16
Default Re: Redraw/repaint problem with FX 5200 and OpenGL

Ok, I got another machine and did some more experimenting:

Original machine:
Dell Precision 420
Dual P3-1 GHz, Intel Carmel (840) Chipset

New machine:
Dell Dimension 8300
P4-3 GHz with HyperThreading, Intel 875 Chipset

The new machine came with a FX 5200 non ultra card (vbios: 04.34.20.22.bf). It works fine with no problems that I can notice.
I swapped in the eVGA FX 5200 Ultra (vbios 04.34.20.59.01) and did not change any config files. The 2D redraw/repaint problems show up. Also, some pixels twinkle and there's some flickering.

Both machines are running kernel 2.4.20-31.9smp (as HyperThreading shows up as 2 virtual CPUs). I'm using LCD monitors connected via DVI.
efx52u is offline   Reply With Quote
Old 07-13-04, 03:41 PM   #29
efx52u
Registered User
 
Join Date: Jan 2004
Posts: 16
Default Re: Redraw/repaint problem with FX 5200 and OpenGL

I've managed to solve the problem!
For various reasons I had to install Windows XP onto the system. Whenever I started it I got a dialog box with a message saying the card was not getting enough power, the performance will be reduced, and to check that the power connector was connected. Since the power connector was connected, the board was sent back to eVGA and I got a replacement board.
With the new board, the low power message in Windows is gone and OpenGL works fine in Linux. The 2d slowdown is gone. To fix the pixel twinkling I had to lower the refresh rate to 60 Hz (I'm using a LCD on DVI anyway).

It's not clear if the low power thing and OpenGl 2d slowdown problem are related. The new board has a different vbios version (04.34.20.18.00) than the old (broken) card.
efx52u is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:59 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.