Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-30-02, 07:00 PM   #1
Darkgod
Guest
 
Posts: n/a
Default DMA error (SuSE 8.0)

Welp... I've tried every README, HOWTO, and install instructions I could find and now I've come to the point where there is nothing more that I can see to do. Anyway I have installed the rpm's for SuSE 8.0 numerous times... dif vers at that. They seem to install without a hitch then I do the proper XF86Config and modules.conf editing as well as Symlink generation. I get this error:

(EE) NVIDIA(0): Failed to allocate a DMA push buffer context
(EE) NVIDIA(0): *** Aborting ***
(EE) NVIDIA(0): Failed to allocate DMA push buffer
(EE) NVIDIA(0): *** Aborting ***

I have included my XF86Config file for viewing.
Attached Files
File Type: txt xf86config.txt (5.3 KB, 130 views)
  Reply With Quote
Old 10-05-02, 06:02 AM   #2
Peter Gilbert
Guest
 
Posts: n/a
Question SuSE8.0 GeForce2 mx no DMA Buffer

I have the same problem.

EE nvidia(0) Failed to allocate a DMA push buffer context
***Aborting***


did you have any luck solving your error. I'm trying to get the TwinView to work but so far have just two blank monitors trying to sync and then X dumps back out to the console.
  Reply With Quote
Old 10-05-02, 12:54 PM   #3
maoam02
Guest
 
Posts: n/a
Thumbs up SuSE 8.0 Problem

I have had the same one ("DMA buffer") and also no errors in the XF86 log file. I solved it in entering first the line
Option "NvAgp" "0" (watch upper and lower cases! you used upper cases for ...GP, this may be a problem, I am not sure)
into the XF86Config file which disables AGP. This worked but slow.

The section looks currently like this:

Section "Device"
BoardName "RIVA TNT2"
BusID "1:0:0"
Driver "nvidia"
Option "NvAgp" "1"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
EndSection

It works also with the values "1" (see above, works faster than "0" because it uses AGP) and "2" (more or less the same speed as "1").
If omitting the whole entry the error as describebd will appear or not but it won't work. SuSE's SaX2 is obviously not in the position to add this line by itself. I didn't check if the value "3" also works (it should).

I have a TNT2 chip and a VIA P3V133 mainboard. I am using Release 2960 of the NVidia driver (as recommended by the script NVchooser.sh).
  Reply With Quote
Old 10-08-02, 10:55 PM   #4
Darkgod
Guest
 
Posts: n/a
Default

I have solved the issue... My "default" installation did not install gcc which wasn't the issue in whole but was preventing me from installing from source. The SuSE binaries that nvidia has premade don't work correctly or work correctly on all installations. So I installed the gcc package and compiled from source and works just fine with agpgart and 4x setting.
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Reproducable Hard Lockup - RH 8.0 & 3123 brand NVIDIA Linux 6 10-05-02 03:48 PM
nforce & redhat 8.0 incin NVIDIA Linux 3 10-03-02 01:10 PM
Redhat 8.0, no rpm, can't compile. Ironphil NVIDIA Linux 6 10-02-02 03:13 PM
Source RPMS for GCC3.2 - Red Hat 8.0? chrisw01 NVIDIA Linux 4 08-21-02 08:17 AM

All times are GMT -5. The time now is 10:53 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.