Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-24-04, 09:25 AM   #1
nlinuxdia
Registered User
 
Join Date: Jan 2004
Posts: 9
Default Help needed.

I originally posted this in the wrong forum. Sorry 'bout that.

Here's my problem:

After installing the latest driver release for my Geforce3 ti500 and editing my XF86Config file, everything initially seemed O.K.

I installed UT2003 and wanted to see how fast it smoked with this fresh linux install 'cause I'm a n00b to linux and was pretty excited. Well, in the terminal, when I launch the game, I get the error: Xlib: extension "Xig-Sundry-nonstandard" missing on display ":0.0".

The game doesn't crash or anything, it's just unplayably slow. Here is my xf86config file:

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "KDS XF-9e"
DisplaySize 360 270
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 3 (generic)"
VideoRam 65536
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

System specs:
Amd XP 2200+
512 DDR
Geforce3 Ti500
a7v8x mobo

My log file is attached in the original thread: http://www.nvnews.net/vbulletin/show...threadid=23982


Thank you in advance for your help.
__________________
Clever sig.
nlinuxdia is offline   Reply With Quote
Old 01-26-04, 09:58 AM   #2
rednuht
GeForce FX5600 (1.0-5336)
 
rednuht's Avatar
 
Join Date: Sep 2003
Location: uk
Posts: 164
Default from the readme

taken from the readme file
You should also remove the following lines:

Load "dri"
rednuht is offline   Reply With Quote
Old 01-26-04, 02:35 PM   #3
nlinuxdia
Registered User
 
Join Date: Jan 2004
Posts: 9
Default

Thanks for the help red, but the problem is persistant after removing that line. When I run glxgears, I get an average of 5.0fps...no errors in my log file but there are warnings about resolution. Is the log necessary to include, if so, it's still attached to the other thread: http://www.nvnews.net/vbulletin/sho...?threadid=23982

I appreciate the help!!
__________________
Clever sig.
nlinuxdia is offline   Reply With Quote
Old 01-26-04, 03:37 PM   #4
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Looks like your old thread got dumped. What's the output of 'glxinfo'?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 01-26-04, 09:18 PM   #5
nlinuxdia
Registered User
 
Join Date: Jan 2004
Posts: 9
Default

Well, I decided to start over from scratch. It was easy because I had an old GeForce2 that doesnt use glx (well, I think it doesn't ). Anyway, I switched cards and when I booted with the Gf2, it installed the linux default nvidia drivers which replaced the ones that I had screwed up. I then switched them back, and it detected the switch, installed the default drivers, etc...

I re-downloaded the driver .run file and used what I've learned when I was screwing it up to exit "x" by using the terminal, then did the "sh" thingy, (can you tell I'm a n00b to linux) typed in "startx" and edited the XF86Config file per the readme. I then restarted the computer and viola! glxgears shows almost 6000 fps. A nice improvement from 5!!

Thanks nvidia for making linux drivers. It's a pain in the glxgears(or ass whichever you prefer) when hardware manufacturers don't support their own hardware with linux drivers.

Thanks everyone that helped out, I really appreciate it.


If you're a n00b to linux like me, don't get all bent out of shape if it doesnt work right away, eventually you will get it, and all of your hard work will prove valuable and you will appreciate it more. Don't give up!
__________________
Clever sig.
nlinuxdia is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flame's crypto attack may have needed $200,000 worth of compute power News Archived News Items 0 06-11-12 09:40 PM
9700 Pro OC app. needed PaiN Other Desktop Graphics Cards 5 10-11-02 12:46 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 03:59 AM
HD recommendation needed raggie007 General Hardware 12 10-01-02 09:08 PM
Powersupply help needed. Zarich General Hardware 7 09-25-02 01:45 AM

All times are GMT -5. The time now is 03:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.