Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-24-04, 07:41 AM   #1
nlinuxdia
Registered User
 
Join Date: Jan 2004
Posts: 9
Default PHelp needed. Please read.

Here's my problem:

After installing the latest driver release for my Geforce3 ti500 and editing my XF86Config file, everything initially seemed O.K.

I installed UT2003 and wanted to see how fast it smoked with this fresh linux install 'cause I'm a n00b to linux and was pretty excited. Well, in the termainal, when I launch the game, I get the error: Xlib: extension "Xig-Sundry-nonstandard" missing on display ":0.0".

The game doesn't crash or anything, it's just unplayably slow. Here is my xf86config file:

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "KDS XF-9e"
DisplaySize 360 270
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 3 (generic)"
VideoRam 65536
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

System specs:
Amd XP 2200+
512 DDR
Geforce3 Ti500
a7v8x mobo
__________________
Clever sig.
nlinuxdia is offline   Reply With Quote
Old 01-24-04, 07:44 AM   #2
nlinuxdia
Registered User
 
Join Date: Jan 2004
Posts: 9
Default

Here's the log file as requested:
Attached Files
File Type: log xfree86.1.log (34.5 KB, 160 views)
__________________
Clever sig.
nlinuxdia is offline   Reply With Quote
Old 01-24-04, 11:53 AM   #3
Moled
cheese
 
Join Date: Aug 2003
Posts: 137
Default

thats not an error, you just don't have that extension in your xserver and since you are using xfree you won't

whats the output of glxinfo?

have you tried a game such as quake3 etc?

the opengl renderer is know to be slower than the d3d one in ut2k3
Moled is offline   Reply With Quote
Old 01-24-04, 11:56 AM   #4
Moled
cheese
 
Join Date: Aug 2003
Posts: 137
Default

and from that log I can tell you its not using the correct driver (nvidia) but the unaccelerated nv one

hence you will get terrible performance since everything in done in software

I guess its using a different config file

(==) Using config file: "/etc/X11/XF86Config"

is that the one you edited?
Moled is offline   Reply With Quote
Old 01-24-04, 06:53 PM   #5
nlinuxdia
Registered User
 
Join Date: Jan 2004
Posts: 9
Default

Quote:
Originally posted by Moled
and from that log I can tell you its not using the correct driver (nvidia) but the unaccelerated nv one

hence you will get terrible performance since everything in done in software

I guess its using a different config file

(==) Using config file: "/etc/X11/XF86Config"

is that the one you edited?
Yeah, that's the one. I figured out that I had left the

Load "dri"

line in there, and so I took it out. The problem still persists. How do I get my glxinfo info out of the terminal and into this post? Won't let me copy/paste, and i'm a dummy.

Thanks for everything so far!!
__________________
Clever sig.
nlinuxdia is offline   Reply With Quote
Old 01-24-04, 07:11 PM   #6
Moled
cheese
 
Join Date: Aug 2003
Posts: 137
Default

just select it with the mouse to copy

middle mouse button or left + right together to paste
Moled is offline   Reply With Quote
Old 01-24-04, 07:24 PM   #7
geowiz
Registered User
 
Join Date: Jul 2003
Location: Houston, Tx USA
Posts: 110
Default nv vs nvidia

Moled is right that the log indicates that you are using the XFree86 standard "nv" driver. But the XF86Config file you sent indicates that you are using the "nvidia" driver.

2 possibilities - wrong log file or wrong config file. Now, XFree86 4 series has one of two config files.... /etc/X11/XF86Config and/or /etc/X11/XF86Config-4 depending on distribution. The log indicates /etc/X11/XF86Config. Did you actually edit the /etc/X11/XF86Config-4 and send that?

Or, look in /var/log/ for the XFree86.0.log and see if it is more recent than the XFree86.1.log..... possible the wrong log got sent.

For the glx issue, run glxgears. to get the info from the terminal, use a redirect and output to a file.
glxinfo > glxinfo.txt
then attach the glxinfo.txt file ;-)

Good luck
geowiz is offline   Reply With Quote
Old 01-24-04, 07:31 PM   #8
nlinuxdia
Registered User
 
Join Date: Jan 2004
Posts: 9
Default

In my current log I see the following warnings:

(WW) (1856x1392,Monitor0) mode clock 218.3MHz exceeds DDC maximum 210MHz
(WW) (1920x1440,Monitor0) mode clock 234MHz exceeds DDC maximum 210MHz
(WW) (1920x1200,Monitor0) mode clock 230MHz exceeds DDC maximum 210MHz
(WW) (2048x1536,Monitor0) mode clock 266.95MHz exceeds DDC maximum 210MHz
(WW) NVIDIA(0): Not using mode "1024x768" (height 1536 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1200)
(WW) NVIDIA(0): Not using mode "960x720" (height 1440 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1200)
(WW) NVIDIA(0): Not using mode "928x696" (height 1392 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1200)
(WW) NVIDIA(0): Not using mode "896x672" (height 1344 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1200)
(WW) NVIDIA(0): Not using mode "576x384":
(WW) NVIDIA(0): horizontal sync start (589) not a multiple of 8
(WW) NVIDIA(0): Not using mode "360x200":
(WW) NVIDIA(0): Failed to verify AGP usage

Dammit, I wish I couuld decipher that! Lemme see what google says...any ideas to what may have caused these warnings and how to remedy them? Could this be the cause of my video problems?
__________________
Clever sig.
nlinuxdia is offline   Reply With Quote

Old 01-24-04, 08:14 PM   #9
nlinuxdia
Registered User
 
Join Date: Jan 2004
Posts: 9
Default

Here is the glxinfo.txt

Average fps on glxgears was 5.0fps

Horrid....
Attached Files
File Type: txt glxinfo.txt (6.2 KB, 169 views)
__________________
Clever sig.
nlinuxdia is offline   Reply With Quote
Old 01-26-04, 11:02 AM   #10
nlinuxdia
Registered User
 
Join Date: Jan 2004
Posts: 9
Default

This forum is slooooooooooooooow.
__________________
Clever sig.
nlinuxdia is offline   Reply With Quote
Old 01-26-04, 05:45 PM   #11
Moled
cheese
 
Join Date: Aug 2003
Posts: 137
Default

ah, via chipset

if you had posted in the gfx forum I think you would have gotten a better response

get the new drivers from: http://www.nvidia.com/object/linux_d..._ia32_1.0-5336

Quote:
Fixed AGP failures on some VIA motherboards.

I think that may help you
Moled is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flame's crypto attack may have needed $200,000 worth of compute power News Archived News Items 0 06-11-12 09:40 PM
Anatomy of a hack: 6 separate bugs needed to bring down Google browser News Archived News Items 0 05-22-12 06:40 PM
in 307.11 don't read Fan speed with nvidia-settings sl1pkn07 NVIDIA Linux 2 05-21-12 10:08 AM
APM (nonsuspend) hard-lockups - I READ THE FAQ idangazit NVIDIA Linux 9 12-27-02 07:43 AM
HD recommendation needed raggie007 General Hardware 12 10-01-02 09:08 PM

All times are GMT -5. The time now is 06:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.