Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-27-04, 06:31 PM   #1
dleemans
Registered User
 
Join Date: Jan 2004
Posts: 2
Default No AGP on Sis746 based mobo with Kernel 2.6.1

Hi,

I just installed the latest nvidia drivers (5536) successfully
on a Slackware 9.1 system with kernel 2.6.1.
card is a Geforce4 MX-440, mobo is an Asrock K7S8X.
X is solid stable and 3D accelleration seems ok, but 2D is awfully slow. You can actually see the background being drawn.
Kernel agp loads but doesn't mention the chipset found (as it does in 2.4.24, where it finds a Sis746 AGP chipset)).
The XFree86 log mentions this :
(WW): NVIDIA : unable to verify AGP usage
When the nvidia module loads, the kernel produces this :
unable to retrieve symbol table
This only happens with kernel 2.6.x, everything is ok on kernel 2.4.x.
Maybe something for the kernel 2.6 AGP maintainer ?
Other people with the same issues ?

Kind regards,

David
dleemans is offline   Reply With Quote
Old 01-27-04, 06:35 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

Make sure you have both agpgart.ko and the actual backend driver (in your case sis-agp.ko) loaded before you start X.
zander is offline   Reply With Quote
Old 01-27-04, 06:58 PM   #3
dleemans
Registered User
 
Join Date: Jan 2004
Posts: 2
Default

Thx, problem is indeed solved now :

the sis-agp module was simply not loaded. Apparently, this does not happen automatically even though my kernel is build with "auto module loading".
I adapted /etc/rc.d/rc.modules to load the sis-agp module on boot.


Kind regards,

David
dleemans is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 04:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 11:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 05:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 09:22 PM

All times are GMT -5. The time now is 03:25 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.