Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-04-04, 10:12 AM   #13
squarooticus
 
Join Date: Nov 2003
Posts: 36
Default

Quote:
Originally posted by Andy Mecham
No, but it makes a difference in which distros I test with.
Andy, any word on this? Have you had a chance to test this setup yet?

Cheers,
Kyle
squarooticus is offline   Reply With Quote
Old 02-05-04, 09:32 PM   #14
squarooticus
 
Join Date: Nov 2003
Posts: 36
Default BTW, still broken with 1.01 beta

I tested the AGP/PCI dual head setup tonight, and the PCI display is still slow as molasses in winter. So, the BIOS update didn't help.
squarooticus is offline   Reply With Quote
Old 05-14-04, 02:06 PM   #15
surfed
Registered User
 
Join Date: May 2004
Posts: 7
Default Re: No double buffering on second screen?

What about using nvidia driver on agp card and nv driver on pci card? Would this result in good 3d agp performance and maybe good 2d performance in pci card?

EDIT:
i just tried the above with good results. I have full 2d speed on my PCI card (no 3d) and almost 75% of my original framerate in 3d using the AGP card. I am NOT using xinerama.

Last edited by surfed; 05-14-04 at 02:36 PM.
surfed is offline   Reply With Quote
Old 05-14-04, 02:34 PM   #16
squarooticus
 
Join Date: Nov 2003
Posts: 36
Default Re: No double buffering on second screen?

Quote:
Originally Posted by surfed
What about using nvidia driver on agp card and nv driver on pci card? Would this result in good 3d agp performance and maybe good 2d performance in pci card?
I was not able to successfully get the two drivers to coexist.
squarooticus is offline   Reply With Quote
Old 05-14-04, 02:37 PM   #17
surfed
Registered User
 
Join Date: May 2004
Posts: 7
Default Re: No double buffering on second screen?

Quote:
Originally Posted by squarooticus
I was not able to successfully get the two drivers to coexist.
I am just using them both together.... works great
surfed is offline   Reply With Quote
Old 06-06-04, 02:57 AM   #18
surfed
Registered User
 
Join Date: May 2004
Posts: 7
Default Re: No double buffering on second screen?

The followin config gives me good 3d on agp and good 2d on pci card WITH xinerama.


Code:
Section "Files"
    FontPath 	"/usr/X11R6/lib/X11/fonts/misc:unscaled"
    FontPath 	"/usr/share/fonts/corefonts"
    FontPath 	"/usr/local/share/fonts"
    FontPath 	"/usr/share/fonts"
#    .....cut rest of font files for irrelevency
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail# allows the server to start up even if the mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    Option "Xinerama" "true"
    Option "UseInt10Module" "1"
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    # Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    # Option "XkbOptions" ""
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option       "ButtonNumber" "5"
  Option       "Device" "/dev/mouse"
  Option       "Name" "Autodetection"
  Option       "Protocol" "ExplorerPS/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
  Identifier "lg"
  Option       "DPMS"
  HorizSync 31.5-79
  VertRefresh 50-100
EndSection

Section "Monitor"
    Identifier "samsung"

# Analog:
# Modeline 	"1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync

# Digital:
Modeline	"1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
Modeline        "800x600@60" 38.21 800 832 976 1008 600 612 618 631 +hsync +vsync
EndSection

Section "Device"
    Identifier "AGP"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA FX5200 128 DDR (AGP)"
    Driver "nvidia"
    BusId "PCI:2:0:0"
    Option "DPMS" "0"
    Option "HWCursor" "1"
    Option "CursorShadowYOffset" "2"
    Option "NvAGP" "1"
    Option "CursorShadowXOffset" "4"
    Option "CursorShadow" "1"
    Option "NoLogo" "0"
    Option "CursorShadowAlpha" "64"
    Option "DigitalVibrance" "35"
    Option "RenderAccel" "1"
EndSection

Section "Device"
    Identifier "PCI"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA FX5200 128 DDR (PCI)"
    Driver "nv"
    BusId "PCI:1:7:0"
    Option "DPMS" "1"

EndSection

Section "Screen"
    Identifier "screen0"
    Device "AGP"
    Monitor "samsung"
	DefaultColorDepth 24
    Subsection "Display"
        Depth 24
        Modes "1280x1024@60" "800x600"
        ViewPort 0 0
    EndSubsection
EndSection

Section "Screen"
    Identifier "screen1"
    Device "PCI"
    Monitor "lg"
	DefaultColorDepth 24
    Subsection "Display"
        Depth 24
        Modes "1024x768"
        ViewPort 0 0
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "default"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen 0 "screen0"
    Screen 1 "screen1" LeftOf "screen0"
EndSection
surfed is offline   Reply With Quote
Old 06-06-04, 11:36 AM   #19
squarooticus
 
Join Date: Nov 2003
Posts: 36
Default Re: No double buffering on second screen?

Quote:
Originally Posted by surfed
The followin config gives me good 3d on agp and good 2d on pci card WITH xinerama.
What version of the kernel module/driver are you using? Did you have to provide any specific options to the kernel module to get this to work? What version of the X server?

Whenever I try this (and I tried it just now), it appears to work from the perspective of the X server log, but I get no sync on the PCI display, and when I try to move the mouse cursor there, the system hard-locks.

Thanks,
Kyle
squarooticus is offline   Reply With Quote
Old 06-06-04, 12:29 PM   #20
squarooticus
 
Join Date: Nov 2003
Posts: 36
Default Re: No double buffering on second screen?

By the way, the reason I'm asking about your setup is that the mere presence of the PCI card (a GeForce FX5200) in my system causes the 5336 nvidia kernel module to crash: even if the PCI card isn't being used by X, I get oopses whenever I try to use Xv on the AGP card, for instance.

Cheers,
Kyle
squarooticus is offline   Reply With Quote

Old 06-23-04, 08:44 PM   #21
squarooticus
 
Join Date: Nov 2003
Posts: 36
Default Re: No double buffering on second screen?

BTW, I finally go the nvidia 1st head, nv 2nd head to work by "priming" the PCI card with a dual-nvidia startx followed by an nvidia-nv startx. I am using X.org 4.4: I was not able to get this to work with 4.3's nv driver. Please send me email at krose@krose.org if you want details.

Cheers,
Kyle
squarooticus is offline   Reply With Quote
Old 06-24-04, 02:53 PM   #22
squarooticus
 
Join Date: Nov 2003
Posts: 36
Default Re: No double buffering on second screen?

BTW, I should point out that, under this regime, I have fantastic 2D performance on both heads, plus 3D support on the first (nvidia) head. It would be nice, however, to use one driver for both, especially considering the hoops I have to jump through to get the X.org 4.4 nv driver to work on the FX 5200 at all.

Andy/other nVidia guys, can you please take a look at the nvidia driver/kernel module and figure out why its non-AGP performance is so terrible, at least on my chipset (AMD-81x1)?

Also, a more general question: what numbers should I be seeing for FPS at glxgears' default window size? I get approximately 3,000 fps on a dual Opteron 244, FX 5600.

Cheers,
Kyle
squarooticus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 5.6 .nvidia-settings-rc settings un-applied on screen lock bluziff NVIDIA Linux 1 06-14-12 05:12 AM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 06:00 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 03:17 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM

All times are GMT -5. The time now is 11:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.