Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-01-04, 10:25 AM   #1
FEDC1user
Registered User
 
Join Date: Feb 2004
Location: Virgina
Posts: 3
Question System Locks during screen saver -- help!

I recently installed the nvidia drivers version .5336 (the latest ones) and now my system works fine until the screensaver gets activated. I have a RivaTNT2 32MB card. Once the screensaver gets activated the entire system locks up and the only way I can get out is kill power at the tower (not a good thing...). I get the following output in /var/log/messages:
Feb 1 10:38:38 localhost kernel: 0: nvidia: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-5336 Wed Jan 14 18:29:26 PST 2004
Feb 1 10:38:38 localhost insmod: Warning: loading /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/video/nvidia.o will taint the kernel: non-GPL license - NVIDIAFeb 1 10:38:38 localhost insmod: See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Feb 1 10:38:38 localhost insmod: Module nvidia loaded, with warnings


I made the mistake of "assuming" that the latest version would work for me w/o running the NVchooser.sh file first to make sure. After running NVchooser.sh, it tells me:
NVIDIA does not provide a prebuilt binary driver for your
distribution at this time. Please download:
NVIDIA_kernel-1.0-2960.tar.gz
NVIDIA_GLX-1.0-2960.tar.gz

I downloaded those, but get compile errors when running the "make install" command, saying that the wrong version of gcc is being used to compile the driver.

How can I change the version of gcc that it is trying to use during the "make install" command? Any help on this would be greatly appreciated....

Thx -- Tim
FEDC1user is offline   Reply With Quote
Old 02-01-04, 07:10 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default

The 2960 drivers are close to 2 years old. It may be time for an OS upgrade. Which distro and version are you using? But then kernel 2.4.22 isn't that old.
whig is offline   Reply With Quote
Old 02-01-04, 07:48 PM   #3
FEDC1user
Registered User
 
Join Date: Feb 2004
Location: Virgina
Posts: 3
Default

I just loaded Fedora Core 1 to play around with it. I had been using RH9, but since that is the last RH, I thought I would get onboard with the Fedora Project.

I'm not sure why it told me to use the 2960 drivers, but I am having a very hard time to get them to install. I keep getting an error message when I type the "make install" command. It says the compiler it is using to compile the drivers is not compatible with the version used to compile the kernel. It tells me that I can point the "make" command to the version of gcc used to compile the kernel, but I don' t know how to do that.

I reinstalled the latest version of the driver so that I could get the Xserver working again, but still have the crash problem with the screensaver.

So far, the only work around that I have come up with is to have the screensaver just go to a blank screen. With this setting, my system does not lock up.

Could it be that there is a setting somewhere that I need to tweak, and that these latest drivers from nvidia will be OK?

Or could it be a support problem with the Fedora Core? Everything that I have seen so far with Fedora has been pretty much identical to RH9...

Thanks for the reply, any other suggestions for me to try?

-Tim
FEDC1user is offline   Reply With Quote
Old 02-01-04, 09:48 PM   #4
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default

A guess: your screensaver is an OpenGL one, and that OpenGL games crash your system too. This won't affect normal desktop applications as they don't use OpenGL.

What is your hardware? Also check your logs for signs of kernel panics.
whig is offline   Reply With Quote
Old 02-02-04, 05:59 PM   #5
FEDC1user
Registered User
 
Join Date: Feb 2004
Location: Virgina
Posts: 3
Thumbs up

I think I have figured out the problem. After doing some more research, I found some info on problems caused by the Advanced Power Management daemon:

"Note that standby is not supported, but that the kernel will attempt
to enter standby if told to do so. When changing power levels, many
system services are alerted of the change so that they can handle the
change appropriately. For example, networking will be disabled before
suspending, then reenabled when resuming. When the kernel attempts to
enter standby, the bios will fail the attempt. The kernel will print out
the error message "standby: Parameter out of range", but will fail to
notify the system services of the failure. As a result, the system will
not go into suspension, but all system services will be disabled and the
system will appear hung. The best way to recover from this situation is
to enter suspend, then resume."

I edited /etc/rc5.d file with the following command:

mv S26apmd K26apmd

This way apm does not start at boot. The problem has been resolved. Thought you might like to know the solution that was found...

-Tim
FEDC1user is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Max Payne 3 system requirements updated, new PC screenshots released News Archived News Items 0 05-28-12 06:49 AM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 06:00 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 03:17 PM
Strange RedHat 7.3 issues with A7N266-C nforceuser NVIDIA Linux 8 09-27-02 03:16 PM

All times are GMT -5. The time now is 06:08 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.