Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-02-04, 03:18 PM   #1
Gonzor
Registered User
 
Join Date: Feb 2004
Posts: 2
Default Graphics Accelerator doesn't accelerate

Hi,

I am using the 2.6.1 kernel, and the 5336 drivers don't seem to work properly. They work better than the default drivers, but all GL applications (tuxracer, various screensavers) use 100% cpu load. Glxgears shows ~800 fps and I couldn't find anything wrong with agpgart in glxinfo and XFree86.0.log, so I assume agp works properly..
Could something be wrong with mesa ?


sorry about my bad english but it isn't my native language and I am pretty pissed of right now *g*...
Gonzor is offline   Reply With Quote
Old 02-02-04, 05:17 PM   #2
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default

Step on the gas!

Maybe mesa was installed or updated after nvidia-glx / driver package?

Many games will run 100% cpu (q3a, rtcw, etc). but if you have really bad FPS, it could be that Mesa's libGL is being used instead of nvidia's.

If that's the case, or you are unsure, you can try to re-install the GL libraries.

I use debian, so I can just put mesa packages on hold and not have to worry about updates fiddling with my libGL, but suse or other distros may not have such an option.
logan is offline   Reply With Quote
Old 02-03-04, 01:27 AM   #3
Gonzor
Registered User
 
Join Date: Feb 2004
Posts: 2
Default

if I use this driver with a precompiled Red Hat Fedora 2.4 Kernel, my Performance is much better. Perhaps I missed an option in my 2.6 configuration?
Gonzor is offline   Reply With Quote
Old 02-03-04, 01:37 AM   #4
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default

Well, it could be the X and AGP configuration in the kernel.

I used to build the kernel with AGPGART support, but then switched to nvidia's AGP driver hoping it would solve my lockup problems. It didn't, but I never bothered to change the config back.

/etc/X11/XF86Config-4:
# Option "NvAGP" "0" # disable AGP
Option "NvAGP" "1" # use NvAGP
# Option "NvAGP" "2" # use AGPGART
# Option "NvAGP" "3" # use AGPGART then NvAGP (default)

I could probably go with NvAGP 3, which should fallback to nvidia's AGP driver, but whatever...

I guess you should just make sure you have the AGP config the way it should be, either AGPGART enabled in the kernel and NvAGP 2, or AGP disabled in the kernel and NvAGP 1.

-(~) cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: NVIDIA
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

You should also know I had a real hard time getting nvidia's AGP driver to work. I think a driver upgrade fixed the problem, you may want to just go with AGP enabled in the kernel.
logan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thoughts from console owners on NVIDIA's GEFORCE GRID MikeC Console World 11 05-27-12 08:43 AM

All times are GMT -5. The time now is 11:08 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.