Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-05-04, 06:19 AM   #1
michael-mc
Registered User
 
Join Date: Feb 2004
Posts: 2
Unhappy garbage display exiting graphic mode

when exiting graphic mode or shutting down have garbage dispaly
problem does not exist with the original "NV" driver supplied by the OS

the OS is mandrake linux V9.2

video card is GEforce 4 MX 440

motherboard is DFI TA64-B

CPU is P3

Nvidia driver is latest 1.0-5336

would appreciate help
Attached Files
File Type: txt xf86config-4.txt (2.7 KB, 134 views)
michael-mc is offline   Reply With Quote
Old 02-05-04, 07:08 AM   #2
sasa
Registered User
 
Join Date: May 2003
Location: Prague, Czech Rep.
Posts: 3
Send a message via ICQ to sasa
Default

I have the same problem with the latest (5336) drivers in 2.6.2-pre8.
Works fine in 2.4.25-rc?.
It hapens every time I quit the X server. It is frozen so deep that SysRQ keys don't
work and I cannot login from a different computer.
Sometimes I have black screen, sometimes vertical yellow and pink stripes.

I read something that to restore the text mode, the driver needs to access BIOS INT 10. I don't know if can do that just without anything or if it nees a kernel module to be loaded.
Other thing is that I only tested it from vesafb and rivafb framebuffers. I Will try it from a VGA console.
sasa is offline   Reply With Quote
Old 02-05-04, 07:09 AM   #3
sasa
Registered User
 
Join Date: May 2003
Location: Prague, Czech Rep.
Posts: 3
Send a message via ICQ to sasa
Default

I forgot - I have MSI KT4V motherboard with Via KT400 chipset and a GeForce2 MX 400 card. And X server from RedHat 8.0.
sasa is offline   Reply With Quote
Old 02-05-04, 07:11 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

You'll want vesafb (or rivafb) disabled.
zander is offline   Reply With Quote
Old 02-05-04, 12:58 PM   #5
michael-mc
Registered User
 
Join Date: Feb 2004
Posts: 2
Default

how do you disable it?
michael-mc is offline   Reply With Quote
Old 02-05-04, 02:04 PM   #6
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

Assuming it is vesafb you're using, passing video=vesa:off vga=normal to the kernel (from the boot loader) should do the trick.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
320.17 can't detect video modes on Lenovo laptop tadawson NVIDIA Linux 13 07-14-12 02:40 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 10:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 12:34 PM

All times are GMT -5. The time now is 05:26 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.