Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-10-04, 12:57 AM   #1
46and2
Registered User
 
Join Date: Feb 2004
Location: Texas
Posts: 2
Send a message via AIM to 46and2
Default Need help--Starting X takes 5 minutes!

I just did a full install of Slackware 9.1 (switched from RH9) and then installed the 5336 nvidia driver. Everything works, but now when I startx, the screen goes blank and it's about 5 minutes before the desktop appears.
I logged in from another computer on the LAN and ran startx -- -verbose 5 from there so I could see what was happening while the screen blanked. When the "NVIDIA(0):" lines began, everything slowed to snail's pace, and after the "NVIDIA(0)" lines everything went back to normal. I tried some archived drivers all the way back to 4349, but they all had the same problem. I never had this problem when I was using RH, but I don't remember which driver version I had installed.
Video card is a PNY Verto Geforce2 PRO 64MB.
I've attached my XFree86 log (logverbose 5) and I added my XF86Config on to the end with cat >>. (Is there a way to attach 2 files?)
I'm grateful the driver works, but having to wait 5 minutes everytime I start X is super annoying. I would love to hear if anybody has any experience with this problem or any suggestions on how to fix it.

Thanks
Attached Files
File Type: log xfree86.0.log (41.0 KB, 235 views)
46and2 is offline   Reply With Quote
Old 02-10-04, 01:53 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

From the README:

Code:
Q: X takes a long time to start (possibly several minutes).  What can
   I do?
   
A: Most of the startx delay problems we have found are caused by incorrect
   data in video BIOSes about what display devices are possibly connected
   or what i2c port should be used for detection.  You can work around
   these problems with the XF86Config option "IgnoreDisplayDevices"
   (please see the description in (app-d) APPENDIX D: XF86CONFIG OPTIONS).
zander is offline   Reply With Quote
Old 02-10-04, 02:24 AM   #3
46and2
Registered User
 
Join Date: Feb 2004
Location: Texas
Posts: 2
Send a message via AIM to 46and2
Default Fixed!


Thanks zander!
I missed this when skimming the (incredibly long) README. I told nvidia to ignore DFP's and TV's and now X starts in a few seconds.
46and2 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
11 Minutes Of Commanding Carrier Command Footage News Archived News Items 0 06-27-12 11:50 AM
AMD Takes Graphics Crown with AMD Radeon HD 7970 GHz Edition (AMD) News Archived News Items 0 06-22-12 04:50 AM
Presidents Vs Zombies: 20 Minutes Of Resident Evil 6 News Gaming Headlines 0 06-21-12 09:30 AM
Play Tera for 30 minutes in your browser for free News Archived News Items 0 06-07-12 07:50 AM
Arma 3 video shows minutes of in-game footage News Archived News Items 0 05-06-12 07:50 PM

All times are GMT -5. The time now is 11:05 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.