Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-10-04, 09:10 AM   #1
axelf
Registered User
 
Join Date: Feb 2004
Posts: 1
Default AMD64 (Suse9.0) and 1.0-5332 problem

Hi,

after two days of trying I hope someone can help me...

I want to use my GeForce5900 with the actual driver 1.0-5332. But all what I get is a black screen or ASCII stuff and a pressed reset-button for reboot.
Here is what I tried:

try1: my SuSE installation uses kernel 2.4.21-193. The installation process of the downloaded .run file worked fine. I compiled the driver and installed it into the modules section. So far no problem. But after restarting X all I got was a black screen or some ASCII stuff and a complete freeze. I've found no error logs for this problem. The loaading of the module via insmod works with no problem.

try 2: I updated the distri to an unsupported 2.6.2 kernel. Damn fast...but no chance for compiling the driver. The installer says something about kernel headers, but the sources are installed. A manual compilation failes because of this error message: "gcc is not the version which compiled the kenel" or something like this. And exists...but when have sometimes can compile this beast I fear I will get the black screen error again.

What now? Have I a chance of using my card under this distribution? For a Linux newbie like me a big problem.

Thanks for your help!

AxelF
axelf is offline   Reply With Quote
Old 03-01-04, 02:42 AM   #2
Inchoate
Registered User
 
Join Date: Jan 2004
Posts: 2
Default

I believe you may need to supply
export IGNORE_CC_MISMATCH=1
and
--kernel-include-path=/path/to/you/src
where /path/to/your/src is the include subdir where you built the kernel; also you may need to copy that ./config/modversions.h to the include path provided above. That solved my problems for 2.4.xxx.

Apparently there's a new way to link against kernel includes and that's /lib/modules/`uname -r`/build/include, but modversions.h never made it there either.

I got this to compile on 2.4.xxx but can't for 2.6.3 on SuSe 9.0 for AMD64.

GL,

-- Jason
Inchoate is offline   Reply With Quote
Old 03-01-04, 03:26 AM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

You will need to patch the 1.0-5332 driver release in order to be able to use it with Linux 2.6 kernels; the new family of kernels insists that the exact same compiler be used for the kernel and kernel modules. As to the black screen, make sure you have vesafb disabled and experiment with the AGP configuration (should the problem persist with Linux 2.6).
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.