Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-12-04, 10:24 PM   #1
CrLf
Linux Power!
 
Join Date: Dec 2002
Location: Lisbon, Portugal, E.U.
Posts: 61
Default Problems with prelink and libGL in Fedora Core 1

Recently I tried to verify some packages using "rpm -V packagename" and I get a bunch of "prelink: /usr/X11R6/lib/xscreensaver/sproingies: at least one of file's dependencies has changed since prelinking" kind of errors and after a bit of investigation (checking the prelink logs) I traced the problem to this:

"/usr/sbin/prelink: /usr/X11R6/lib/xscreensaver/glmatrix: Cannot prelink against non-PIC shared library /usr/lib/tls/libGL.so.1"

prelink.log is full os these kind of messages, all related to the same lib. I guess that this is not such a big deal but weird just the same.

I'm using Fedora Core 1 with all the latest updates and nvidia drivers v5336.
CrLf is offline   Reply With Quote
Old 02-13-04, 01:37 AM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default

Find out more by searching this forum for "TLS".
whig is offline   Reply With Quote
Old 02-13-04, 01:28 PM   #3
CrLf
Linux Power!
 
Join Date: Dec 2002
Location: Lisbon, Portugal, E.U.
Posts: 61
Default

I renamed the /usr/lib/tls directory to tls.old to force the use of the non TLS versions. This problem also happens with these versions. It's a libGL problem, in both the normal and TLS versions.

PS: I forced a full prelinking and ldconfig to test this.
CrLf is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.