Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-10-04, 10:34 PM   #1
scotus
Registered User
 
Join Date: Feb 2004
Location: St. Louis, MO
Posts: 1
Default Yet another NOOB w/Suse 9.0 net issues

Okay, I downloaded the Nvidia unified drivers (1.0-0261), installed the binary RPM, and got this:
linux:/work # depmod -a
depmod: *** Unresolved symbols in /lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o
depmod: *** Unresolved symbols in /lib/modules/2.4.21-override-athlon/kernel/drivers/sound/nvaudio.o

uname -a returns this: linux 2.4.21-166-athlon #1 Thu Dec 18 18:24:05 UTC 2003 i686 athlon i386 GNU/Linux. This is SuSE 9.0, and I've pulled down all the updates from SuSE.com in the last couple of days with autoupdate.

I am aware of forcedeth, but their precompiled module that they recommend for Suse does not bind, giving symbol errors. The txt files also don't make sense to me. It's been too long since I patched kernel source and I've forgotten how to use these files.

What on earth do I have to do to keep from loading an idiot cheapo ethernet card into the box just to get the network going with Linux?
scotus is offline   Reply With Quote
Old 02-14-04, 09:05 PM   #2
leibold
Registered User
 
Join Date: May 2003
Posts: 66
Default

The version of the running kernel and the version the network module (any module really) need to match exactly.

The binary modules you downloaded from nvidia or forcedeth are most likely for the kernel SuSE released on CD/DVD (2.4.21-99-athlon). However you have upgraded your system to a later version (2.4.21-166-athlon).

You have lots of choices (besides the cheapo ethernet card ) :

- build the network module on your system (make sure you install the correct kernel-source package first, it's version must match too).
- try to find (wait for) binaries matching your updated kernel.
- downgrade back to the kernel from the SuSE 9.0 release.
leibold is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM
Mandrake 9.0 or RH 8.0 for a Linux Noob?? jthompson7051 NVIDIA Linux 5 10-08-02 10:46 PM

All times are GMT -5. The time now is 06:19 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.