Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-11-04, 04:35 PM   #1
maibaum
Registered User
 
Join Date: Feb 2004
Posts: 3
Default SuSE 8.2: "Failed to allocate config DMA context"

I tried to install the NVidia graphics driver for my GeForce2 MX 400 on a fresh SuSE 8.2 install. The installation went fine, but X refuses to start with the new nvidia driver. This is the relevant (I think) part of XFree86.0.log:

(--) PCI:*(1:0:0) nVidia Corporation NV11 [GeForce2 MX/MX 400] rev 178, Mem @ 0xee000000/24, 0xf0000000/27, BIOS @ 0xefff0000/16
(II) Module nvidia: vendor="NVIDIA Corporation"
(II) NVIDIA XFree86 Driver 1.0-5336 Wed Jan 14 18:30:46 PST 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(--) Chipset NVIDIA GPU found
(**) NVIDIA(0): Depth 16, (--) framebuffer bpp 16
(==) NVIDIA(0): RGB weight 565
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xF0000000
(--) NVIDIA(0): MMIO registers at 0xEE000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce2 MX/MX 400
(--) NVIDIA(0): VideoBIOS: 03.11.01.48.00
(EE) NVIDIA(0): Failed to allocate config DMA context
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

The driver and the kernel were both compiled using the same version of gcc (3.3 20030226 (prerelease)).

I would appreciate it if someone could point me into the right direction.

Lutz
maibaum is offline   Reply With Quote
Old 02-13-04, 04:00 PM   #2
maibaum
Registered User
 
Join Date: Feb 2004
Posts: 3
Lightbulb [Solved] SuSE 8.2: "Failed to allocate config DMA context"

I found a solution to this problem in the following thread:

http://www.nvnews.net/vbulletin/show...threadid=16509

In short, I had to do the following before running the nvidia driver installation program:

cp /boot/vmlinuz.config /usr/src/linux/.config
cp /boot/vmlinuz.version.h /usr/src/linux/include/linux
cp /boot/vmlinuz.autoconf.h /usr/src/linux/include/linux
cd /usr/src/linux
make cloneconfig dep

I didn't think this was necessary, since I already had the kernel sources installed, but this worked for me.

Lutz
maibaum is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
DMA error (SuSE 8.0) Darkgod NVIDIA Linux 3 10-08-02 10:55 PM

All times are GMT -5. The time now is 06:23 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.