Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-05-05, 01:27 PM   #1
nvidia-is-sgi
Registered User
 
nvidia-is-sgi's Avatar
 
Join Date: Feb 2005
Posts: 16
Default FX5700LE, 2.6.10, FC3, AMD Irongate, 1.0-6629

Symptoms:

xdm won't start, it tries and dies and tries again, requires a reboot to
get out of the loop.

without xdm, trying to run startx locks up the system hard and
requires a hard boot complete with a file system check.

FX5700LE, 2.6.10, FC3, AMD Irongate, 1.0-6629

AMD Athlon 1.4Ghz
ASUS A7M266 ACPI BIOS 1006


xorg.conf and Xorg.0.log attached
Attached Files
File Type: txt Xorg.0.log.txt (28.8 KB, 139 views)
File Type: txt xorg.conf.txt (5.0 KB, 155 views)
nvidia-is-sgi is offline   Reply With Quote
Old 02-05-05, 01:56 PM   #2
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: FX5700LE, 2.6.10, FC3, AMD Irongate, 1.0-6629

hmm, As far as I can see, Xorg's log are OK, so can you please run "nvidia-bug-report.sh" after Xorg crashed... (start up in textmode, login, and run "xinit") or you may can get out of the loop, by pressing ALT+SYSRQ(AKA print screen)+i (i, not I) (this depends if FC3 has sysrq-support (check for /proc/sysrq-trigger)... and attach the log here...
chunkey is offline   Reply With Quote
Old 02-05-05, 02:02 PM   #3
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: FX5700LE, 2.6.10, FC3, AMD Irongate, 1.0-6629

The first thought when I saw irongate again disable all agp by adding the line: Option "NvAGP" "0" and also try to put it in 1x in the bios. This chipset had so much agp troubles at the time so that is the reason I first want to have agp turned off.
Thunderbird is offline   Reply With Quote
Old 02-05-05, 02:25 PM   #4
nvidia-is-sgi
Registered User
 
nvidia-is-sgi's Avatar
 
Join Date: Feb 2005
Posts: 16
Default Re: FX5700LE, 2.6.10, FC3, AMD Irongate, 1.0-6629

Quote:
Originally Posted by chunkey
hmm, As far as I can see, Xorg's log are OK, so can you please run "nvidia-bug-report.sh" after Xorg crashed... (start up in textmode, login, and run "xinit") or you may can get out of the loop, by pressing ALT+SYSRQ(AKA print screen)+i (i, not I) (this depends if FC3 has sysrq-support (check for /proc/sysrq-trigger)... and attach the log here...

system required hard reboot, don't know if this will be as useful as if the 3-fingered salute had worked.
Attached Files
File Type: txt nvidia-bug-report.log.txt (82.7 KB, 172 views)
nvidia-is-sgi is offline   Reply With Quote
Old 02-05-05, 02:26 PM   #5
nvidia-is-sgi
Registered User
 
nvidia-is-sgi's Avatar
 
Join Date: Feb 2005
Posts: 16
Default Re: FX5700LE, 2.6.10, FC3, AMD Irongate, 1.0-6629

Quote:
Originally Posted by Thunderbird
The first thought when I saw irongate again disable all agp by adding the line: Option "NvAGP" "0" and also try to put it in 1x in the bios. This chipset had so much agp troubles at the time so that is the reason I first want to have agp turned off.

I remember reading about the AGP settings but don't recall where they get set. I will check the bios but where does the nvagp option go?
nvidia-is-sgi is offline   Reply With Quote
Old 02-05-05, 02:40 PM   #6
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: FX5700LE, 2.6.10, FC3, AMD Irongate, 1.0-6629

That option needs to be placed in the screen/device section of the X config file. (it doesn't matter if you put it in device or screen both work)
Thunderbird is offline   Reply With Quote
Old 02-05-05, 05:28 PM   #7
nvidia-is-sgi
Registered User
 
nvidia-is-sgi's Avatar
 
Join Date: Feb 2005
Posts: 16
Default Re: FX5700LE, 2.6.10, FC3, AMD Irongate, 1.0-6629

Quote:
Originally Posted by Thunderbird
That option needs to be placed in the screen/device section of the X config file. (it doesn't matter if you put it in device or screen both work)

So far disabling the 4x in the bios has allowed me to startx.

Then, just to throw caution to the wind, I enabled the 4x and
disabled the NvAGP in the xorg.conf and I have ran startx and
it's running.

I also needed to add DefaultColorDepth 24 to the screen section of xorg.conf to get anything better than 8-bit

I still have not tried running xdm, but that's less critical.

Thanks!
nvidia-is-sgi is offline   Reply With Quote
Old 02-08-05, 07:13 PM   #8
nvidia-is-sgi
Registered User
 
nvidia-is-sgi's Avatar
 
Join Date: Feb 2005
Posts: 16
Default Re: FX5700LE, 2.6.10, FC3, AMD Irongate, 1.0-6629

For the benefit of those poor souls that have to go through this same crap.

I apllied patches 1155389, 1165235, 1171869
Disabled 4x AGP in the bios (that sets it at 2x)
removed any agpgart stuff from the kernel
enabled the nvidia agp in the xorg.conf
and also added DefaultColorDepth 24 to the xorg.conf

I think that's about it. nVidia should put some of the knowledge from this board into their installer.
nvidia-is-sgi is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
AMD Gooses the Clocks on 'Bulldozer' Opterons News Archived News Items 0 06-04-12 02:24 PM

All times are GMT -5. The time now is 01:27 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.