Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-13-04, 04:25 PM   #1
buckwheat12
Registered User
 
Join Date: Feb 2004
Posts: 1
Default Nvidi ti 4200 Blank Screen after nvidia install

I have a Nvidia ti 4200 video card, I am trying to install the Nvidia driver for it but I am running into some problems. Here is what I have done so far:

I first downloaded the NVIDIA-Linux-x86-1.0-5336-pkg1.run file off of nvidia's site.
I then did a Ctrl-Alt-F1 and then an init 3 to get out to a prompt and down x.
I logged in as root and installed the .run file and it said everything was sucessfull.
I edited the XF86Config-4 file and changed the driver from "nv" to "nvidia" and saved the file.
I tried to start x and only get a blank screen, if I change the "nvidia" back to "nv" in my config file everything works fine.

Here's what my XFree86.0.log shows:

XFree86 Version 4.3.0
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.18-23mdksmp i686 [ELF]
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Fri Feb 13 13:06:27 2004
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "layout1"
(**) |-->Screen "screen1" (0)
(**) | |-->Monitor "monitor1"
(**) | |-->Device "device1"
(**) |-->Input Device "Keyboard1"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "en_US"
(**) XKB: layout: "en_US"
(WW) Option "XkbOptions" requires an string value
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Mouse1"
(**) FontPath set to "unix/:-1"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "AllowMouseOpenFail"
Using vt 7
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80002008, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 01:00:0: chip 10de,0253 card 1462,8791 rev a3 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,2), BCTRL: 0x000a (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xcdd00000 - 0xcfefffff (0x2200000) MX[b]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xbd900000 - 0xcdbfffff (0x10300000) MX[b]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:2:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV25 [GeForce4 Ti 4200] rev 163, Mem @ 0xce000000/24, 0xc0000000/27, 0xcdb80000/19, BIOS @ 0xcfee0000/17
(II) Addressable bus resource ranges are:
(II) OS-reported resource ranges:
(II) PCI Memory resource overlap reduced 0xd0000000 from 0xd7ffffff to 0xcfffffff
(II) Active PCI resource ranges:
(II) Active PCI resource ranges after removing overlaps:
(II) OS-reported resource ranges after removing overlaps with PCI:
(II) All system resource ranges:
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "v4l"
(II) Loading /usr/X11R6/lib/modules/drivers/linux/v4l_drv.o
(II) Module v4l: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.0.1
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 2.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.5336
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.5336
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) v4l driver for Video4Linux
(II) NVIDIA XFree86 Driver 1.0-5336 Wed Jan 14 18:30:46 PST 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
(II) resource ranges after probing:
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xC0000000
(--) NVIDIA(0): MMIO registers at 0xCE000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce4 Ti 4200
(--) NVIDIA(0): VideoBIOS: 04.25.00.29.24
(--) NVIDIA(0): VideoRAM: 65536 kBytes
(II) NVIDIA(0): Connected display device(s): CRT-0
(--) NVIDIA(0): Detected TV Encoder: Philips 7104
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 8 bpp: 350 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 16 bpp: 350 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 32 bpp: 350 MHz
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) NVIDIA(0): monitor1: Using hsync range of 30.00-107.00 kHz
(II) NVIDIA(0): monitor1: Using vrefresh range of 48.00-120.00 Hz
(II) NVIDIA(0): Clock range: 12.00 to 350.00 MHz
(II) NVIDIA(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "512x384" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "1152x864" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1280x960" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1280x960" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1280x1024" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1280x1024" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1280x1024" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1600x1200" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1600x1200" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1600x1200" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1600x1200" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1600x1200" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1792x1344" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1792x1344" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1856x1392" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1856x1392" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "2048x1536" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(WW) NVIDIA(0): Not using mode "1024x768" (height 1536 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1200)
(WW) NVIDIA(0): Not using mode "960x720" (height 1440 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1200)
(WW) NVIDIA(0): Not using mode "928x696" (height 1392 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1200)
(WW) NVIDIA(0): Not using mode "896x672" (height 1344 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1200)
(WW) NVIDIA(0): Not using mode "896x672" (height 1344 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1200)
(WW) NVIDIA(0): Not using mode "768x576":
(WW) NVIDIA(0): horizontal sync width (846 - 832 = 14) not a multiple of 8
(WW) NVIDIA(0): Not using mode "576x384":
(WW) NVIDIA(0): horizontal sync start (589) not a multiple of 8
(WW) NVIDIA(0): Not using mode "360x200":
(WW) NVIDIA(0): horizontal sync start (378) not a multiple of 8
(**) NVIDIA(0): Validated modes for display device CRT-0:
(**) NVIDIA(0): Default mode "1024x768": 94.5 MHz, 68.7 kHz, 85.0 Hz
(**) NVIDIA(0): Default mode "1024x768": 78.8 MHz, 60.1 kHz, 75.1 Hz
(**) NVIDIA(0): Default mode "1024x768": 75.0 MHz, 56.5 kHz, 70.1 Hz
(**) NVIDIA(0): Default mode "1024x768": 65.0 MHz, 48.4 kHz, 60.0 Hz
(**) NVIDIA(0): Mode "1024x480": 65.0 MHz, 48.4 kHz, 85.9 Hz
(**) NVIDIA(0): Default mode "800x600": 56.3 MHz, 53.7 kHz, 85.1 Hz
(**) NVIDIA(0): Default mode "800x600": 114.8 MHz, 106.2 kHz, 85.0 Hz (D)
(**) NVIDIA(0): Default mode "800x600": 49.5 MHz, 46.9 kHz, 75.0 Hz
(**) NVIDIA(0): Default mode "800x600": 101.2 MHz, 93.8 kHz, 75.0 Hz (D)
(**) NVIDIA(0): Default mode "800x600": 50.0 MHz, 48.1 kHz, 72.2 Hz
(**) NVIDIA(0): Default mode "800x600": 94.5 MHz, 87.5 kHz, 70.0 Hz (D)
(**) NVIDIA(0): Default mode "800x600": 87.8 MHz, 81.2 kHz, 65.0 Hz (D)
(**) NVIDIA(0): Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(**) NVIDIA(0): Default mode "800x600": 81.0 MHz, 75.0 kHz, 60.0 Hz (D)
(**) NVIDIA(0): Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz
(--) NVIDIA(0): Display dimensions: (370, 270) mm
(--) NVIDIA(0): DPI set to (70, 72)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xcdb80000 - 0xcdbfffff (0x80000) MX[b]
[1] 0 0 0xc0000000 - 0xc7ffffff (0x8000000) MX[b]
[2] 0 0 0xce000000 - 0xceffffff (0x1000000) MX[b]
[3] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[4] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[8] -1 0 0xcfffc000 - 0xcfffcfff (0x1000) MX[b]
[9] -1 0 0xcffff000 - 0xcfffffff (0x1000) MX[b]
[10] -1 0 0xcfffe000 - 0xcfffefff (0x1000) MX[b]
[11] -1 0 0xcfffd000 - 0xcfffdfff (0x1000) MX[b]
[12] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[b]O
[13] -1 0 0xcfee0000 - 0xcfefffff (0x20000) MX[b](B)
[14] -1 0 0xcdb80000 - 0xcdbfffff (0x80000) MX[b](B)
[15] -1 0 0xc0000000 - 0xc7ffffff (0x8000000) MX[b](B)
[16] -1 0 0xce000000 - 0xceffffff (0x1000000) MX[b](B)
[17] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
[18] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
[19] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[21] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[22] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
[23] -1 0 0x0000d800 - 0x0000d87f (0x80) IX[b]
[24] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[b]
[25] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[b]
[26] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[27] 0 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): AGP 4X successfully initialized
(II) NVIDIA(0): Setting mode "1024x768"
buckwheat12 is offline   Reply With Quote
Old 02-15-04, 12:37 PM   #2
DaryX
GAINWARD GeForge 4 TI4200
 
Join Date: Feb 2004
Location: ITALY (PADOVA)
Posts: 7
Angry I've same problem too

I've the same problem with the same videocard (Gainward TI 4200) but under RH 9 (Shrike). After installing the driver a blank sreen appears (or sometimes a black screen with some random chars). This is because the X-server crashes invact if U press ctrl-alt-canc the system restart, but the ctrl-alt-backspace doesn't function. The problem is that the debug info in XFree86 doesn't report EE or significant warning.
Now I'm going to post a my own thread stressing the problem I hope to solve it asa soon as possible.
Have U solved the problem?

P.S.: if u change in XF86config nvidia to nv you don't use the nvidia accelerated driver but the generic for Geffo 4, that driver works fine also to me (and I haven't still uninstalled the accelerated one)
DaryX is offline   Reply With Quote
Old 02-16-04, 11:12 AM   #3
Tomas
Registered User
 
Join Date: Feb 2004
Posts: 1
Default Restart?

What key is CTL-ALT-CANC??

Tomas
Tomas is offline   Reply With Quote
Old 02-16-04, 11:47 AM   #4
DaryX
GAINWARD GeForge 4 TI4200
 
Join Date: Feb 2004
Location: ITALY (PADOVA)
Posts: 7
Default sorry...

Probably U don't have an Italian keyboard, in an US keyboard must be CTRL-ALT-DEL. Right? with this key U're able to restartt the system (U can obtain the same effect with #init 6).
DaryX is offline   Reply With Quote
Old 02-16-04, 09:01 PM   #5
bailout
Registered User
 
Join Date: Feb 2004
Posts: 5
Default

exactly the same problem here with mdk9.2. I get a completely black screen and have to hard reboot cntl-alt-backspace/del have no effect. Works again when I edit back to load "nv"
bailout is offline   Reply With Quote
Old 02-17-04, 05:50 AM   #6
DaryX
GAINWARD GeForge 4 TI4200
 
Join Date: Feb 2004
Location: ITALY (PADOVA)
Posts: 7
Default Probably is due to AGP modules

I've posted a new thread about this ....

http://www.nvnews.net/vbulletin/show...threadid=24974
DaryX is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
NVS3100 (Thinkpad T410) blank screen on resume NvFuchs NVIDIA Linux 2 05-15-12 02:02 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 06:32 PM

All times are GMT -5. The time now is 07:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.