Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-15-04, 11:48 AM   #1
krischik
Registered User
 
Join Date: Feb 2004
Location: Germany
Posts: 4
Question GeForce 5700, SuSE 9.0, hsync problems (solved)

Hello,

when I startx then the left an right border is all fuzzy, jumping about the width of a thump. I think it might be an hsync problem. Ob course the picture in betreen the borders look just as bad.

What I have tried that far:

- X works ok in with "vesa" instead of "nv" driver.

- MS-Windows works with all resolutions.

- modlines from a working installation (same monitor) won't work.

- sax2 won't work either - it did work with at installation, but then the vesa driver is used.

- sax2 won't reconize the card by name, just saying it is "0x0342".

- downloaded nvidia driver - however I am unsure if they are activated.

Card: MSI GeForce FX5700-TD RTL
Mainbord: Asus K8V Deluxe
OS: SuSE 9.0 AMD64
Driver: 1.0-5332

Any help is apreciated.

With Regards

Martin
Attached Files
File Type: log xfree86.0.log (41.3 KB, 119 views)

Last edited by krischik; 02-17-04 at 03:34 AM.
krischik is offline   Reply With Quote
Old 02-15-04, 12:08 PM   #2
krischik
Registered User
 
Join Date: Feb 2004
Location: Germany
Posts: 4
Post XF86Config

Well Andy Mecham said the XF86Config should be added as well - but you can only add one attechement.
Attached Files
File Type: txt xf86config.txt (5.2 KB, 129 views)
krischik is offline   Reply With Quote
Old 02-15-04, 12:45 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

Judging from the configuration and log files, you're using the XFree86 nv driver; does the problem reproduce with the binary NVIDIA driver (see the README for configuration instructions)?
zander is offline   Reply With Quote
Old 02-15-04, 04:49 PM   #4
Ulf
Registered User
 
Join Date: Feb 2004
Location: Stockholm
Posts: 3
Default

I had recently similar problems with a SuSE 9.0 based system
but this is now at least functional, using the NVIDIA-module.
You are correct that sax will not work with neither nv
(black screen) nor NVIDIA (white screen). So use
sax2 -m 0=vesa
That makes it possible to set up all aspects except possibly graphics.
You will probably not be able to test your monitor settings so save
and leave at that stage (accepting the identification 0x0342).
You may have to edit XF86Config manually.
Check if your nvidia.o-module has been properly installed in .../kernel/drivers/video etc.
This is what I did. The performance is not stellar, not much better
than what my standard geforce2ultra card delivers.
Ulf is offline   Reply With Quote
Old 02-16-04, 03:49 AM   #5
krischik
Registered User
 
Join Date: Feb 2004
Location: Germany
Posts: 4
Unhappy The nvidia Driver won't work either

Hello,

I tried the nvidia driver but it won't work either. The screen is all black, except for a few lines at the bottom.

- I checked that the kernel driver was loaded:

Module Size Used by Tainted: P
nvidia 2684864 0 (unused)

- checked the log file: everything ok until:

...
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib64/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.5332
Module class: XFree86 Video Driver
...
(II) NVIDIA(0): AGP 8X successfully initialized
(II) NVIDIA(0): Setting mode "1600x1200"

Please don't tell me a 250,-- Card won't do "1600x1200".

With Regards

Martin
Attached Files
File Type: log xfree86.0.log (29.7 KB, 121 views)
krischik is offline   Reply With Quote
Old 02-16-04, 02:11 PM   #6
Ulf
Registered User
 
Join Date: Feb 2004
Location: Stockholm
Posts: 3
Default

Hallo Martin
Your logfile ends when it should start loading glx. Is everything
properly installed?
For setting up XF86Config consult the SuSE database http://sdb.suse.de/sdb/de/html/wessels_sax247.html

Be modest start with some lower resolution and disable agp
by using: Option "NvAGP" "0" in Section Device.
Only the 2.6x kernel series can handle the modern agp-protocol.

If/when things start working enable the built in agpgart if you
use a 2.4.x kernel.

Good luck
Ulf is offline   Reply With Quote
Old 02-17-04, 03:32 AM   #7
krischik
Registered User
 
Join Date: Feb 2004
Location: Germany
Posts: 4
Smile Now it works!

Thank you Ulf,

'Option "NvAGP" "0"' was the bringer. Now I have a working AMD 64 System.

With Regards

Martin

PS: Attached it the now wokring XF86Config.
Attached Files
File Type: txt xf86config.txt (4.2 KB, 126 views)
krischik is offline   Reply With Quote
Old 02-17-04, 12:39 PM   #8
Ulf
Registered User
 
Join Date: Feb 2004
Location: Stockholm
Posts: 3
Default

Hallo again
I am glad that it works.
You may be able to enhance the performance somewhat
by setting: Option "NvAGP" "1"
This will enable the nvidia agp. On the system I tested
this resulted in approx 4500 fps for glxgears, which
is a bit disappointing compared to Ti4200.
If you would like to try the 2.6.2 kernel, which is
available at the SuSE site, you could later switch
to: Option "NvAGP" "2"
Kind regards,
Ulf
Ulf is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
Suse Linux 8.0 - Geforce 4 TwinView TA00 NVIDIA Linux 8 08-30-02 03:24 AM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 09:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM

All times are GMT -5. The time now is 05:21 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.