Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-01-04, 01:38 PM   #1
Aquila
Registered User
 
Join Date: Jul 2003
Posts: 6
Default Prob: Failed to initialize AGP

Hello

I've just installed Gentoo, and first configured X for using the nv driver. Today I wanted to install the nvidia driver, but when I do that, X doesn't show up any longer. I shows a screen with strange signs on it, and some colours (green, blue). Moving the mouse or something doesn't has any effect.

I've checked the log, and it says:
(WW) NVIDIA(0): Failed to initialize AGP
(II) NVIDIA(0): Setting mode "1280x1024"

Is it a known problem, and has somebody the solution?

Grtz
Aquila is offline   Reply With Quote
Old 03-01-04, 01:39 PM   #2
Aquila
Registered User
 
Join Date: Jul 2003
Posts: 6
Default XFree86.0.log

In attach:
XFree86.0.log
Attached Files
File Type: log xfree86.1.log (23.9 KB, 124 views)
Aquila is offline   Reply With Quote
Old 03-01-04, 01:41 PM   #3
Aquila
Registered User
 
Join Date: Jul 2003
Posts: 6
Default XF86Config

In attach:
XF86Config
Attached Files
File Type: txt xf86config.txt (14.3 KB, 143 views)
Aquila is offline   Reply With Quote
Old 03-01-04, 04:34 PM   #4
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default

Hi,

kill this line:
Option "omit xfree86-dga"

change this to that:
# Load "freetype"
Load "freetype"

change this:
Driver "nv"
to that:
Driver "nvidia"

and post your hardware, your dmesg and please, start reading the README!
It is not there to waste space, it has REAL and IMPORTANT information.
energyman76b is offline   Reply With Quote
Old 03-02-04, 03:01 AM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

@energyman76b: if you take a closer look at his post and the XFree86 log file, you'll see that he was using the NVIDIA driver module.

@Aquila: you will need to solve the lockup problem before you can determine the reason for the AGP initialization failure. For the moment, force AGP off, disable ACPI, vesafb and UP I/O APIC support and check if it helps.
zander is offline   Reply With Quote
Old 03-02-04, 05:44 AM   #6
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default

Hi,
I HAVE read, what he wrote!

Zander, YOU should read his XF86Config:

Section "Device"
Identifier "NVidia TI4200"
Driver "nv"
#VideoRam 131072
# Insert Clocks lines here if appropriate

He is definetly NOT using the nvidia-driver.
energyman76b is offline   Reply With Quote
Old 03-02-04, 10:31 AM   #7
Aquila
Registered User
 
Join Date: Jul 2003
Posts: 6
Default

Do you realy think I'm stupid like that? Maybe my english is bad, but I know what I'm talking about...
And I posted that I had a running X (nv-drivers) changed it to nvidia and got the error. And look @ the error, omg, it says (WW) NVIDIA(0) translated maybe? Warning Nvidia driver @ screen 0 failed to initialize agp...


I changed the config the way you say, but I hasn't an effect on the problem...
I'll try the other solution, hope that helps...

Grtz


//edit: Sorry for the sarc, had a bad day. When I disable AGP it works, no errors (except the refresh rate)

Last edited by Aquila; 03-02-04 at 10:51 AM.
Aquila is offline   Reply With Quote
Old 03-02-04, 03:40 PM   #8
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default

Hi,

you are right, my error. Sorry.

What type of chipset do you have?
Do you have AGPGART support in kernel?
Have you tried the NvAGP options?
energyman76b is offline   Reply With Quote

Old 03-02-04, 07:09 PM   #9
DaryX
GAINWARD GeForge 4 TI4200
 
Join Date: Feb 2004
Location: ITALY (PADOVA)
Posts: 7
Default me too...

I have a similar problem... still unresolved check my thread
http://www.nvnews.net/vbulletin/show...threadid=25603
For the APM, control in your kernel configuration if it's enabled the APM support.
For the AGP try to downgrade the rate by the BIOS and check if function(my videocard function at 2x max; at 4x X server chrash at startup).
Check also if the AGP drive strength value is in the range 0xEA - 0xEE.
Goodnight (especially 4me).
DaryX is offline   Reply With Quote
Old 03-03-04, 12:49 AM   #10
Aquila
Registered User
 
Join Date: Jul 2003
Posts: 6
Default

Maybe the solution is verry simple, my card has the GeForce4 Ti 4200 with AGP8X
when I use NVAGP it works, the moment I try AGPGART X crashes... So I'm going to put down agp to 4x and check the install of agpgart...
Aquila is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Red Hat 7.3, tarred 2960 download, NVdriver failed to initialize SparceMatrix NVIDIA Linux 7 09-10-02 12:02 AM
How much heat can a GeForce4 Ti 4600 handle? Velkator NVIDIA GeForce 7, 8, And 9 Series 4 09-03-02 04:41 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM

All times are GMT -5. The time now is 06:29 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.