Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-19-04, 04:01 PM   #13
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

I don't expect it helps, chances are reliability decreases with Linux AGPGART and this option disabled on certain configurations. Does your problem reproduce with fast writes and side band addressing disabled? Does it reproduce with AGP disabled alltogether?
zander is offline   Reply With Quote
Old 02-19-04, 06:45 PM   #14
darkhelmet03
Registered User
 
Join Date: Jul 2003
Posts: 62
Default FYI

the card is an FX5600.
darkhelmet03 is offline   Reply With Quote
Old 02-20-04, 10:59 AM   #15
LeVA
Guest
 
Posts: n/a
Default

I have now disabled the Fast Write and the SBA (installed the driver by the installer, and didn't modified the source, so everything is at default).
My problem is still the same, but I have not got that kernel badness message in my syslog when my system hangs.
I'm using XFree-4.3.99.903 (but this happens with the stable 4.3.0 too). My problem is that X hangs occasionly, and eats 100% of my cpu resource. Unfortunately I can not reproduce this wilfully. This means that this hang happens "randomly". I have to ssh to my machine from another computer, and do `killall -9 X`. Then my login manager restarts, and I can login again. But after a hang, if I switch to plain console's (ctrl+alt+f1), the font is totally messed up (random ascii characters). When this hang happens, I can move my cursor in X, but I can not click anywhere. After I connect to my computer from another machine, I can do anything I want (except running mc, which tries to connect to an X server).
So my computer didn't crash, just can not work anymore, because a process eats the 100% of the cpu (I can see this with `top`, and this process is X).

$ uname -a
Linux leva 2.6.2 #4 Sun Feb 15 15:00:40 CET 2004 i686 unknown
_
$ cat /proc/driver/nvidia/agp/host-bridge
Host Bridge: _ _ Intel Corp. 82845G/GL [Brookdale-G] Chipset Host Bridge
Fast Writes: _ _ Supported
SBA: _ _ _ _ _ _ Supported
AGP Rates: _ _ _ 4x 2x 1x
Registers: _ _ _ 0x1f000217:0x00000114
_
My video card:
$ cat /proc/driver/nvidia/cards/0
Model: _ _ _ _ _ GeForce FX 5200
IRQ: _ _ _ _ _ _ 11
Video BIOS: _ _ _04.34.20.27.06
Card Type: _ _ _ AGP
_
My driver:
$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86 NVIDIA Kernel Module _1.0-5336 _Wed Jan 14 18:29:26 PST 2004
GCC version: _gcc version 2.95.4 20011002 (Debian prerelease)
_
I have an ABIT BE7-RAID mainboard with an Intel 82845PE (MCH) chipset. I'm not using the agpgart module, I just load the nvidia kernel module, and I'm using the "nvidia" driver with my X.

$ cat /etc/X11/XF86Config-4
# Load "GLcore"
Load "bitmap"
# Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
# Load "vbe"
Load "v4l"

[...]

Section "Device"

_ _ _ _ Identifier _ _ _"Card0"
_ _ _ _ Driver _ _ _ _ _"nvidia"
# _ _ _ Driver _ _ _ _ _"nv"
_ _ _ _ VendorName _ _ _"Inno3D"
_ _ _ _ BoardName _ _ _ "GeForce FX 5200"
_ _ _ _ Screen _ _ _ _ _0
_ _ _ _ BusID _ _ _ _ _ "PCI:1:0:0"
_
_ _ _ _ Option _ _ _ _ _"CursorShadow" "false"
_ _ _ _ Option _ _ _ _ _"NoLogo" "true"
_ _ _ _ Option _ _ _ _ _"NvAGP" "1"
_ _ _ _ Option _ _ _ _ _"UseEdidFreqs" "true"
_ _ _ _ Option _ _ _ _ _"IgnoreEDID" "false"
# _ _ _ Option _ _ _ _ _"DigitalVibrance" "0"
_
EndSection

[...]

As you can see I'm using the internal AGP, but this hang happens with the agpgart module loaded (and with NvAGP "2") too. I tried to use my card in AGP-2x mode too, but still bad.

I posted a bug in XFree's bugzilla, and I got this answer:
Status -> RESOLVED
Resolution: NOTOURBUG
------- Additional Comments From agd5f@yahoo.com _2004-02-19 10:09 -------
Ask Nvidia. _You are using their binary drivers. _Unfortunately we can't support them.

What should I do? I've tried all of the combinations with the options and modules, but everytime I got this weird hang in my X. I think I'm going to break my card soon
Somebody help me please.

Thanks!

Daniel
  Reply With Quote
Old 02-20-04, 11:25 AM   #16
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

What else have you tried aside from switching between Linux AGPGART and the NVIDIA AGP GART driver? Have you tried disabling AGP? Have you tried some of the other suggestions made in similar threads on this forum?
zander is offline   Reply With Quote
Old 02-20-04, 11:52 AM   #17
LeVA
Guest
 
Posts: n/a
Default

Quote:
Originally posted by zander
What else have you tried aside from switching between Linux AGPGART and the NVIDIA AGP GART driver? Have you tried disabling AGP? Have you tried some of the other suggestions made in similar threads on this forum?
Here are the combinations I've tried:


1.:
AGP-Mode: 4x
XF86Config: NvAGP "1"
Kernel: NONE
NVIDIA Driver (a): NVreg_EnableAGPFW = 0;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 0;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 1; (0=enable; 1=disable !!!)

2.:
AGP-Mode: 4x
XF86Config: NvAGP "2"
Kernel: agpgart + intel-agp
NVIDIA Driver (a): NVreg_EnableAGPFW = 0;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 0;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 1; (0=enable; 1=disable !!!)

3.:
AGP-Mode: 4x
XF86Config: NvAGP "2"
Kernel: agpgart + intel-agp
NVIDIA Driver (a): NVreg_EnableAGPFW = 0;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 0;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 0; (0=enable; 1=disable !!!)

4.:
AGP-Mode: 4x
XF86Config: NvAGP "1"
Kernel: NONE
NVIDIA Driver (a): NVreg_EnableAGPFW = 1;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 0;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 1; (0=enable; 1=disable !!!)

5.:
AGP-Mode: 4x
XF86Config: NvAGP "1"
Kernel: NONE
NVIDIA Driver (a): NVreg_EnableAGPFW = 1;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 1;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 1; (0=enable; 1=disable !!!)

6.:
AGP-Mode: 4x
XF86Config: NvAGP "1"
Kernel: NONE
NVIDIA Driver (a): NVreg_EnableAGPFW = 1;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 1;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 0; (0=enable; 1=disable !!!)

7.:
AGP-Mode: 2x
XF86Config: NvAGP "1"
Kernel: NONE
NVIDIA Driver (a): NVreg_EnableAGPFW = 0;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 0;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 1; (0=enable; 1=disable !!!)

8.:
AGP-Mode: 2x
XF86Config: NvAGP "1"
Kernel: NONE
NVIDIA Driver (a): NVreg_EnableAGPFW = 0;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 0;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 0; (0=enable; 1=disable !!!)

9.:
AGP-Mode: 2x
XF86Config: NvAGP "2"
Kernel: agpgart + intel-agp
NVIDIA Driver (a): NVreg_EnableAGPFW = 0;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 0;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 1; (0=enable; 1=disable !!!)

10.:
AGP-Mode: 2x
XF86Config: NvAGP "2"
Kernel: agpgart + intel-agp
NVIDIA Driver (a): NVreg_EnableAGPFW = 0;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 0;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 0; (0=enable; 1=disable !!!)

10.:
AGP-Mode: 2x
XF86Config: NvAGP "2"
Kernel: agpgart + intel-agp
NVIDIA Driver (a): NVreg_EnableAGPFW = 1;
NVIDIA Driver (b): NVreg_EnableAGPSBA = 1;
NVIDIA Driver (c): NVreg_UpdateKernelAGP = 0; (0=enable; 1=disable !!!)

I know this is a long list, but I made a "diary" for this driver issue, and I wrote every change I made to it.
X has crashed (hanged) with all of the combinations above...
Now I *really* don't know what should I do...

Daniel
  Reply With Quote
Old 02-20-04, 11:57 AM   #18
LeVA
Guest
 
Posts: n/a
Default

btw, I didn't tried to disable AGP (if this means that I set the NvAGP to "0"). But why would I do that? Then all of my games would lack of speed, and I bought this card because I wanted to play under linux at last.
  Reply With Quote
Old 02-20-04, 12:10 PM   #19
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

When you're experiencing stability problems, it's a bad idea to enable options that are known to destabilize otherwise reliable systems; don't disable NVreg_UpdateKernelAGP and leave NVreg_EnableAGPFW as well as NVreg_EnableAGPFW disabled. You may not need to disable AGP support permanently, but doing so temporarily will allow you to determine if the problem is AGP related or not. If it was and you had to disable AGP support permanently (unlikely, since you're using an Intel chipset, but entirely possible), you'd find that a slow machine is still faster than a hard locked machine. If it's not AGP related, there are other common error sources worth investigating (see similar threads).
zander is offline   Reply With Quote
Old 02-20-04, 10:53 PM   #20
ByteEnable
Registered User
 
Join Date: Jun 2003
Posts: 24
Default

LeVA:

I've experienced the same issue for about a year now. Some Nvidia drivers are worse than others in the frequency. Sometimes it happens when all my ram is used up (most frequent method for X to hang at 99%), or sometimes, just bam. I have to telnet in and do a /sbin/init 6 to restart. I've restarted X before but it usually craters soon there after, locking up the whole machine, so to save myself aggravation, I just reboot.

Nobody in OpenSource will even debug the issues with NVidia drivers. RedHat just bit buckets all the bugzilla reports into one and marks yours as a duplicate. Can you blame them? Its very hard to debug without the source, however, it is possible.

I wish they would fix this problem too. Sometimes I think I have it licked, then bam, it happens. Sometimes it takes days.

Byte
ByteEnable is offline   Reply With Quote

Old 02-22-04, 04:30 AM   #21
LeVA
Guest
 
Posts: n/a
Default

"I've experienced the same issue for about a year now"

OMG a year?!? And you never wanted to change you mainboard or your video card? Maybe an other configuration would be good. These hangs are very rare problems (fortunately?! ), and don't happen to all the nvidia users. Maybe I'll just buy a new mainboard or a video card...
  Reply With Quote
Old 02-23-04, 12:58 PM   #22
LeVA
Guest
 
Posts: n/a
Default

zander:

I tried to set NvAGP to 0.
Now I'm running this configuration:

kernel .config:
# CONFIG_AGP is not set

$ cat /proc/driver/nvidia/agp/status
Status: Disabled

$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86 NVIDIA Kernel Module 1.0-5336

$ cat /etc/X11/XF86Config-4 | grep Nv
Option "NvAGP" "0"

And guess what, X still "hangs" (after a while eats 100% of cpu resource).
I've tried to set these boot parameters:
pci=noapci noacpi pci=biosirq
But those didn't help.

Now I'm totally lost...

Daniel
  Reply With Quote
Old 03-01-04, 03:19 AM   #23
LeVA
Guest
 
Posts: n/a
Default

Hi !

Oh yeah, I've figured out what is the problem with my machine. ~three days ago I asked my friend to exchange cards; he gave me a GF4-MX460, and I gave him my FX5200 (pretty good business huh? ) He uses redmond, so I could finally test that if it is wrong only under linux.
And guess what, now my uptime is 3d 19:49 now with that good old MX460 and with agpgart (!!! not with nvidia's internal agp), and with the latest 1.0-5336 driver. So I will bring my card back to the store (dear innovision, they gave me 2 years of warranty .

Daniel
  Reply With Quote
Old 03-01-04, 03:54 AM   #24
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

I noticed it only hangs the desktop with the 5336 driver and kde 3.2(easy to get out of) I find by using the 4620 driver it dont do it, have any of you tried the 4620 driver?
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 08:30 PM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM

All times are GMT -5. The time now is 02:20 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.