Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-21-04, 07:33 AM   #1
Virtex
Registered User
 
Join Date: Feb 2004
Posts: 15
Default Xlib error when running glxgears

I just install Mandrake because I couldn't get Fedora to run the new nvidia drivers under x windows. Got the drivers installed and I can get into windows, but this is the error I'm getting while trying to run glxgears:

$ glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
$

anyone have an idea what the problem could be and how I could fix it?
Virtex is offline   Reply With Quote
Old 02-21-04, 08:07 AM   #2
coroner
Registered User
 
Join Date: Feb 2004
Posts: 17
Default

if you have successfully installed the nvidia-drivers edit your /etc/X11/XF86Config then and put "Load glx" into the modules-section... be sure to comment out lines containing dri and GLcore
coroner is offline   Reply With Quote
Old 02-21-04, 08:17 AM   #3
Virtex
Registered User
 
Join Date: Feb 2004
Posts: 15
Default

Done that.
Attached Files
File Type: log xf86.log (14.6 KB, 109 views)
Virtex is offline   Reply With Quote
Old 02-21-04, 08:21 AM   #4
coroner
Registered User
 
Join Date: Feb 2004
Posts: 17
Default

and is it working? could you post the file /var/log/XFree86.0.log here too if its not?
coroner is offline   Reply With Quote
Old 02-21-04, 08:42 AM   #5
Virtex
Registered User
 
Join Date: Feb 2004
Posts: 15
Default

Nope it is still not working same error. Here are the files you asked for there are 3 different ones so I'm posting them all.
Attached Files
File Type: log xfree86.0.log (27.7 KB, 113 views)
Virtex is offline   Reply With Quote
Old 02-21-04, 08:44 AM   #6
Virtex
Registered User
 
Join Date: Feb 2004
Posts: 15
Default

2
Attached Files
File Type: log xfree86.0.old.log (27.7 KB, 94 views)
Virtex is offline   Reply With Quote
Old 02-21-04, 08:45 AM   #7
Virtex
Registered User
 
Join Date: Feb 2004
Posts: 15
Default

3
Attached Files
File Type: log xfree86.9.log (27.9 KB, 100 views)
Virtex is offline   Reply With Quote
Old 02-21-04, 08:50 AM   #8
coroner
Registered User
 
Join Date: Feb 2004
Posts: 17
Default

i dont know for which reason, but instead of the nvidia-supplied driver the standard nv-driver of X11 is used... could you look into /etc/X11 and tell, if there are more than one file starting with XF86Config? if this is true then copy the one config file you first sent here to /etc/X11/XF86Config and try again...
coroner is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Star Wars 1313 running on Unreal Engine 3 on PC at E3, will be linear and light on Je News Latest Tech And Game Headlines 0 06-08-12 05:20 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM

All times are GMT -5. The time now is 03:10 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.