Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-22-04, 02:45 PM   #1
tecate428766
Registered User
 
Join Date: Feb 2004
Posts: 36
Default how do i install the nvidia drivers on suse 9.0??

please someone HELP. i've only been using linux for about 2 weeks now. the only reason i am trying to install nvidia drivers is because i want to play unrealtournament on it. where am i supposed to save the drivers at? and how do i do everything els? im so lost. will someone please tell me what to do so i can have some fun on this machine??!?!
tecate428766 is offline   Reply With Quote
Old 02-22-04, 05:35 PM   #2
prplxd
Registered User
 
Join Date: Feb 2004
Posts: 42
Question ??

You can pretty much save the download anywhere you want.

I downloaded mine to: /usr/local/src
from there, I ran sh <nvidia file name.run>, and it installed the drivers.

It will also create an ~/Nvidia directory with all its stuff.
I recommend you read the Nvidia README first.
prplxd is offline   Reply With Quote
Old 02-22-04, 05:53 PM   #3
andyrock
Registered User
 
andyrock's Avatar
 
Join Date: Jan 2004
Location: EU / Portugal
Posts: 110
Default

boot with "linux 3" command at lilo prompt (this will take you to command line, with no X)

login as root

run your downloaded file with sh NVIDIA-XYZ.run

run sax2 with: sax2 -m 0=nvidia (0 is a number)

init 5

enjoy :-)
__________________
AndyRock

--
1. Toshiba M30-742 | Centrino/Pentium-M 1700mhz | Geforce FX 5200Go
2. Celeron (Tualatin) 1400mhz | Geforce Ti 4800SE
andyrock is offline   Reply With Quote
Old 02-22-04, 08:16 PM   #4
tecate428766
Registered User
 
Join Date: Feb 2004
Posts: 36
Default

thanks, but somehow i managed to completely avoid all of that by accident. i have no idea how, but this is waht i did.
i downloaded the drivers on a windows machine(it has a cdrw drive) put it on a cdrw disk. mounted that drive. then, it started to install. (wouldnt work while on the HDD. so then it came up with a message saying that the "file ALREADY exists on the system:continue and overwrite" so, i tabbed over to yes and, started to install, then came the error of not having kernel source installed. so i had to exit. out of frustration, i rebooted so i could start from a freash system load. and, oddly enough, the nvidia logo popped up on screen?? crazy..so i played the gear screen saver, and it was playing around 95fps in fullscreen mode. please dont ask me what i did lol.
Anyway, before i "tried" to install the nvidia drivers, i ran sax2 before anything els i did(before i even read about needing drivers and whatever) looked up the cross refference of the board 0x0322 is my model(geforce fx 5200 agp with 128MB ddr ram. its crazy how its working, im not sure if its fully 100% sure that its working correctly, but im assuming that it is. i'll install ut2003 and see if it runs fine. if i it does, i guess its safe to say that it works correctly. anyway, uhm..if anyone els reads this, i guess try doing what i did. not that i planned any of it, or know what im doing.
tecate428766 is offline   Reply With Quote
Old 02-23-04, 05:41 AM   #5
andyrock
Registered User
 
andyrock's Avatar
 
Join Date: Jan 2004
Location: EU / Portugal
Posts: 110
Default

maybe you've installed it using yast online update
__________________
AndyRock

--
1. Toshiba M30-742 | Centrino/Pentium-M 1700mhz | Geforce FX 5200Go
2. Celeron (Tualatin) 1400mhz | Geforce Ti 4800SE
andyrock is offline   Reply With Quote
Old 02-23-04, 04:09 PM   #6
tecate428766
Registered User
 
Join Date: Feb 2004
Posts: 36
Default install error??!?! AHHH

well, i tried YaST to install it from YOU. but, and error occured download. i think it says ftp site not responding or soemthing. anyway, i finally got the installer to run(put it on cdrw and went from there). the installer came up and worked fine, untill it said this;"ERROR: Unable to determine the NVIDIA kernel module filename" Then below that it reads "ake: *** [select_makefile] Error 1. that is after it tried to compile its own kernal interface. im not sure what to do about this. i couldnt find any help on README files or anything els that i've found. HELP AGAIN PLEASE!!! is it because im running it from the cdrom drive?



-
IBM xSeries eServer, 2.0 Celeron. 128MB DDR2100 CL2.5 RAM. not sure what chipset, but it is INTEL i beleive. PNY GeForceFX 5200 AGP 128. Samsung CDdrive(40x i think).40GB IBM HDD, Boadcom NetExtreme GigaNet interface. Samsung 955DF monitor. Also has integrated ATI RageXL(works, but not configured for multiple monitor support). SuSE 9.0 PRO(i586)- kernel 2.4.21-192-Default.
tecate428766 is offline   Reply With Quote
Old 02-23-04, 05:02 PM   #7
andyrock
Registered User
 
andyrock's Avatar
 
Join Date: Jan 2004
Location: EU / Portugal
Posts: 110
Default

Install kernel source, update it with YOU, and as root do:

cd /usr/src/linux
make cloneconfig
make dep

log of

crtl alt F1

log in as root
init 3
now you can run the installer
after you finished run:
sax2 -m 0=nvidia
init 5
__________________
AndyRock

--
1. Toshiba M30-742 | Centrino/Pentium-M 1700mhz | Geforce FX 5200Go
2. Celeron (Tualatin) 1400mhz | Geforce Ti 4800SE
andyrock is offline   Reply With Quote
Old 02-23-04, 05:25 PM   #8
tecate428766
Registered User
 
Join Date: Feb 2004
Posts: 36
Default ..

well, i just did that last step, it came up with a question. "plug In CPU Schedulers (CONFIG_PLUGIN_SCHED) [N/y/?] (NEW)
So,....im lost from this point...shuold i type Y, N? thanks
PS, thanks alot people for helping me out.
tecate428766 is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 01:54 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 10:31 PM
Suse 8.1 and Nvidia drivers tombraider500 NVIDIA Linux 4 10-06-02 12:19 PM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 06:32 PM
nvidia drivers and slackware 9.0 pbrennen NVIDIA Linux 5 09-16-02 07:57 AM

All times are GMT -5. The time now is 07:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.