Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-22-04, 04:08 PM   #1
Kevinito
Registered User
 
Join Date: Feb 2004
Posts: 3
Default Command Line on SuSe

I am currently running Suse Linux version 8.2 and I am having trouble installing the graphics drivers for my GeForce 2 GTS. I login via super user and type sh NVIDIA . . . and the executable says to shut down X. I guess the question is this . . . how do I boot up Linux just in command line without the nice gui?

Many thanks for your response,

Kevin
Kevinito is offline   Reply With Quote
Old 02-22-04, 04:50 PM   #2
andyrock
Registered User
 
andyrock's Avatar
 
Join Date: Jan 2004
Location: EU / Portugal
Posts: 110
Default

you may boot with "linux 3" at lilo prompt, or boot as usual, logout X and do as root:

/etc/rc.d/xdm stop

now you can install your driver ;-)
__________________
AndyRock

--
1. Toshiba M30-742 | Centrino/Pentium-M 1700mhz | Geforce FX 5200Go
2. Celeron (Tualatin) 1400mhz | Geforce Ti 4800SE
andyrock is offline   Reply With Quote
Old 02-22-04, 09:05 PM   #3
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

All you do is Ctrl, Alt, F3, login as root, type init 3, login as root then do it. After you finished just type init 5 and you will be at the GUI login screen.

You should only need to reboot only if you install a new kernel.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 02-23-04, 08:00 PM   #4
Kevinito
Registered User
 
Join Date: Feb 2004
Posts: 3
Default

SuLinUX and AndyRock,

I have attempted both of your suggestions and the SuSE command prompt does not recognize init 3. It nags back "command not found", or something of that nature. I even tried /etc/rc.d/xdm stop and it says program or command not found. I do appreciate the prompt replies, but to no avail.

Many thanks!

Kevin
Kevinito is offline   Reply With Quote
Old 02-24-04, 03:40 AM   #5
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

Quote:
Originally posted by Kevinito
SuLinUX and AndyRock,

I have attempted both of your suggestions and the SuSE command prompt does not recognize init 3. It nags back "command not found", or something of that nature. I even tried /etc/rc.d/xdm stop and it says program or command not found. I do appreciate the prompt replies, but to no avail.

Many thanks!

Kevin
Are you typing init 3 as root because I find it hard to believe that it's not working.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 02-24-04, 05:50 AM   #6
Kevinito
Registered User
 
Join Date: Feb 2004
Posts: 3
Default

This is exactly what I do. I turn on the computer, X is loaded. I then press ctrl, alt, f3 and it gets me to the command line. I then type su -p and type the superuser password. I then type init 3 and it says "Command not found" or something of that nature. Thanks for the assistance!

-Kevin
Kevinito is offline   Reply With Quote
Old 02-24-04, 05:57 AM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

Try it with /sbin/init 3 instead; you might also find this document helpful: ftp://ftp.suse.com/pub/suse/i386/sup...nstaller-HOWTO.
zander is offline   Reply With Quote
Old 02-24-04, 06:39 AM   #8
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

Whats with the su -p option?, it's just root and then password. you should only use the su command when your user.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 12:54 AM
My SuSE 8.0 just totally BROKE. Help please!!! sephiroth762 NVIDIA Linux 6 10-09-02 02:30 PM
Suse 8.1 and Nvidia drivers tombraider500 NVIDIA Linux 4 10-06-02 11:19 AM
Newbie - Compiling my own for SuSe 8.0 jocephus19 NVIDIA Linux 5 09-01-02 09:38 PM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 12:31 PM

All times are GMT -5. The time now is 01:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.