Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-15-04, 05:19 PM   #1
DaryX
GAINWARD GeForge 4 TI4200
 
Join Date: Feb 2004
Location: ITALY (PADOVA)
Posts: 7
Exclamation Ti 4200 - RedHat 9 ->X-server crash at startup

Problem: RedHat 9 ->X-server crash at startup
After installing the driver NVIDIA-Linux-x86-1.0-5336-pkg1.run, i have configured my XF86config file, I have start the x-server and crashed at the begging before the loading of the nvidia logo.
Note: in the log there aren't any errors there's only one warning but in my opinion isn't significant.

My config:
SOFTWARE...
- Red Hat linux 9 (Shrike)
- Kernel version: 2.4.20-8 custom
- glib-1.2.10-10
- gcc (GCC) 3.2.2 20030222 (Red Hat Linux 3.2.2-5)
HARDWARE...
- Gainward GeForce 4 TI 4200 64Mb DDR
- Bios rev:
- Monitor: Samsung Syncmaster 152 BM (LCD)
- ATHLON XP 1700
- Motherboard: ASUS A7V266 (Chipset KT266)

I think that the crash is due to:
* glib library.
* AGP.

Please contact me as soon as possible.
TQ

file output:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun Feb 15 15:04:14 2004

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel source path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel source path: '/lib/modules/2.4.20-8custom/build'
-> Performing cc_version_check with CC="cc".
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f nv.o os-agp.o os-interface.o os-registry.o nv-linux.o nv_compiler.h *
.d NVdriver nvidia.o
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.4.20-8custom/
build'...
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > nv_compiler.h
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wno-multichar -Werror -O -MD -D__KERNEL__ -DMO
DULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KE
RNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=5
336 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -DREMAP_PAGE_
RANGE_5 -I. -I/lib/modules/2.4.20-8custom/build/include -Wno-cast-qual -Wno
-error nv.c
In file included from /lib/modules/2.4.20-8custom/build/include/linux/vmallo
c.h:8,
from nv-linux.h:62,
from nv.c:14:
/lib/modules/2.4.20-8custom/build/include/linux/highmem.h: In function `bh_k
map':
/lib/modules/2.4.20-8custom/build/include/linux/highmem.h:20: warning: point
er of type `void *' used in arithmetic
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wno-multichar -Werror -O -MD -D__KERNEL__ -DMO
DULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KE
RNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=5
336 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -DREMAP_PAGE_
RANGE_5 -I. -I/lib/modules/2.4.20-8custom/build/include -Wno-cast-qual -Wno
-error os-agp.c
In file included from /lib/modules/2.4.20-8custom/build/include/linux/vmallo
c.h:8,
from nv-linux.h:62,
from os-agp.c:24:
/lib/modules/2.4.20-8custom/build/include/linux/highmem.h: In function `bh_k
map':
/lib/modules/2.4.20-8custom/build/include/linux/highmem.h:20: warning: point
er of type `void *' used in arithmetic
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wno-multichar -Werror -O -MD -D__KERNEL__ -DMO
DULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KE
RNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=5
336 -DNV_UNIX -DNV_LINUX -D
NV_INT64_OK -DNVCPU_X86 -DREMAP_PAGE_RANGE_5 -I. -I/lib/modules/2.4.
20-8custom/build/include -Wno-cast-qual -Wno-error os-interface.c
In file included from /lib/modules/2.4.20-8custom/build/include/linux/vmallo
c.h:8,
from nv-linux.h:62,
from os-interface.c:26:
/lib/modules/2.4.20-8custom/build/include/linux/highmem.h: In function `bh_k
map':
/lib/modules/2.4.20-8custom/build/include/linux/highmem.h:20: warning: point
er of type `void *' used in arithmetic
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wno-multichar -Werror -O -MD -D__KERNEL__ -DMO
DULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KE
RNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=5
336 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -DREMAP_PAGE_
RANGE_5 -I. -I/lib/modules/2.4.20-8custom/build/include -Wno-cast-qual -Wno
-error os-registry.c
In file included from /lib/modules/2.4.20-8custom/build/include/linux/vmallo
c.h:8,
from nv-linux.h:62,
from os-registry.c:14:
/lib/modules/2.4.20-8custom/build/include/linux/highmem.h: In function `bh_k
map':
/lib/modules/2.4.20-8custom/build/include/linux/highmem.h:20: warning: point
er of type `void *' used in arithmetic
ld -r -o nv-linux.o nv.o os-agp.o os-interface.o os-registry.o
ld -r -o nvidia.o nv-linux.o nv-kernel.o
-> done.
-> Kernel module compilation complete.
-> Installing both new and classic TLS OpenGL libraries (but only new XFree86
TLS libraries.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-5336):
executing: './usr/src/nv/makedevices.sh'...
executing: '/sbin/ldconfig'...
executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Sanity check passed.
-> Shared memory test passed.
-> Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
(version: 1.0-5336) is now complete. Please update your XF86Config file as
appropriate; see the file /usr/share/doc/NVIDIA_GLX-1.0/README for details.


My XF86config file:
XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Generic Non-Interlaced SVGA, 1024x768 @ 60 Hz, 800x600 @ 72 Hz"
HorizSync 31.5 - 48.5
VertRefresh 50.0 - 70.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
VideoRam 65536
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
Attached Files
File Type: log xfree86.0.log (25.8 KB, 120 views)
DaryX is offline   Reply With Quote
Old 02-15-04, 08:39 PM   #2
Nospoonzz
Registered User
 
Join Date: Feb 2004
Location: Somewhere in Linuxville
Posts: 11
Default

Try this. This worked for me when I ran RED HAT 9.0
Go to consol. <quit the X server>
<you must be root or su>
Go to were you put the latest NVIDIA 5336 driver.< cd /root/bla/bla>
once there. type; sh NVIDIA-Linux-x86-1.0-5336-pkg1.run --add-this-kernel

After that is done type;
sh NVIDIA-Linux-x86-1.0-5336-pkg1-custom.run

This should build and install a driver for your kernel.

Make sure to edit you X11 config. file per Nvidia's readme file.
replace "nv" with "nvidia" under the driver section.
make sure to comment out < # > the dri.
after this save it and re-start X.

To remove the MESA libs. that may be causing a problem.<they did for me>.
At a shell command type;

rpm -e --nodeps XFree86-Mesa-libGL

You should be good to go. Let me know if this helps.
Nospoonzz is offline   Reply With Quote
Old 02-16-04, 05:27 AM   #3
DaryX
GAINWARD GeForge 4 TI4200
 
Join Date: Feb 2004
Location: ITALY (PADOVA)
Posts: 7
Unhappy No the problem isn't solved! But...

First TQ 4 your interest 4 my trouble.
I've installed the custom driver with --add-this-kernel (but it isn't necessary the wonderfull installer make it 4 U).
Then I've configured my XF86config and then I've deleted the MESA GL library rpm.
As before happened (before the removing of MESA lib) the first time I run x-server with the accelerated driver I'm able to see the nVIDIA logo and than x-server crash. The other times I tried to start X-server it crashed before the nVIDIA logo. I've saved the first log, give it a look and tell me if U have some ideas (I hope so).
TQ

Could U send me the log file of your uncrashable x-server?
Attached Files
File Type: txt logs&configs.txt (32.0 KB, 118 views)
DaryX is offline   Reply With Quote
Old 02-21-04, 12:56 AM   #4
Nospoonzz
Registered User
 
Join Date: Feb 2004
Location: Somewhere in Linuxville
Posts: 11
Smile Here it is >>>>>>>>>>>>

Sorry, I have been so, so, busy with work. I almost forgot.

Here it is.................................. Good luck my friend..


# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
#Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1280x1024"
HorizSync 31.5 - 67.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 Ti4400"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
Nospoonzz is offline   Reply With Quote
Old 03-01-04, 08:29 PM   #5
cyphereza
Registered User
 
cyphereza's Avatar
 
Join Date: Mar 2004
Location: 54200, KL, MY
Posts: 3
Send a message via Yahoo to cyphereza
Default

uhh, can anyone tell me whether the config file works or not? thanks!
__________________
CEO, Infamous Network Inc.
cyphereza is offline   Reply With Quote
Old 03-03-04, 01:56 AM   #6
Nospoonzz
Registered User
 
Join Date: Feb 2004
Location: Somewhere in Linuxville
Posts: 11
Smile

Uhhh, sure it works.
Nospoonzz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.