Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-19-03, 01:26 PM   #253
numike
Registered User
 
Join Date: Mar 2003
Location: SF Bay Area
Posts: 3
Default Problem with kernel rhp

Hi, I am a somewhat a novice so any help is appriciated. I upgreaded my kernel from 2.4.18-10 which was working with NVIDIA driver and I got startx to work after a few weeks. Now my kernel is 2.4.18-27.7.x because I used the update agent to install the RPM's

When I boot from my floppy 27.7.x the screen is blank and when I try to startx from a windows session it fails. Looking under the the boot libs I see the NVdriver

1959668 1172 -r--r--r-- 1 root root 1194920 Aug 27 2002 /lib/modules/2.4.18-10/kernel/drivers/video/NVdriver

I do not want to compile my kernel (chicken). I tried to reinstall the NVIDIA rhp while running 27.7.x kernel and it failed. Any ideas how to install the driver in the new kernel?

I rebooted with 2.4.18-10 and everything seems to be okay. There were error messages on the new kernel. I am looking into those.

This is my first post on this site. thanks ahead of time for any help.

Michael
numike is offline   Reply With Quote
Old 03-19-03, 03:40 PM   #254
Brandon77
Registered User
 
Join Date: Mar 2003
Posts: 2
Default Thanks for the info

Thanx anyway for that great info but i tried something else and dam it worked.
============>For Micheal
Hey r u using RH8?If you are make sure you downloaded the correct driver.By tihe way what kind of card do you have or using?I think i had the same problem ,but you gotta help me with these questions before i can aid you.

CYA. Brandon77
Brandon77 is offline   Reply With Quote
Old 03-19-03, 10:41 PM   #255
numike
Registered User
 
Join Date: Mar 2003
Location: SF Bay Area
Posts: 3
Default

Brandon77 - Thanks for you offer to help.

I am using RH 7.3 Kernel 2.4.18-10 which works and just rpm to 2.4.18-27.7.x which does not work (fix security hole).

AMD Athlon CPU 1.8 GHZ - Chipset nVidia 220D North Bridge.

packages installed last year (I could not find a package for 2.4.18-27.7.x on wed site yesterday).

[root@numike root]# rpm -qa | grep NVID
NVIDIA_GLX-1.0-3123
NVIDIA_kernel-1.0-3123.rh73up_2.4.18_10

XFree86-xfs-4.2.0-8

I had a lot of trouble getting XFree86 to work when I installed 7.3 last year (got hacked with 7.2) with the card but it work with 2.4.18-10 pretty well using 800x600. My GEM monitor can do more.

So I have a new kernel and no driver in the boot libs. How do I put a NVdriver there is my novice question. Right question?

Michael
numike is offline   Reply With Quote
Old 03-20-03, 07:30 PM   #256
mgrenier
Registered User
 
Join Date: Oct 2002
Posts: 3
Default rh8.0 HP Pavilion e-gforce 4 mx 440 se AGP

I've been pulling my hair out on this one.

I have an HP pavilion pentium 3, with a e-gforce 4 mx 440 se agp video card.

I downloaded the drivers according to NVchoose.sh

rpm -ivh NVIDIA_kernel-1.0-1491.i686.rpm
rpm -ivh NVIDIA_GLX-1.0-1491.i386.rpm

made the changes to FX86Config.

reboot

startx

I get the NVIDIA splash page, but then X hangs. I think the problem is in the GL libs
but not sure.

I've spent 2 weeks on this one. Could anyone point me in the right direction
mgrenier is offline   Reply With Quote
Old 03-20-03, 09:56 PM   #257
troystar
Registered User
 
Join Date: Mar 2003
Posts: 1
Default buildmeister error again - Dual Processor Machine

I have RH 8.0 installed, on a dual processor system. When I initially installed the NVIDIA drivers, I had no problems at all. I downdloaded and installed the SMB kernel packages, changed my XF11CONFIG file, and all worked great!


Then I upgraded to LINUX kernel-smb-2.4.18-27.8.0. When I rebooted, the driver no longer worked. So I did my research, and learnbed I would have to compile the NVIDIA driver with the command "rpmbuild --rebuild NVIDIA_kernel-1.0-4191.src.rpm" But each time I do, I get an error message:

install: cannot stat `nvidia.o': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.32146 (%install)

RPM build errors:
user buildmeister does not exist - using root
group buildmeister does not exist - using root
user buildmeister does not exist - using root
group buildmeister does not exist - using root
Bad exit status from /var/tmp/rpm-tmp.32146 (%install)

I have seen many other people in this forum withg the same error message, but NOBODY has given a sollution that works. I have the necessary tools installed, including the kernel development packages. I also upgraded EVERYTHING using the RedHat Network, so I know I am using the latest binaries & SRC packages. What should I do?
troystar is offline   Reply With Quote
Old 03-27-03, 12:28 PM   #258
advait
Registered User
 
Join Date: Mar 2003
Location: Mumbai
Posts: 4
Unhappy

Hello every1. I'm trying hard to get my linux working..I'm a novice though, I wud appreciate any help

I have installed Redhat 8.0, but I'm unable to install the display drivers.

NVIDIA_nforce-1.0-0248.rh80up_2.4.18_17.athlon.rpm got installed without any error messages.

I downloaded the following files from nVidia's website:
NVIDIA_kernel-1.0-4180.tar
NVIDIA_GLX-1.0-4180.tar

Following is the what I get when I type "make install" after extracting the contents of NVIDIA_kernel-1.0-4180.tar

cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -mcmodel=kernel -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=4180 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNV_64_BITS -DNVCPU_X86_64 -I. -I/lib/modules/2.4.18-24.8.0/build/include -Wno-cast-qual nv.c
cc1: code model `kernel' not supported in the 32 bit mode
In file included from nv-linux.h:83,
from nv.c:14:
/lib/modules/2.4.18-24.8.0/build/include/linux/highmem.h: In function `bh_kmap':
/lib/modules/2.4.18-24.8.0/build/include/linux/highmem.h:20: warning: pointer of
type `void *' used in arithmatic
nv.c: In function `nv_agp_translate_address':
nv.c:2756: warning: cast from pointer to integer of different size
make: *** [nv.o] Error 1

I would appreciate anyyyy help.

My System configuration is
Athlon 1700+ processor
A7N266-VM with nForce Chipset (GeForce2 onboard) motherboard
Samsung SyncMaster 17" monitor
advait is offline   Reply With Quote
Old 03-27-03, 02:05 PM   #259
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
Originally posted by advait
NVIDIA_kernel-1.0-4180.tar
NVIDIA_GLX-1.0-4180.tar
Wrong drivers. 4180 is for AMD's Opterons, which aren't even out yet. Use 4191, the "IA32" driver.

Quote:
Originally posted by troystar
install: cannot stat `nvidia.o': No such file or directory
Post some of the error messages that were printed before that one. The reason nvidia.o can't be stat'ed is that it was never created, and there's a reason that nvidia.o never got created. That reason is in the previous error messages.

Quote:
Originall posted by numike
So I have a new kernel and no driver in the boot libs. How do I put a NVdriver there is my novice question. Right question?
Yep. You install the kernel source corresponding (version-wise) to your running kernel, make sure that that kernel is still running, and compile the NVIDIA_kernel package. Using the .tar.gz drivers would be easier in this case, since that way, you don't have to worry about NVIDIA_GLX requiring the (old) NVIDIA_kernel to be installed. If you rebuild the .src.rpm, then you'll have to remove the old GLX, remove the old kernel, install the new kernel, and reinstall the new GLX.

Before you start the compile, make sure that there's a /lib/modules/<current kernel version>/build symlink that points at the base of the kernel source for whatever kernel you're currently running.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 03-28-03, 12:26 PM   #260
advait
Registered User
 
Join Date: Mar 2003
Location: Mumbai
Posts: 4
Cool thnx a lot

Thanks a lot, I will try those the "IA32" driver 4191.
advait is offline   Reply With Quote

Old 03-28-03, 12:46 PM   #261
numike
Registered User
 
Join Date: Mar 2003
Location: SF Bay Area
Posts: 3
Default NVIDIA Driver for new Kernel

Thanks BWKAZ for your assistance.

Yep. You install the kernel source corresponding (version-wise) to ...
numike is offline   Reply With Quote
Old 04-04-03, 02:46 PM   #262
advait
Registered User
 
Join Date: Mar 2003
Location: Mumbai
Posts: 4
Default

Hey bwkaz, numike thanks. I tried the driver 4191, but it still won't work. I think i've figured out the problem.. maybe!

Ok, I get a single message about "*** unresolved symbols in nvidia.o"

The version of driver 4191 is 2.4.18-18.8.0 and that of the kernel in my system is kernel-2.4.18-14.i686.rpm. Is that the reason why I get such an error?

If this version of the driver (in 4191) is the reason of error, will the new IA32 driver (4349) resolve the problem?

Thanks for helping
advait is offline   Reply With Quote
Old 04-04-03, 02:47 PM   #263
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

advait: yes, that's the reason you're seeing unresolved symbols. Please try the 1.0-4349 installer.

Thanks!

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-05-03, 01:10 PM   #264
advait
Registered User
 
Join Date: Mar 2003
Location: Mumbai
Posts: 4
Default

Alright I am going to try the 4349 driver. Its kinda difficult for me to download it; thanks to my bad internet [dial-up] connection.

Do you really know whether it will work, in spite of a different version of the kernel (I've made sure that the kernel-source package and the installed kernel - both are of the same version)?
advait is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Showcases GPU Breakthroughs at IBC 2012 News Latest Tech And Game Headlines 0 09-07-12 10:10 AM
The Nvidia Forums Are Still Not Available, Finally We Know Why News Latest Tech And Game Headlines 0 07-14-12 05:10 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 03:59 AM
Redhat 8.0, no rpm, can't compile. Ironphil NVIDIA Linux 6 10-02-02 03:13 PM

All times are GMT -5. The time now is 07:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.