Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-18-02, 10:41 PM   #85
lucianpoe
Registered User
 
Join Date: Oct 2002
Location: Detroit area
Posts: 13
Send a message via Yahoo to lucianpoe
Default

Quote:
Originally posted by klunker23
# File generated by anaconda.
#

Section "ServerLayout"
#
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Option "AutoRepeat" "500 5"
# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
#Option "XkbOptions" ""
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us" #Option "XkbVariant" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 31.5 - 48.5
VertRefresh 60.0 - 75.0
Option "dpms"
EndSection

Section "Device"
# no known options
#BusID
Identifier "NVIDIA GeForce 4 (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

----------------------------

Thats my XF86Config file... That _SHOULD_ work.. But when i start X it just switches off the monitor, which then displays "NO SIGNAL!"

Cheers

Klunk.

See the last seection where it says
Section "DRI"
Mode 0666
EndSection"

???

Comment it out (add a # in front of each line); save the changes, then reboot.

--Lucian
lucianpoe is offline   Reply With Quote
Old 10-18-02, 11:13 PM   #86
STEEL1
Registered User
 
Join Date: Oct 2002
Posts: 15
Default Good XF86Config file

folks;

Here is my XF86Config file. just to answer the few questions ya ppl have.

1> Notice the commented line
# Load "dri"

2> and the driver loading section
Section "Device"
# no known options
#BusID
Identifier "NVIDIA GeForce 3 (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 3 (generic)"
BoardName "NVIDIA GeForce 3 (generic)"
EndSection

3> you dont need to comment out the load dri section in the end cause it is just not loaded ... see step 1.

Have fun...

Make sure you did choose the right monitor, compatible display settings and resolutions etc.

STEEL
3 years of linux and not a second of regret :-)
Attached Files
File Type: txt xf86config.txt (3.1 KB, 336 views)
STEEL1 is offline   Reply With Quote
Old 10-19-02, 01:03 AM   #87
STEEL1
Registered User
 
Join Date: Oct 2002
Posts: 15
Default upgrading to kernel-2.4.18-17.8.0

Redhat auto updater will update your kernel to kernel-2.4.18-17.8.0
This will stop XServer since we compiled it using the older version of the kernel kernel-2.4.18-14


Instructions to get XServer working again for linux newbies or anyone else who cares:

Step 1> To get Xserver working again we have to recompile the NVIDIA_kernel-1.0-3123 on Linux kernel kernel-2.4.18-17.8.0.
Download the following files from NVidia's site if you deleted your initial file you downloaded before. (Note that the NVIDIA_kernel is the **src.rpm** rpm file and the NVIDIA_GLX is a **rpm**):
NVIDIA_kernel-1.0-3123.src.rpm
and
NVIDIA_GLX-1.0-3123.i386.rpm

Step 2> Open /etc/inittab file and change the following line. be carefull while changing this line. This will allow linux to reboot in text multiuser mode.
Change :
id:5:initdefault: to id:3:initdefault:

Step 3> rename the previosly compiled kernel to make a backup copy. In a terminal window.
"cd /usr/src/redhat/RPMS/i386"
"mv NVIDIA_kernel-1.0-3123.i386.rpm NVIDIA_kernel-1.0-3123.i386.rpm.old"

Step 4> upgrade your kernel to kernel-2.4.18-17.8.0 and kernel-source-2.4.18-17.8.0 and hwdata using the redhat downloader. Hope you still have other dependencies installed.

Step 5> Reboot and run linux in the new kernel. It will start in the command line mode. Login as root.

Step 6> remove the previously loaded GLX and kernel files in the right order as below.

rpm -e NVIDIA_GLX-1.0-3123
rpm -e NVIDIA_kernel-1.0-3123

Step 5> on command line do a "rpmbuild --rebuild NVIDIA_kernel-1.0-3123.src.rpm" to create drivers for the RH new kernel that we have now booted the system in. (This will again create the new binary RPM for the new kernel in "/usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm")

Step 6> Installed this new (NVIDIA_kernel-1.0-3123.i386.rpm)
"rpm -ivh /usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm"

Step 7> Install the GLX (NVIDIA_GLX-1.0-3123.i386.rpm)
"rpm -ivh NVIDIA_GLX-1.0-3123.i386.rpm"

Step 8> your Xconfig file should work from before and you dont have to change anything in there.
bnow do "startx" to start XServer.

Step 9> once XServer works fine Open /etc/inittab file and change the following line again. This will allow linux to reboot in GUI mode again.
Change :
id:3:initdefault: to id:5:initdefault:

Step 10> reboot agin to make sure everything is fine and have fun

STEEL
STEEL1 is offline   Reply With Quote
Old 10-19-02, 10:44 AM   #88
klunker23
Registered User
 
Join Date: Oct 2002
Posts: 7
Default

Lucian -

That doesnt work, also, putting in the Option "ConnectedMonitor" "CRT" Doesnt work either.

I only just realised that it was using my TV OUT instead of my tft monitor.

My TFT Monitor doesnt look like it is supported by linux, its a Relisys TL450 if thats any help

Cheers

Klunk.
klunker23 is offline   Reply With Quote
Old 10-19-02, 10:08 PM   #89
RonO
Guest
 
Posts: n/a
Default Failed init

After completing all of the steps necessary to build the rpm and then install them, I modified XF86Config. After rebooting, X won't start giving me the following error message in the config log:

(EE) NVIDIA(0): Failed to initialize theNVdriver kernel module!

I've searched here for other suggestions and they all say one of three things: 1) You're using a version of the rpms compiled under a different kernel, 2) you don't have /dev/nvidia0 defined, or 3) you don't have the correct permissions for the /dev/nv* files.

To answer 2/3, here's the output of an ls -l /dev/nv*

crw-rw-rw- 1 root root 195, 0 Oct 19 15:38 /dev/nvidia0
crw-rw-rw- 1 root root 195, 1 Oct 19 15:38 /dev/nvidia1
crw-rw-rw- 1 root root 195, 2 Oct 19 15:38 /dev/nvidia2
crw-rw-rw- 1 root root 195, 3 Oct 19 15:38 /dev/nvidia3
crw-rw-rw- 1 root root 195, 255 Oct 19 15:38 /dev/nvidiactl

As for 1, since I didn't start this process until after the auto update process bumped my kernel up to 18-17.8.0 (from 18-14), I'm unsure how I could have compiled this for any other kernal but 18-17.8.0. However, I must conceed I screwed something up along the way.

Any suggestions/help would be appreciated.

Ron
  Reply With Quote
Old 10-19-02, 11:07 PM   #90
D0M1N8R
Registered User
 
Join Date: Oct 2002
Location: NE
Posts: 12
Send a message via ICQ to D0M1N8R Send a message via AIM to D0M1N8R Send a message via Yahoo to D0M1N8R
Default My installation went perfect using the .gz files

Hey folks I didnt read this thread from start and only printed the instructions out so that I could use them just incase something didnt go my way. But all went smooth and so simple.

Here is what I did.
boot in text mode (level 3)

downloaded the .gz files from nvidia

tar vxfz NVIDIA_kernel*
tar vxfz NVIDIA_GLX*

cd NVIDIA_kernel-1.0-3123
su root
make install
cd ../NVIDIA_GLX-1.0-3123
make install

pico /etc/X11/XF86Config


Get rid of DRI line in modules section
Load "dri"

change "nv" to "nvidia"

now boot in graphical mode (level 5)
in my case everything works. YaY

I noticed they did away with the XF86Config-4 file.
I like the new look. 3 thumbs up for RH who are rapidly building a bridge for the trapped windows users to cross. New trash bin is great!!! Once setup this GUI is very windows user friendly.

OK im impressed enough to go give RH some money so off I go to purchase a copy.
D0M1N8R is offline   Reply With Quote
Old 10-20-02, 09:54 AM   #91
-predator-
Guest
 
Posts: n/a
Unhappy help

i had the old kernel and everything was clear, but now, after the kernel update, everything is like it was before the update, but I cant set the resolution higher than 800x600 (i had 1024x768 before). there is the nvidia starting-screen, the driver is nvidia, no errors are shown.
plz help, im noob

i have a chaintech g4 ti4200 if thats important
-pred-
  Reply With Quote
Old 10-21-02, 01:11 AM   #92
lucianpoe
Registered User
 
Join Date: Oct 2002
Location: Detroit area
Posts: 13
Send a message via Yahoo to lucianpoe
Default

Go to RedHat's "Start Menu" -> "System Settings" -> "Display";

- in the window appeared, click on the "Advanced" tab;

- you will have two (2) things listed: the monitor on top, and the video card on the bottom;

- click the "configure" button of the monitor section;

- scroll down to Relisys, choose "Relisys RE 450" and see if this one works.

- if this doesn't work, instead of "Relisys", choose "Generic", then choose "Generic Laptop Display Panel" with the maximum resolution for your TFT (you most probably got either an 14.1" TFT or a 15" - thus either 800x600 or 1024x768 res); this will only use safe values for the horiz/vertical freq.

Let me know how it goes.

-- Lucian



Quote:
Originally posted by klunker23
Lucian -

That doesnt work, also, putting in the Option "ConnectedMonitor" "CRT" Doesnt work either.

I only just realised that it was using my TV OUT instead of my tft monitor.

My TFT Monitor doesnt look like it is supported by linux, its a Relisys TL450 if thats any help

Cheers

Klunk.
lucianpoe is offline   Reply With Quote

Old 10-21-02, 01:29 AM   #93
lucianpoe
Registered User
 
Join Date: Oct 2002
Location: Detroit area
Posts: 13
Send a message via Yahoo to lucianpoe
Default Re: Good XF86Config file

Steel1,

Not to offend, but not all of us have the XF86Config file generated by Anaconda (which is your case). Mine wasn't, and in cases like mine, there IS NO 'Load "dri"' instruction. If you look at the config file that klunker23 posted, you'll see what I'm talking about. In our case, the file had been generated by the Xserver's autoconfig utility that is invoked at boot time when the X-server cannot be started (nvidia drivers cannot be loaded/initiated due to misconfig).

-- Lucian


Quote:
Originally posted by STEEL1
folks;

Here is my XF86Config file. just to answer the few questions ya ppl have.

1> Notice the commented line
# Load "dri"

2> and the driver loading section
Section "Device"
# no known options
#BusID
Identifier "NVIDIA GeForce 3 (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 3 (generic)"
BoardName "NVIDIA GeForce 3 (generic)"
EndSection

3> you dont need to comment out the load dri section in the end cause it is just not loaded ... see step 1.

Have fun...

Make sure you did choose the right monitor, compatible display settings and resolutions etc.

STEEL
3 years of linux and not a second of regret :-)

Last edited by lucianpoe; 10-21-02 at 02:02 AM.
lucianpoe is offline   Reply With Quote
Old 10-21-02, 01:45 AM   #94
lucianpoe
Registered User
 
Join Date: Oct 2002
Location: Detroit area
Posts: 13
Send a message via Yahoo to lucianpoe
Default Re: Failed init

RonO,

We all too got through this mud. Try following the instructions described here:
http://www.nvnews.net/vbulletin/show...&threadid=2965
and see if this works for you. From my experience with both Windows XX and RedHat XX, doing a "clean" install is the best medicine you can "treat" your PC with.

Post your results (PS: to test it, run "glxgears"; if you installed "cleanly", you should get 4770.400 FPS and above consistently).

-- Lucian

Quote:
Originally posted by RonO
After completing all of the steps necessary to build the rpm and then install them, I modified XF86Config. After rebooting, X won't start giving me the following error message in the config log:

(EE) NVIDIA(0): Failed to initialize theNVdriver kernel module!

I've searched here for other suggestions and they all say one of three things: 1) You're using a version of the rpms compiled under a different kernel, 2) you don't have /dev/nvidia0 defined, or 3) you don't have the correct permissions for the /dev/nv* files.

To answer 2/3, here's the output of an ls -l /dev/nv*

crw-rw-rw- 1 root root 195, 0 Oct 19 15:38 /dev/nvidia0
crw-rw-rw- 1 root root 195, 1 Oct 19 15:38 /dev/nvidia1
crw-rw-rw- 1 root root 195, 2 Oct 19 15:38 /dev/nvidia2
crw-rw-rw- 1 root root 195, 3 Oct 19 15:38 /dev/nvidia3
crw-rw-rw- 1 root root 195, 255 Oct 19 15:38 /dev/nvidiactl

As for 1, since I didn't start this process until after the auto update process bumped my kernel up to 18-17.8.0 (from 18-14), I'm unsure how I could have compiled this for any other kernal but 18-17.8.0. However, I must conceed I screwed something up along the way.

Any suggestions/help would be appreciated.

Ron
lucianpoe is offline   Reply With Quote
Old 10-21-02, 01:57 AM   #95
lucianpoe
Registered User
 
Join Date: Oct 2002
Location: Detroit area
Posts: 13
Send a message via Yahoo to lucianpoe
Default Re: help

-predator-,

In a terminal window run this command:
pico /etc/X11/XF86Config;

- this will edit your I/O configurations; scroll down towards the bottom where you'll see a section like this:


Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection



- see that "Default Depth" section ? Make sure that the immediately following SubSection "Display" (where you see the "Modes") has the "1024x768" parameter added in front of all the others (just like in the example above).

- when you add this parameter, make sure you leave a space between it and the following.

- immediately after the "Default Depth" section you should see other sections listed. Play with them, and you will notice how you will enable/disable monitor resolution options when you use the GDM from the start menu.

>PS

Depth of 16 means 16-bit colors;
Depth of 24 means 24-bit colors;
Depth of 32 means 32-bit colors can be displayed;

Let us know how it turns out.

--Lucian

Quote:
Originally posted by -predator-
i had the old kernel and everything was clear, but now, after the kernel update, everything is like it was before the update, but I cant set the resolution higher than 800x600 (i had 1024x768 before). there is the nvidia starting-screen, the driver is nvidia, no errors are shown.
plz help, im noob

i have a chaintech g4 ti4200 if thats important
-pred-

Last edited by lucianpoe; 10-21-02 at 02:04 AM.
lucianpoe is offline   Reply With Quote
Old 10-21-02, 02:01 AM   #96
lucianpoe
Registered User
 
Join Date: Oct 2002
Location: Detroit area
Posts: 13
Send a message via Yahoo to lucianpoe
Default Re: Seems to work, but Pan hangs in GNOME

Don,

Could you post your XF86Config file that caused your Xserver to crash? I don't believe it was due to the drivers.

- 'Load "glx"' section is to load the glx drivers used for 3D rendering (it uses GL);

-- Lucian

Quote:
Originally posted by Don Rieck
Thanks to the instructions I was able to successfully (?) install the NVidia drivers. All worked - Tux Racer was nice and fast, etc

However, after the install I noticed that Pan (the newsreader) would hang at any kind of window activity - ie scrolling, etc. It would work for about 3 seconds, and then totally hang the system - hard reboot needed.

All the other apps seemed to work OK.

So the questions:

1. Does anyone else see PAN hanging with these installed ?

2. To Un-install them, I copied my old XF86Config file that I backed up over the new one. However, this caused X not to start at all. The errors seemed to have something to do with GLX, so I commented that load out of the 'new' (reverted to) XF86COnfig file, which seemed to let X load.

I've confirmed that PAN now behaves itself again, so it was definitely the drivers that screwed it up.

What does commenting out the glx line actually do ?

3. Would an older version of the drivers work better ?
Are the instructions essentially the same ?

Many thanks !

Don Rieck
don@theriecks.com

Last edited by lucianpoe; 10-21-02 at 02:06 AM.
lucianpoe is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Showcases GPU Breakthroughs at IBC 2012 News Archived News Items 0 09-07-12 11:10 AM
The Nvidia Forums Are Still Not Available, Finally We Know Why News Archived News Items 0 07-14-12 06:10 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 04:59 AM
Redhat 8.0, no rpm, can't compile. Ironphil NVIDIA Linux 6 10-02-02 04:13 PM

All times are GMT -5. The time now is 05:23 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.