Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-03-04, 05:47 PM   #1
dsg
Registered User
 
Join Date: Mar 2004
Posts: 9
Default Regular lockup problem

I'm having a very annoying problem, namely that with the nvidia driver loaded, X locks up regularly. The longest it's run was around 20 hours (on the 4496 drivers), but usually it only gets 2-3 hours. The mouse moves, but there is no other activity on the screen, and the keyboard and mouse do not respond. This is not a kernel lockup, as other processes continue running (my MP3 player is still decoding, etc.)

I've tried the 5336, 5328 and 4496 drivers, and this happens on them all. I have Fast Writes and SBA off.

My motherboard is an Abit VP6 (dual pentium 3) board, which uses a VIA chipset. The card is an FX5600XT. I'm running debian-unstable, but I tried slackware 9.1 on the same machine with no luck. I have kernel 2.6.3, but I've had this problem with 2.6.2, 2.6.1, 2.4.23 and 2.4.24 as well. Running with the nv driver appears to be stable (been running for quite a few days with it without problems), but it's slow and gives no 3d accel, so it's only a temporary fix.

I would really appreciate any help with this.

I've attached an XFree86.0.log from the last crash (logverbose 5), and my XF86Config (I've tried with AGPGART and nVidia's AGP - this one uses nVidia's, but neither works).

Thanks.
Attached Files
File Type: log crash.log (29.1 KB, 302 views)
dsg is offline   Reply With Quote
Old 03-03-04, 05:49 PM   #2
dsg
Registered User
 
Join Date: Mar 2004
Posts: 9
Default

And since this forum only allows one attachment per message, here's the XF86Config.
Attached Files
File Type: txt xf86config.txt (2.1 KB, 354 views)
dsg is offline   Reply With Quote
Old 03-04-04, 01:25 AM   #3
gordwait
Registered User
 
Join Date: Feb 2004
Posts: 6
Default Me too, but in slackware 9.0

I've had all sorts of lockups with the current (as of 3 march 04) graphics driver.
I gave up on the motherboard drivers (I have the A7N266-VM motherboard)way too many crashes and lockups, some related to USB hardware on the board.

I'm about to pack the motherboard back up and take it back for a refund, unless I can find a solution within the next day. This forum shows a lot of people having random daily lockups under linux, so I'm not having
much hope.

Come Onnnn nvidia, open up the driver source so someone can find and fix the problems!
How many programmers do you put on the task??
I read linux is overtaking MAC on the desktop about now. Take linux seriously, not by giving out buggy drivers!
Argggg...
Gord Wait
gordwait is offline   Reply With Quote
Old 03-04-04, 08:28 AM   #4
dsg
Registered User
 
Join Date: Mar 2004
Posts: 9
Default

An update: with AGP disabled, it's now been running for around 15 hours without problems. Of course, that doesn't mean it's fixed, but it's a good sign. This would of course also just be a temporary fix, as 3d accel speed without AGP sucks. Any ideas on this?
dsg is offline   Reply With Quote
Old 03-04-04, 08:55 AM   #5
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

Have you tried the 4620 driver?
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 03-04-04, 10:55 AM   #6
gordwait
Registered User
 
Join Date: Feb 2004
Posts: 6
Default

Ok, I'm willing to give it a shot, but what's so special about the 4620 driver?
How about the motherboard drivers? What's a stable version of those?
Gord
gordwait is offline   Reply With Quote
Old 03-04-04, 11:10 AM   #7
gordwait
Registered User
 
Join Date: Feb 2004
Posts: 6
Default

Ah, should have followed the link first - 4620 are the older versions of the drivers? What's so special? Why not download em from nvidia direct too?

Decent hardware, lip service linux support - crashing under linux is simply not acceptable for "released" mainstream drivers. I would have stuck with windoze if I thought crashing randomly was Ok.

Other than USB sometimes seeming to cause problems (I could not even boot the
bare.i kernel of slackware 9.1 without first disabling the USB chips entirely!) I wonder if the hardware Power Supply Fan monitor logic is causing me greif?
Under win2000, I occasionally get a warning from the Asus monitor claiming that the power supply fan has stopped - it hasn't, and the graph shows a breif subsecond glitch, so I don't know if the problem is real or not.
Point is, under linux, where does that IRQ go? perhaps this is missing from the nvidia drivers? (I can get a whole day of linux without a crash, then the next day, it crashes every hour or so - can't figure how the rate of crashing varies so much!!)

Gord
gordwait is offline   Reply With Quote
Old 03-04-04, 01:29 PM   #8
gordwait
Registered User
 
Join Date: Feb 2004
Posts: 6
Default Tried 4620, it crashed too.

I'm on slackware 9.1, using the modified 4620 nvidia drivers mentioned below (and a bunch of other official nvidia versions too)
Using A7N266-VM board, with the built in video.
It can work for a few hours, then boom, optionally horizontal lines of crud thru the
xwindow display, the screen freezes, and the mouse still works.

I've spent a week battling this, the same hw works fine under win2000,
that's it, I'm going to take it back and find a truly "linux friendly" motherboard and video card. Nice try nvidia. Later.

Gaud I hope the grass is greener somewhere else. This kind of pain is what will kill linux off.

Gord
gordwait is offline   Reply With Quote

Old 03-04-04, 02:49 PM   #9
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: Tried 4620, it crashed too.

Quote:
Originally posted by gordwait
I'm on slackware 9.1, using the modified 4620 nvidia drivers mentioned below (and a bunch of other official nvidia versions too)
Using A7N266-VM board, with the built in video.
It can work for a few hours, then boom, optionally horizontal lines of crud thru the
xwindow display, the screen freezes, and the mouse still works.

I've spent a week battling this, the same hw works fine under win2000,
that's it, I'm going to take it back and find a truly "linux friendly" motherboard and video card. Nice try nvidia. Later.

Gaud I hope the grass is greener somewhere else. This kind of pain is what will kill linux off.

Gord
Onboard nvidia card?, your saying it's going to kill off linux just because you cannot get your onboard gfx working, what are you talking about, try another distro or kernel and even the new xfree86 4.4.0.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 03-04-04, 04:28 PM   #10
gordwait
Registered User
 
Join Date: Feb 2004
Posts: 6
Default

I gave up trying to make my external nvidia card work.

The board also has an Nvidia chip set.
If the gfx drivers suck, why should I expect different from the chipset drivers?

I like slackware, besides this kind of issue is in the kernel, and all distros at the same kernel version are going to do the same thing.

IE if it doesn't work under slackware 9.1 with a 2.4.22 kernel, it's not
going to work on any other distro with 2.4.22 kernel.

I also read that people have the same nvidia lockups under 2.6 kernel, so no
point in spending another day updating to 2.6.

How much of my spare time should I invest debugging the nvidia drivers?
I think the last week was more than I wanted.

It's the drivers, which will be the same on ANY distro!

The new xfree does not have native 3D support for the nvidia card or onboard card I have (GEForce MX 400 based AGP). It does have tons of support for S3 and some support for ATI.

Also lots of support for via chipsets, amd chipsets, very little for nvidia.

I should have checked out the nvidia support before I bought - that's my main mistake..

Gord
gordwait is offline   Reply With Quote
Old 03-04-04, 04:59 PM   #11
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

Dude switching distro can make a big different, SuSE for instants adds alot of backend stuff to it's kernel and the only one to support AGP 8x in it's kernel.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 03-04-04, 09:15 PM   #12
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default

Just a small thought: use memtest86 to check your ram. Others in this forum having crashes found they had bad ram.
whig is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 09:17 AM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 03:14 PM
nVidia Geforce4 440 Go 1400x1050 problem moreinf NVIDIA Linux 10 09-16-02 12:25 PM
Geforce 4 Go and X-Server Problem with shutdown rapljenovic NVIDIA Linux 2 08-30-02 10:11 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 07:48 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.