Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-31-02, 07:12 PM   #1
tim_wilson
Guest
 
Posts: n/a
Question TNT + geforce2 GTS w/ TV-OUT

Here is my setup:
ELSA Gladiac - nVidia geforce 2 GTS AGP
Diamond Viper 550 - nVidia TNT
Linux 2.4.18-xfs

What I want is the Geforce2 to display to my monitor and I want my TNT to display to its TV-OUT. I just installed Gentoo Linux with the Linux+XFS kernel option (using i686-only CC flags). Previously I had a Slack 7.x with a standard Linux 2.4.x (.12 I think) kernel. Under Slack, my TV-OUT worked perfectly for the most part (no Xvideo or full screen w/ mplayer, though). Under the new system I am unable to use my TNT's TV-OUT. What I don't understand is that I'm able to use Geforce2 with my monitor perfectly.

Here is the error message I get in "dmesg":

nvidia: loading NVIDIA NVdriver Kernel Module 1.0-2960 Tue May 14 07:41:42 PDT 2002
NV0: RmInitAdapter failed

Now for my X error log:

(**) NVIDIA(1): Depth 16, (--) framebuffer bpp 16
(==) NVIDIA(1): RGB weight 565
(==) NVIDIA(1): Default visual is TrueColor
(==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(1): Option "NvAGP" "0"
(**) NVIDIA(1): Option "ConnectedMonitor" "TV"
(**) NVIDIA(1): Option "TVStandard" "NTSC-M"
(**) NVIDIA(1): Option "TVOutFormat" "COMPOSITE"
(==) NVIDIA(1): Using HW cursor
(**) NVIDIA(1): Forcing COMPOSITE video output
(==) NVIDIA(1): video key set to default value of 0x83e
(**) NVIDIA(1): Use of AGP disabled per request
(**) NVIDIA(1): ConnectedMonitor string: "TV"
(**) NVIDIA(1): TV Standard string: "NTSC-M"
(--) NVIDIA(1): Chipset : "RIVA TNT"
(--) NVIDIA(1): ChipID : 0x10de0020
(--) NVIDIA(1): ChipRev : 0x4
(--) NVIDIA(1): Linear framebuffer at 0xEA000000
(--) NVIDIA(1): MMIO registers at 0xEE000000
(EE) NVIDIA(1): Failed to initialize the NVdriver kernel module!
(EE) NVIDIA(1): *** Aborting ***

Would this most likely be because of my Linux+XFS kernel? I'm also using XFree86 4.2.0, and my nvidia GLX and kernel driver say "compiled for 4.0.2" in the X error log.

Thanks for any help.
  Reply With Quote
Old 08-01-02, 04:15 AM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

Before I give the answer to your problem I want to give you another advise. Don't try to run the nvidia drivers in xinerama mode when using multiple nvidia cards. (you are likely using xinerama now, the desktop becomes bigger ..) The reason not to use it at the moment is that the nvidia drivers are very buggy using it. Things you don't get are Xv and OpenGL will only work on one screen. The best thing to do is to load multiple Xservers (using one or two XF86Config-4 files)

For some reason it doesn't want to load the NVdriver. There are a few things you can check. Check if /dev/nvidia1 exists (and has the correct permissions) and also check /var/log/messages. I really hope the messages file gives some extra info else I really don't know. Not much people get these errors. (had someone else a few days ago for which I didn't have a solution either)

Others who weren't using a laptop were using (rh) kernel 2.4.18-5 perhaps it is related to a kernel problem. (rh 2.4.18-3 didn't have problems) Ofcourse you are on a different distro.

Dailly I'm on #nvidia and we rarely have that problem there either. If those files don't help us bug nvidia: linux-bugs@nvidia.com

Last edited by Thunderbird; 08-01-02 at 04:17 AM.
Thunderbird is offline   Reply With Quote
Old 08-01-02, 04:25 PM   #3
tim_wilson
Guest
 
Posts: n/a
Default

I figured out how to make it work. What I really wanted TV-out for was mplayer, which has a VESA option. To make that work I had to set my PCI Viper 550 card as my primary in my BIOS settings, and let my AGP geforce2 card become the secondary. Then I setup X to only use my geforce2 card (via BusID settings). This works surpisingly well. I have to switch to console to start mplayer (-vo VESA), but I can switch back to X and use it at the same time a video is playing. The only minor annoyance is that my text console is now on my TV. Not so bad though, since xterms are available.

I also got X to display on both my monitor and my TV at the same time using the new settings. I don't know why it didn't work w/ my AGP card as primary.
  Reply With Quote
Old 08-01-02, 05:25 PM   #4
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

I wouldn't use this a solution there's also something else you can use for tvout and that's nvtv: http://www.sf.net/projects/nv-tv-out. It has its own tvout implementation independant of the nvidia drivers. Using it you can disable/enable tvout on your TNT while in X, just play with it.
Thunderbird is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fatal upgrade: from bad (8800 GTS) to worse 9GTX 560 Ti) ssnyder NVIDIA Linux 1 07-01-12 08:14 PM
GeForce2 on Inspiron 4100 sjg NVIDIA Linux 8 10-07-02 02:06 PM
Video In on GeForce2 GTS? TwistedNsanity NVIDIA Linux 7 08-04-02 11:41 AM
1.2ghz 266 fsb TBird, VT GF2 GTS, MSI K7T Turbo-R mobo Kev1 For Sale/Trade 5 08-03-02 07:31 PM
Can fan on GeForce2 GTS be turned off with APM? nurey NVIDIA Linux 3 07-29-02 11:11 AM

All times are GMT -5. The time now is 03:51 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.