Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-17-04, 06:38 AM   #1
nashirak
Registered User
 
Join Date: Dec 2002
Posts: 14
Default nvnet unresolved symbols

I keep getting unresolved symbols when I compile and try to load the nvnet module on my 2.4.19-686 Kernel Debian System. I have a A7N8X-X board. I get the following unresolved symbols:

Quote:
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_unregister_driver_Rsmp_f56513b9
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol __netdev_watchdog_up_Rsmp_ee86a4c4
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol iomem_resource_Rsmp_9efed5af
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol free_irq_Rsmp_f20dabd8
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol netif_rx_Rsmp_bcdb21a5
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_alloc_consistent_Rsmp_33390bf1
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol __request_region_Rsmp_1a1a4f09
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol alloc_skb_Rsmp_30a77f15
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol __kfree_skb_Rsmp_89673e21
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_free_consistent_Rsmp_b2748b28
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_register_driver_Rsmp_954e8c53
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol alloc_etherdev_Rsmp_b2516e65
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol unregister_netdev_Rsmp_16b50aff
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol __out_of_line_bug_Rsmp_8b0fd3c5
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_disable_device_Rsmp_ff052e74
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_read_config_word_Rsmp_3e5c726f
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol register_netdev_Rsmp_69a4d809
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_set_dma_mask_Rsmp_98ebc076
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol skb_over_panic_Rsmp_241a50dd
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol __ioremap_Rsmp_9eac042a
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol eth_type_trans_Rsmp_c8890d9d
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_enable_device_Rsmp_6225e990
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_find_capability_Rsmp_b073eaa1
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol printk_Rsmp_1b7d4074
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol kfree_Rsmp_037a0cba
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_write_config_word_Rsmp_2b36ae09
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol cpu_raise_softirq_Rsmp_d01f3ee8
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol softnet_data_Rsmp_35c1e273
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol __udelay_Rsmp_9e7d6bd0
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol pci_set_master_Rsmp_71ceaeca
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol jiffies_Rsmp_0da02d67
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol request_irq_Rsmp_0c60f2e0
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: /lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o: unresolved symbol __release_region_Rsmp_d49501d4
/lib/modules/2.4.19-686/kernel/drivers/net/nvnet.o:
If you notice it looks like it compiled this module with SMP support for some reason and that is why its coming back with unresolved symbols. My questions is what is going on? Do the make rules try to compile SMP support (at least if that is the problem) for the module and it goes crazy? Or is it that its looking at another directory for the source. I have everything symlinked to a directory that my kernel (for my distrobution) was compiled from, ie. kernel-headers-2.4.19-686/. I have four symlinks to this file: (in /usr/src)
(uname -r produces: 2.4.19-686)


Symlinks:
linux
linux-2.4.19
linux-2.4.19-686
2.4.19-686

So I think it pointing to the correct directory. Does anyone have any suggestions about how to get this working? Something I need to add to the makefile mabye (to explictly dissallow compilation with SMP support, again, if that is even the problem here).

Thx
nashirak is offline   Reply With Quote
Old 03-17-04, 09:10 AM   #2
nashirak
Registered User
 
Join Date: Dec 2002
Posts: 14
Default

Nevermind. I didnt realize you had to:

make clean

rather than

in each directory (nvaudio and nvnet) so it was still using whatever bogus kernel headers it was compiled with before.

I thought

make unistall

would have run make clean in every directory but I guess I was wrong. Sorry,

Thanks
nashirak is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8 + Nvidia 3123 + tarball src rpms = wtf?? caustic NVIDIA Linux 8 10-09-02 08:56 PM
NVNET device not present, delaying activation robothefan NVIDIA Linux 4 10-01-02 09:43 PM
Installing nForce drivers on Debian 3.0 Doink NVIDIA Linux 4 09-14-02 08:34 PM
Linux 2.4.19 unresolved symbols... wallsaroundme NVIDIA Linux 3 08-10-02 08:24 PM
nvnet drivers in kernel, not module? xaphod NVIDIA Linux 2 08-10-02 12:03 PM

All times are GMT -5. The time now is 05:58 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.