Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-20-04, 09:24 PM   #1
Remxi
Registered User
 
Join Date: Mar 2004
Posts: 1
Question How do I change the gcc version so I can compile the NVIDIA kernel module?

When I tried to install the NVIDIA drivers, I got the following message:

"You appear to be compiling the NVIDIA kernel module with a compiler different from the one that was used to compile the running kernel. This may be perfectly fine, but there are cases where this can lead to unexpected behaviour and system crashes.

If you know what you are doing and want to override this check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the name of the compiler that was used to compile the kernel."

Following the instructions in the FAQ, I found out that the compiler version used to compile the running kernel was gcc 2.7.2.3, but the version of the compiler currently running was 2.95.4. I wanted to know how I could obtain the older version of gcc and set it to be the current compiler so I can compile the NVIDIA kernel module.

I'm using Debian 3.0r1 with the 2.2.20 kernel.
Remxi is offline   Reply With Quote
Old 03-26-04, 07:52 AM   #2
vlsoft
Registered User
 
Join Date: Feb 2004
Location: Hungary (central Europe)
Posts: 2
Default Re: How do I change the gcc version so I can compile the NVIDIA kernel module?

Do You really need to get the other compiler?
I think setting the environmental variable you mentioned above,
helps you.(IGNORE_CC_MISMATCH)
By the way: the best solution is to compile a kernel for yourself, it's not a big deal,
you only have to do is include the things you have in your computer to the kernel,
add module support, and everything will be fine, the nvidia drivers will compile
with the new kernel...
The 2.4.25 version of the kernel will be great for you...
Good luck.
vlsoft is offline   Reply With Quote
Old 03-27-04, 01:24 AM   #3
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: How do I change the gcc version so I can compile the NVIDIA kernel module?

Installing the correct gcc version would be something debian specific since the compiler used to build the kernel is available somewhere in the project.. usually you'd install a package with a name like 'gcc27' for the older releases.

You'd then set the CC environment variable, like CC=gcc27

To clarify how the ignore environment variable is used, you need to run this command before running the installer.
IGNORE_CC_MISMATCH=1
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 03-27-04, 01:35 AM   #4
crimsun
Registered User
 
Join Date: Aug 2002
Posts: 43
Default Re: How do I change the gcc version so I can compile the NVIDIA kernel module?

Hi Remxi,

I recommend you upgrade to a 2.4 or a 2.6 kernel. Please see this site: http://home.comcast.net/~andrex/Debi...dia/index.html

In this manner, you'll be able to use your currently-installed version of GCC 2.95 to compile the Nvidia kernel module.
crimsun is offline   Reply With Quote
Old 03-27-04, 01:54 AM   #5
666_1337
Registered User
 
Join Date: Dec 2003
Posts: 28
Send a message via ICQ to 666_1337
Post Re: How do I change the gcc version so I can compile the NVIDIA kernel module?

i would REALLY suggest you to upgrade...
linux 2.6 has a new memory manager, which increased performance over 50% on my machine.
gcc 3.4 (will release this week) surely builds 20% faster binaries than 2.7...
666_1337 is offline   Reply With Quote
Old 03-27-04, 04:52 AM   #6
Moled
cheese
 
Join Date: Aug 2003
Posts: 137
Default Re: How do I change the gcc version so I can compile the NVIDIA kernel module?

http://gcc.gnu.org/ml/gcc/2004-03/msg01259.html
Moled is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 10:18 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.