Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-09-02, 01:24 AM   #1
caustic
Guest
 
Posts: n/a
Default Redhat 8 + Nvidia 3123 + tarball src rpms = wtf??

Ok, first of all I have tried all of the methods explained on the forum to no avail. I have installed my kernel src package and was able to build the rpms from their source.

When I try to install the kernel rpm I am getting this error:

Code:
[root@The-Lab i386]# rpm -ivh NVIDIA_kernel-1.0-3123.i386.rpm
Preparing...                ########################################### [100%]
   1:NVIDIA_kernel          ########################################### [100%]
depmod: *** Unresolved symbols in /lib/modules/2.4.18-14/kernel/drivers/video/NVdr
iver
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol irq_stat_R
727c7c3e
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol mem_map_R1
2cb6230
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol proc_root_
driver_R71103d21
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol register_c
hrdev_R44b36f42
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol init_mm_R5
42e8e6f
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol proc_root_
Rf7cb19b8
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol __pollwait
_Rd9f12fbe
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol create_pro
c_entry_R74ce1c92
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol remove_pro
c_entry_R9d94e529
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver:
Hint: You are trying to load a module without a GPL compatible license
      and it has unresolved symbols.  Contact the module supplier for
      assistance, only they can help you.

/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: insmod /lib/modules/2.4.18-1
4/kernel/drivers/video/NVdriver failed
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: insmod NVdriver failed

NVdriver installed successfully
I have tried to do "make install" after extracting the tarballs also and I get this error:

Code:
[root@The-Lab NVIDIA_kernel-1.0-3123]# make install

...

size NVdriver
   text    data     bss     dec     hex filename
 894237   55380   52396 1002013   f4a1d NVdriver
depmod: *** Unresolved symbols in /lib/modules/2.4.18-14/kernel/drivers/video/NVdriver
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol irq_stat_R727c7c3e
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol mem_map_R12cb6230
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol proc_root_driver_R71103d21
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol register_chrdev_R44b36f42
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol init_mm_R542e8e6f
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol proc_root_Rf7cb19b8
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol __pollwait_Rd9f12fbe
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol create_proc_entry_R74ce1c92
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: unresolved symbol remove_proc_entry_R9d94e529
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver:
Hint: You are trying to load a module without a GPL compatible license
      and it has unresolved symbols.  Contact the module supplier for
      assistance, only they can help you.

/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: insmod /lib/modules/2.4.18-14/kernel/drivers/video/NVdriver failed
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: insmod NVdriver failed
make: *** [package-install] Error 255
[root@The-Lab NVIDIA_kernel-1.0-3123]#
This is getting very fustrating after all these attempts, what could I possibly be doing wrong?

Any help is GREATLY appreciated.
  Reply With Quote
Old 10-09-02, 05:55 AM   #2
a.schmitz
Guest
 
Posts: n/a
Angry

I had the same problem. I compiled a 2.4.19 myself and then I was able to build from source and src rpm. Looks like the redhat guys modified the kernel for some reason. When I try to startx now I get a nice ascii mixup on screen. I suppose that is where hardware gets involved. I am running a 1800XP+ on MSI Board with nforce and Geforce2 GTS Pro.
  Reply With Quote
Old 10-09-02, 11:23 AM   #3
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Unresolved symbols are caused by a mismatch between your kernel source configuration and your running kernel. Did you reconfigure your kernel sources?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 10-09-02, 12:01 PM   #4
a.schmitz
Guest
 
Posts: n/a
Default

Quote:
Originally posted by Andy Mecham
Unresolved symbols are caused by a mismatch between your kernel source configuration and your running kernel. Did you reconfigure your kernel sources?

--andy

Hi,

I tried to reconfigure the kernel shipped with redhat. This endet in a big pile of compiler errors. Apart from all this, it looks like XFree is a gcc2 binary. We did a recompile with gcc3 here and now it works.

short: compile new kernel from source (2.4.19) -> create kernel modules and GL from source or source rpm -> compile XFree with gcc3.

-andreas
  Reply With Quote
Old 10-09-02, 12:41 PM   #5
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Quote:
I tried to reconfigure the kernel shipped with redhat. This endet in a big pile of compiler errors.
This is probably why it didn't work in the first place, assuming you tried to reconfigure the kernel before trying the NVIDIA drivers. The NVIDIA driver depends on the kernel source configuration exactly matching the running kernel. If it doesn't, you're going to see unresolved symbols.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 10-09-02, 05:38 PM   #6
caustic
Guest
 
Posts: n/a
Default

?
Quote:
This is probably why it didn't work in the first place, assuming you tried to reconfigure the kernel before trying the NVIDIA drivers. The NVIDIA driver depends on the kernel source configuration exactly matching the running kernel. If it doesn't, you're going to see unresolved symbols.
I did reconfigure my kernel prior to enable NTFS support. So is my recompiling of the kernel the reason I cannot install the NVIDIA_kernel?

Quote:
I tried to reconfigure the kernel shipped with redhat. This endet in a big pile of compiler errors. Apart from all this, it looks like XFree is a gcc2 binary. We did a recompile with gcc3 here and now it works.

short: compile new kernel from source (2.4.19) -> create kernel modules and GL from source or source rpm -> compile XFree with gcc3.
Can someone please break this down into steps for a newbie like myself?
  Reply With Quote
Old 10-09-02, 05:48 PM   #7
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Quote:
I did reconfigure my kernel prior to enable NTFS support. So is my recompiling of the kernel the reason I cannot install the NVIDIA_kernel?
It shouldn't be. It looks like your kernel sources and running kernel are not in sync; that's why you're seeing the unresolved symbols. Is the kernel you reconfigured and rebuilt the one you're running now? Have you changed your kernel sources since recompiling?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 10-09-02, 06:00 PM   #8
caustic
Guest
 
Posts: n/a
Default

Yes, I am running my rebuilt kernel, and I have not changed my kernel sources since recompiling....atleast I don't think so...is there a way to check? Because I remember trying to install my ntfs support for a 2.4.18 kernel I downloaded, which failed, and so then I just edited my 2.4.18-14 kernel which came preloaded with RedHat and I got the ntfs module compiled in. Mabey my first attempt at the 2.4.18 kernel f---ed something up???

  Reply With Quote

Old 10-09-02, 08:56 PM   #9
caustic
Guest
 
Posts: n/a
Thumbs up

That must have been the problem. I reinstalled linux with every package and tried it with the src rpms, worked like a charm. I load up and the nvidia logo flashes as it should, and I can now have a desktop at 24bit. Kick ass, only I hope when I reinstall ntfs support it doesn't **** up.

Anyways, peace and thanks
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Showcases GPU Breakthroughs at IBC 2012 News Archived News Items 0 09-07-12 10:10 AM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 03:59 AM
Redhat 7.3 + Nvidia drivers 3123 = troubles e-r-a-n NVIDIA Linux 4 09-17-02 12:26 PM
Nvidia 3123 not working on Mandrake 8.2 UP with Geforce 440 MMX tariqf NVIDIA Linux 1 09-17-02 08:22 AM

All times are GMT -5. The time now is 06:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.