Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-11-04, 01:06 PM   #1
hamselv
Registered User
 
Join Date: Apr 2004
Location: Aalborg, Denmark
Posts: 2
Default SDL and nVidia drivers on Multihead

Hi

I have a little problem with my new setup, I bought two lcd panels and connected them, enabled TwinView on my TI-4400 asus board (V8440 deluxe), and then everything is smooth in plain X. And it work out quite well..

Next I want to game Neverwinther nights, a game I play quite often, so i made a little fullscreen hack to its SDL Lib, but ... here the cake:

the nvidia driver only provides one screen with the resolution of :

Screen #0: @ 2560x1024 pixels (650x260 millimeters) /24 bit

which is annoying because the SDL lib uses the info provided by the x-server, so I contacted the libsdl-dev crew, but I also wanted you to know this, because I think its the driver which has the problem,

The driver version is NVIDIA-Linux-x86-1.0-5336

total sysinfo:
Kernel: Linux 2.6.4
CPU[1]: Intel(R) Pentium(R) 4 CPU 2.53GHz@2539.330 MHz
Mem/Use: 1031424 kB/ 33312 kB
Vid: nVidia Corporation NV25 [GeForce4 Ti 4400] (rev 163).
XInfo:4.3.0.1 Screen #0: @ 2560x1024 pixels (650x260 millimeters) /24 bit
Sound:Creative Labs SB Live! EMU10k1 (rev 7).

Hope someone has the same problem as me

Ps. I tried running a second X with just one screen but it has some complications, and its not durable in the lenght..
__________________
Per Christiansen
Programmer and Network Coordinator
http://www.webinc.dk
hamselv is offline   Reply With Quote
Old 04-11-04, 03:56 PM   #2
fdm
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: SDL and nVidia drivers on Multihead

Hi Hamselv,

Just a thought... perhaps you can work around your problem with the information in appendix I from the nvidia graphics card driver readme. It has the option to disable one of the monitors for one or more modes. Here is a short fragment of that text:

Option "MetaModes" "1280x1024,1280x1024; 1024x768,1024x768"

If you want a display device to not be active for a certain
MetaMode, you can use the mode name "NULL", or simply omit the
mode name entirely:

"1600x1200, NULL; NULL, 1024x768"

or

"1600x1200; , 1024x768"


If you define a list of modes in your XF86Config file, you should be able to switch between them by pressing CTRL-ALT-KP_PLUS/KP_MIN

Hope this helps,

Frans
fdm is offline   Reply With Quote
Old 04-11-04, 05:10 PM   #3
hamselv
Registered User
 
Join Date: Apr 2004
Location: Aalborg, Denmark
Posts: 2
Default Re: SDL and nVidia drivers on Multihead

Dunno how this would help me, because I need both screens still. ONe to play the game and one to have info on.

Quote:
Originally Posted by fdm
If you want a display device to not be active for a certain
MetaMode, you can use the mode name "NULL", or simply omit the
mode name entirely:

"1600x1200, NULL; NULL, 1024x768"

or

"1600x1200; , 1024x768"
btw. I have:

Option "MetaModes" "1280x1024,1280x1024" in my x cfg
__________________
Per Christiansen
Programmer and Network Coordinator
http://www.webinc.dk
hamselv is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI + nvidia blob = nvidia blob crash puchuu NVIDIA Linux 11 05-12-12 02:14 PM

All times are GMT -5. The time now is 06:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.