Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-28-02, 07:59 PM   #1
ghost_o
Guest
 
Posts: n/a
Default DPMS on XFree4.2.0 and NVDriver 1.0-2960

OK, to not confuse anything, I am running a 2.4.18 series kernel, glibc2.2.5, Xfree4.2.0, KDE3.0.2, Gnome2.0..

Ok That said - everything works great - DPMS functions all work as expected in any of the Systems I may be logged into at the time.

`xset dpms force off` turns the monitor off as expected. I set the values from my .xinitrc or .xsession files and it happens automagically.

Yesterday I decided to try the NVDrivers again, so I downloaded them, compiled my kernel without AGPgart, rebooted, and compiled and installed them.

All *appears* to work well, except DPMS will no longer turn off my screen. It tries to, but all it does is throw up on me and scrable the screen to where it tells me invalid sync and scan freq on the screen.

Just wondering why this may be an dif anyone else has run into this before?
BTW: It is a Geforce 256DDR

Thanks

-G
  Reply With Quote
Old 07-28-02, 08:40 PM   #2
Bern
Slacker
 
Bern's Avatar
 
Join Date: Jul 2002
Location: Brisvegas, Antipodes
Posts: 15
Send a message via ICQ to Bern
Default

It's working fine for me with the same kernel etc..
The only thing I can think of is you might have missed some option during your kernel config.
__________________
p-two.net
Bern is offline   Reply With Quote
Old 07-28-02, 10:07 PM   #3
ghost_o
Guest
 
Posts: n/a
Default

Quote:
Originally posted by Bern
It's working fine for me with the same kernel etc..
The only thing I can think of is you might have missed some option during your kernel config.
Hmmm.. I have a kernel that has APM and ACPI both turned off, so I know that is not it.

Do you have anything that might stick out in your config files besides the following??

Section "Monitor"
Identifier "monitor0"
HorizSync 31-89
VertRefresh 50-160
EndSection

Section "Device"
Identifier "video0"
Driver "nvidia"
Option "NvAGP" "1"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "video0"
Monitor "monitor0"
Option "IgnoreEdid" "1"
Option "DPMS" "on"
DefaultDepth 16

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

# ************************************************** ********************
# ServerLayout sections.
# ************************************************** ********************

Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection
  Reply With Quote
Old 07-28-02, 10:29 PM   #4
Bern
Slacker
 
Bern's Avatar
 
Join Date: Jul 2002
Location: Brisvegas, Antipodes
Posts: 15
Send a message via ICQ to Bern
Default

This is mine,
Code:
Section "Monitor"

    Identifier  "Acer v771"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    HorizSync   30 - 72

#    HorizSync	30-64         # multisync
#    HorizSync	31.5, 35.2    # multiple fixed sync frequencies
#    HorizSync	15-25, 30-50  # multiple ranges of sync frequencies

# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    VertRefresh 50 - 120

    Option "DPMS"

EndSection
Try removing the "on"
[Edit] And put the option in your monitor section.
__________________
p-two.net

Last edited by Bern; 07-29-02 at 05:26 AM.
Bern is offline   Reply With Quote
Old 07-29-02, 04:58 AM   #5
cake
Registered User
 
Join Date: Jul 2002
Posts: 24
Default

Hello. I have the same problem with SuSe 8.0, had the same problem with SuSe 7.3, both with stndard kernels (2.4.18 for SuSE 8.0) and with Nvidia drivers down the lane to 28...something. The DPMS just does not work properly. If I use the standard drivers everything is O.K. I tried to discuss this issue here before and there was no solution found. I contacted Nvidia support and I got only the typical saying-nothing answer (we are revising your problem....)

Removing the Option "DPMS" leaves the monitor always on, xset dpms force off leads to invalid sysnc. (with or without the DPMS option in config)

My confiiguration:

Manli Nvidia GeForce 2 MX 400
ECS P6IPAT Motherboard
PIII 667 Mhz
512 MB RAM
SuSE 8.0, Kernel 2.4.18

Just use the power button on your monitor, that is the only solution I use.
cake is offline   Reply With Quote
Old 07-29-02, 05:06 AM   #6
ghost_o
Guest
 
Posts: n/a
Default

Quote:
Originally posted by cake
Hello. I have the same problem with SuSe 8.0, had the same problem with SuSe 7.3, both with stndard kernels (2.4.18 for SuSE 8.0) and with Nvidia drivers down the lane to 28...something. The DPMS just does not work properly. If I use the standard drivers everything is O.K. I tried to discuss this issue here before and there was no solution found. I contacted Nvidia support and I got only the typical saying-nothing answer (we are revising your problem....)

Removing the Option "DPMS" leaves the monitor always on, xset dpms force off leads to invalid sysnc. (with or without the DPMS option in config)

My confiiguration:

Manli Nvidia GeForce 2 MX 400
ECS P6IPAT Motherboard
PIII 667 Mhz
512 MB RAM
SuSE 8.0, Kernel 2.4.18

Just use the power button on your monitor, that is the only solution I use.
I don't play games or anything, so it is better for me to just use the standard nv driver and have DPMS functionality that works. Hopefully, nVidia will fix it one day. Who knows!
  Reply With Quote
Old 07-29-02, 06:15 PM   #7
Petersen
Registered User
 
Join Date: Jul 2002
Location: Germany
Posts: 22
Default

Hi,

I don't have any problem with dpms! Using a geforce2 mx, the latest nvidia drivers and running xfree 4.02.

What does "xset q" tell you?
especially these lines:

Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 420 cycle: 600

I found out that kde likes to set the screen saver timeout to 0 (zero), which disables dpms for me (and which is the same as setting "xset s 0").

If I want to have dpms working under kde, I have to
a) enable dpms in the control centre of kde
plus
b) launch "xset s 420" (or something like that) via the .xinitrc

A "zero" value (see above) disables dpms, which means that when entering the dpms state the screen starts flashing and flashing in a very distorted way.

Maybe you could check this?


Regards
Petersen
Petersen is offline   Reply With Quote
Old 07-30-02, 12:04 AM   #8
ghost_o
Guest
 
Posts: n/a
Default

Quote:
Originally posted by Petersen
Hi,

I don't have any problem with dpms! Using a geforce2 mx, the latest nvidia drivers and running xfree 4.02.

What does "xset q" tell you?
especially these lines:

Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 420 cycle: 600

I found out that kde likes to set the screen saver timeout to 0 (zero), which disables dpms for me (and which is the same as setting "xset s 0").

If I want to have dpms working under kde, I have to
a) enable dpms in the control centre of kde
plus
b) launch "xset s 420" (or something like that) via the .xinitrc

A "zero" value (see above) disables dpms, which means that when entering the dpms state the screen starts flashing and flashing in a very distorted way.

Maybe you could check this?


Regards
Petersen
If I leave my configuration 'identical' other than use the "nvidia" versus "nv" driver in my xfree file, DPMS OFF mode breaks. Standby still works as expected, just OFF quits working and it sends my monitor a sync and refresh that it cannot understand. Quickly switching back to "nv" driver, restarting x-session and all works like it should again. I do not even have xscreensaver installed. I am running Gnome2.0 these next few days to see if I like it better (only been running Linux with a monitor for about 3 months now) than KDE, and it behaves exactly as KDE, so it is definately between the xserver and the nvidia driver somewhere. I have tried literally 30 different combinations of driver, agpsetting, where in the XF86config-4 file to place settings, where to put stuff in the .xinitrc files for startx.. My conclusion - on geforce256 DDR, the NVdriver is broke. There was someone else with exact behavior as me that even went to the trouble to get in touch with nVidia to no avail, so I have pretty much given up after wasting 8-10 hours trying to figure it out.

Oh well, like I said, I do nothing that the speed increase of OpenGL would really help anyway, so I am not that bummed out, I just hate to think I am not getting all I can out of the system you know
  Reply With Quote

Old 07-30-02, 12:06 AM   #9
ghost_o
Guest
 
Posts: n/a
Default

Well, let me say it may not be "broke", but may be too strict and adhering to DCC protocols when my monitor may not be. I am not blaming one or the other, but the plain XFree86.org guys got it right!

(Another OpenSource plug)
  Reply With Quote
Old 07-30-02, 04:14 AM   #10
cake
Registered User
 
Join Date: Jul 2002
Posts: 24
Default

Quote:
Originally posted by Petersen
Hi,

I don't have any problem with dpms! Using a geforce2 mx, the latest nvidia drivers and running xfree 4.02.

What does "xset q" tell you?
especially these lines:

Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 420 cycle: 600

I found out that kde likes to set the screen saver timeout to 0 (zero), which disables dpms for me (and which is the same as setting "xset s 0").

If I want to have dpms working under kde, I have to
a) enable dpms in the control centre of kde
plus
b) launch "xset s 420" (or something like that) via the .xinitrc

A "zero" value (see above) disables dpms, which means that when entering the dpms state the screen starts flashing and flashing in a very distorted way.

Maybe you could check this?


Regards
Petersen
Well, after a bit of hassling with "xset s etc." I got to the point I can manually start "xset dpms force off" so I think This solved my problem. Thanks.
cake is offline   Reply With Quote
Old 07-30-02, 02:44 PM   #11
ghost_o
Guest
 
Posts: n/a
Default

Quote:
Originally posted by cake


Well, after a bit of hassling with "xset s etc." I got to the point I can manually start "xset dpms force off" so I think This solved my problem. Thanks.
Could you possibly send the output of an `xset q` when it is working for you. I have tried all of the `xset s` options today as your last post gave me hope to try it again, but mine just garbles the screen still !%^@#^%


I would appreciate it

-G
  Reply With Quote
Old 07-31-02, 06:05 PM   #12
cake
Registered User
 
Join Date: Jul 2002
Posts: 24
Default

Here is my xset q. I have everything set to 1 hour....
Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000000
auto repeat delay: 660 repeat rate: 25
auto repeating keys: 00ffffffdffffbbf
fa9fffffffdff5ff
ffffffffffffffff
ffffffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 0 cycle: 3600
Colors:
default colormap: 0x20 BlackPixel: 0 WhitePixel: 65535
Font Path:
/opt/kde3//share/fonts/override,/usr/X11R6/lib/X11/fonts/misc:unscaled,/usr/X1 1R6/lib/X11/fonts/local,/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X 11/fonts/Type1,/usr/X11R6/lib/X11/fonts/URW,/usr/X11R6/lib/X11/fonts/Speedo,/usr /X11R6/lib/X11/fonts/latin2/misc:unscaled,/usr/X11R6/lib/X11/fonts/latin2/Type1, /usr/X11R6/lib/X11/fonts/kwintv:unscaled,/usr/X11R6/lib/X11/fonts/truetype,/usr/ X11R6/lib/X11/fonts/uni:unscaled,/usr/X11R6/lib/X11/fonts/CID,/opt/kde3//share/f onts
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
Standby: 3600 Suspend: 3600 Off: 3600
DPMS is Enabled
Monitor is On
Font cache:
hi-mark (KB): 1024 low-mark (KB): 768 balance (%): 70
cake is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Red Hat 7.3, tarred 2960 download, NVdriver failed to initialize SparceMatrix NVIDIA Linux 7 09-10-02 01:02 AM

All times are GMT -5. The time now is 11:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.