Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-17-04, 11:35 AM   #1
sirsnipes
Registered User
 
Join Date: Apr 2004
Posts: 3
Default americas army performance issues

Hi I'm pretty new to Linux, but am learning more every day.

I'm running Mandrake 10
AMD 1.2
Gforce FX 5200 128
640 RAM

My performance w/ glxgears seems to be pretty good at 1250fps. My problem is when i start Americas Army it drops to 7 - 25 fps. I'm not sure if this is normal, but is quite a bit lower than in windows xp. Plus i have all settings on ultra low in linux. Any suggestions on how to improve performance would be very much appreciated.

My XFconfig-4 settings are.
Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1600x1200 @ 76 Hz"
HorizSync 31.5-94.0
VertRefresh 50-90
# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce FX (generic)"
Driver "nvidia"
Option "DPMS"
Option "RenderAccel" "on"
#Option "NvAGP" "1"
Option "DigitalVibrance" "100"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 1152 864
EndSubsection

Subsection "Display"
Depth 15
Virtual 1152 864
sirsnipes is offline   Reply With Quote
Old 04-17-04, 01:21 PM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: americas army performance issues

Are you sure this is your full config file? I don't see a screen section for your default depth of 16, further on what resolution are you playing the game?

Note that you can't compare the windows performance with linux (apples with oranges) as the oses are different and because on windows direct3d is used and on linux opengl. (the ut2003 opengl renderer is not as good as the direct3d version)
Thunderbird is offline   Reply With Quote
Old 04-17-04, 01:54 PM   #3
sirsnipes
Registered User
 
Join Date: Apr 2004
Posts: 3
Default Re: americas army performance issues

that is not my full config i just put the parts i thought were relevent. I play the game at 800x600 at 16 bit color. Is there something that i havn't set that could prevent that? On the splash screen of the game I get 170fps.

here is the whole config

File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1600x1200 @ 76 Hz"
HorizSync 31.5-94.0
VertRefresh 50-90

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce FX (generic)"
Driver "nvidia"
Option "DPMS"
Option "RenderAccel" "on"
Option "NvAGP" "1"
#Option "DigitalVibrance" "80"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1152 864
EndSubsection

Subsection "Display"
Depth 15
Virtual 1152 864
EndSubsection

Subsection "Display"
Depth 16
Virtual 1152 864
EndSubsection

Subsection "Display"
Depth 24
Virtual 1152 864
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

note: I changed my resolution back to 24bit now just playing around with settings still. My fps in glxgears on this setting is around 850.
sirsnipes is offline   Reply With Quote
Old 04-17-04, 03:07 PM   #4
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: americas army performance issues

You could try a different nvagp mode seems very low.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 04-17-04, 04:39 PM   #5
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: americas army performance issues

The option nvagp is just for switching between agp drivers. It doesn't really matter if you use agpgart or "nvagp" these days.

You could check if agp is enabled: cat /proc/driver/nvidia/agp/status
Thunderbird is offline   Reply With Quote
Old 04-17-04, 04:56 PM   #6
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: americas army performance issues

On the official americas army forums you will find several posts regarding performance issues.. in particular that many people find the performance to be much higher with agpgart rather than nvagp -- I find them very similar for this game (nvagp rules otherwise). The main problem I think.. is that the engine is very cpu load intensive. I run nearly the same fps with 16x12 maxed features as I do 8x6 minimum (and we all know that it SHOULD make a difference).

I average 12 - 20 fps outdoors (especially with fog) and 45 - 90 fps indoors with my ti4400 (glxgears runs ~3000). Since the 5200s seem a bit slower (by peoples reports) I think your framerate is reasonable. In windows I do run slightly faster for AAOps, but the sound sucks! Alsa is much better -- So, take your pick.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 04-17-04, 07:40 PM   #7
sirsnipes
Registered User
 
Join Date: Apr 2004
Posts: 3
Default Re: americas army performance issues

Thanks for suggestions i will give them a try and get back to you.
sirsnipes is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Twinview performance issues on GTS250 hampsterblade NVIDIA Linux 4 05-30-12 12:53 PM
America's Army is really, really... malachi1313 Gaming Central 15 07-02-08 11:18 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-31-02 12:59 AM
UT2003 demo impressions Crake Gaming Central 241 09-28-02 08:37 AM
Americas Army sniper patch is out! malachi1313 Gaming Central 10 08-08-02 08:42 AM

All times are GMT -5. The time now is 06:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.