Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-30-04, 04:27 AM   #1
iSteve
Registered User
 
Join Date: Jan 2004
Posts: 7
Default nVidia vs Enemy Territory vs 2.6 linux kernel

Greetings,
I have 2.6.0 linux kernel and nvidia 53.36 drivers (that finaly are 2.6-compliant) ...

... and still, as well as with any previous (patched from minion.de), after some time, enemy territory stops to respond for few seconds (up to few minutes). After looking up the /var/log/messages, I found the message below (it is repeated many times) ... any idea what to do?

AMD Athlon XP 2000+
512MB DDR 333MHz RAM, CL 2.5
MSI KT4 Ultra
Prolink GF4 Ti4200
Debian GNU/Linux, linux kernel 2.6, vanilla

TROUBLE MESSAGE:

Jan 29 23:19:53 silver kernel: Badness in pci_find_subsys at drivers/pci/search.c:132
Jan 29 23:19:53 silver kernel: Call Trace:
Jan 29 23:19:53 silver kernel: [__fat_access+94/960] pci_find_subsys+0x3e/0xd0
Jan 29 23:19:53 silver kernel: [__fat_access+264/960] pci_find_device+0x18/0x20
Jan 29 23:19:53 silver kernel: [__fat_access+14/960] pci_find_slot+0x2e/0x40
Jan 29 23:19:53 silver kernel: [_end+545171370/1068759964] os_pci_init_handle+0x2e/0x60 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+543683579/1068759964] _nv001243rm+0x1f/0x24 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+545021105/1068759964] _nv000816rm+0x2f5/0x384 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+544400584/1068759964] _nv003801rm+0xd8/0x100 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+545019883/1068759964] _nv000809rm+0x2f/0x34 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+544404204/1068759964] _nv003816rm+0xf0/0x104 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+544407651/1068759964] _nv000013rm+0x77/0x84 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+544406023/1068759964] _nv003780rm+0x1df/0x2c8 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+544405523/1068759964] _nv000012rm+0x43/0x58 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+544405456/1068759964] _nv000012rm+0x0/0x58 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+543633976/1068759964] _nv001219rm+0xa8/0x124 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+545161916/1068759964] nv_kern_rc_timer+0x0/0x30 [nvidia]
Jan 29 23:19:53 silver kernel: [_end+543701586/1068759964] rm_run_rc_callback+0x36/0x4c [nvidia]
Jan 29 23:19:53 silver kernel: [_end+545161927/1068759964] nv_kern_rc_timer+0xb/0x30 [nvidia]
Jan 29 23:19:53 silver kernel: [sys_sched_get_priority_max+9/48] run_timer_softirq+0x129/0x160
Jan 29 23:19:53 silver kernel: [__is_prefetch+511/624] do_softirq+0x4f/0xa0
Jan 29 23:19:53 silver kernel: [irq_entries_start+837/2176] do_IRQ+0x111/0x130
Jan 29 23:19:53 silver kernel: [__down+12/288] common_interrupt+0x18/0x20
Jan 29 23:19:53 silver kernel: [show_cpuinfo+146/528] get_offset_tsc+0x2/0x20
Jan 29 23:19:53 silver kernel: [handle_vm86_fault+565/2656] do_gettimeofday+0x25/0xb0
Jan 29 23:19:53 silver kernel: [module_finalize+29/144] sys_gettimeofday+0x1d/0xa0
Jan 29 23:19:53 silver kernel: [sys_get_thread_area+15/320] syscall_call+0x7/0xb
iSteve is offline   Reply With Quote
Old 01-30-04, 11:53 AM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

We're looking into it. Sorry for the inconvenience.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 01-30-04, 12:56 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

The message itself or even the condition warned about are harmless, but they typically show up in the aftermath of a severe error condition. If you see this kind of trace in your system log, it's a good idea to go through the most common error sources (AGP, ACPI, APIC, fbdev, RAM, thermal and other problems).
zander is offline   Reply With Quote
Old 01-30-04, 03:31 PM   #4
DarkMachine
Registered User
 
DarkMachine's Avatar
 
Join Date: Jan 2004
Posts: 4
Send a message via ICQ to DarkMachine
Question Same problem

For Quite some time i have not been able to play ET on my machine, it sounds like the same problem above. I am running slackware 9.1 with the 2.6 kernel. I have not done much debugging because it seems to be the only game affected. Also X windows will lockup ramdomly while playing movies, this does not always happen though, it's like i said random. The whole machine does not freeze however, I am able to SSH into the machine and kill the X server and restart it, but i loose all of my consoles(f1-f8) in which i can only see garbled, sometimes colored, ascii text. The only solution if i want to use a console is to reboot. could this be a frame buffer problem? i'd be interested to hear any quick fixes.

thanks
__________________
Asus GeForce4 TI4200 128MB
DarkMachine is offline   Reply With Quote
Old 01-31-04, 01:47 PM   #5
iSteve
Registered User
 
Join Date: Jan 2004
Posts: 7
Default

Andy: any clue about a timeline of fix?
DarkMachine: similar problem happened to me, similarly bad (inputs were ignored), playing this game - only once ... I "solved" it using typical windows method - by restarting the machine.
iSteve is offline   Reply With Quote
Old 02-16-04, 10:18 AM   #6
zby
Registered User
 
Join Date: Feb 2004
Posts: 1
Default

I have the same problem with 2.6.2 kernel (the line number is different though).

The screen and keyboard is locked, but I can login into the system via ssh.

The trace:

Feb 16 06:04:12 zby kernel: Badness in pci_find_subsys at drivers/pci/search.c:167
Feb 16 06:04:12 zby kernel: Call Trace:
Feb 16 06:04:12 zby kernel: [pci_find_subsys+62/240] pci_find_subsys+0x3e/0xf0
Feb 16 06:04:12 zby kernel: [pci_find_device+24/32] pci_find_device+0x18/0x20
Feb 16 06:04:12 zby kernel: [pci_find_slot+46/64] pci_find_slot+0x2e/0x40
Feb 16 06:04:12 zby kernel: [_end+546551322/1068771196] os_pci_init_handle+0x2e/0x60 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545062875/1068771196] _nv001243rm+0x1f/0x24 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+546400401/1068771196] _nv000816rm+0x2f5/0x384 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545779880/1068771196] _nv003801rm+0xd8/0x100 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+546399179/1068771196] _nv000809rm+0x2f/0x34 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545783500/1068771196] _nv003816rm+0xf0/0x104 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545777546/1068771196] _nv003795rm+0x6ea/0xaec [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545163747/1068771196] _nv004046rm+0x3a3/0x3b0 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+546218787/1068771196] _nv001476rm+0x277/0x45c [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545073942/1068771196] _nv000896rm+0x4a/0x64 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545080112/1068771196] rm_isr_bh+0xc/0x10 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+546541638/1068771196] nv_kern_isr_bh+0xa/0x10 [nvidia]
Feb 16 06:04:12 zby kernel: [tasklet_action+133/224] tasklet_action+0x85/0xe0
Feb 16 06:04:12 zby kernel: [do_softirq+108/208] do_softirq+0x6c/0xd0
Feb 16 06:04:12 zby kernel: [do_IRQ+358/384] do_IRQ+0x166/0x180
Feb 16 06:04:12 zby kernel: [common_interrupt+24/32] common_interrupt+0x18/0x20
Feb 16 06:04:12 zby kernel:
Feb 16 06:04:12 zby kernel: Badness in pci_find_subsys at drivers/pci/search.c:167
Feb 16 06:04:12 zby kernel: Call Trace:
Feb 16 06:04:12 zby kernel: [pci_find_subsys+62/240] pci_find_subsys+0x3e/0xf0
Feb 16 06:04:12 zby kernel: [pci_find_device+24/32] pci_find_device+0x18/0x20
Feb 16 06:04:12 zby kernel: [pci_find_slot+46/64] pci_find_slot+0x2e/0x40
Feb 16 06:04:12 zby kernel: [_end+546551322/1068771196] os_pci_init_handle+0x2e/0x60 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545062875/1068771196] _nv001243rm+0x1f/0x24 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545788377/1068771196] _nv003797rm+0xa9/0x128 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+546233373/1068771196] _nv001490rm+0x55/0xe4 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+546400464/1068771196] _nv000816rm+0x334/0x384 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545779880/1068771196] _nv003801rm+0xd8/0x100 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+546399179/1068771196] _nv000809rm+0x2f/0x34 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545783500/1068771196] _nv003816rm+0xf0/0x104 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545777546/1068771196] _nv003795rm+0x6ea/0xaec [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545163747/1068771196] _nv004046rm+0x3a3/0x3b0 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+546218787/1068771196] _nv001476rm+0x277/0x45c [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545073942/1068771196] _nv000896rm+0x4a/0x64 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+545080112/1068771196] rm_isr_bh+0xc/0x10 [nvidia]
Feb 16 06:04:12 zby kernel: [_end+546541638/1068771196] nv_kern_isr_bh+0xa/0x10 [nvidia]
Feb 16 06:04:12 zby kernel: [tasklet_action+133/224] tasklet_action+0x85/0xe0
Feb 16 06:04:12 zby kernel: [do_softirq+108/208] do_softirq+0x6c/0xd0
Feb 16 06:04:12 zby kernel: [do_IRQ+358/384] do_IRQ+0x166/0x180
Feb 16 06:04:12 zby kernel: [common_interrupt+24/32] common_interrupt+0x18/0x20
zby is offline   Reply With Quote
Old 02-16-04, 03:22 PM   #7
McQuaid
Registered User
 
Join Date: Sep 2003
Posts: 8
Default

I had a problem with enemy territory with 2.6 as well, but I don't think it's nvidia related, (could be though, who knows)

Everything went smooth upgrading to 2.6 except enemy territory maps would take longer and longer to load.

With lin 2.4 on my system (p4 1.6 gf4 ti 4200 128 megs of ram) it would usually take about 30-40 secs to load a map. I know I'm kinda low on ram but it would usually work fine. With 2.6 the first map would take about the same time, 30-40 secs, but each map thereafter would get longer and longer, around the 3rd map would take over 3 minutes and I'd get kicked from the server.

I even try hosting my own server as a test, just kept reloading the same map, and the map load times just kept getting longer and longer. From 30 secs to over 4 minutes.

With everything else the performance would seem the same, I tested hdparm and getting about 40 megs/sec (same as 2.4). So it doesn't seem to be a DMA issue.

In the end I went back to 2.4 because I don't like not being able to play ET.

Any ideas?
McQuaid is offline   Reply With Quote
Old 04-21-04, 01:07 PM   #8
DarkMachine
Registered User
 
DarkMachine's Avatar
 
Join Date: Jan 2004
Posts: 4
Send a message via ICQ to DarkMachine
Exclamation Re: nVidia vs Enemy Territory vs 2.6 linux kernel

Here is what fixed my problem try it. When i upgraded to a 2.6 kernel i finally figured out that my swap partition was not being mounted, somthign about being the wrong version. to check if you are getting an error try this

dmesg | grep swap

If you get an error(at least in my case with slackware 9) it will tell you how to change the version of your swap.

then swapon and bingo

This evidently was causing UT2003 not to run on my machine too.
hope this works for you.

DM
__________________
Asus GeForce4 TI4200 128MB
DarkMachine is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
NVIDIA kernel not loading on boot-up, but insmod loads it Kyle NVIDIA Linux 3 09-10-02 12:01 AM

All times are GMT -5. The time now is 07:01 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.