Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-29-04, 06:08 AM   #1
LOE
Registered User
 
Join Date: Apr 2004
Posts: 5
Question Problem with installing lan/audio driver and sh dependencies

I run slackware 9.1 with kernel 2.4.22

I built the rpm from the src, but when I try ot install it the following error occurs:


error: failed dependencies:
/bin/sh is needed by NVIDIA_nforce-1.0-0261
/bin/sh is needed by NVIDIA_nforce-1.0-0261


It's the first time I install linux and to be honest I have no idea about what's going on
But i need the lan running

Last edited by LOE; 04-30-04 at 01:48 AM.
LOE is offline   Reply With Quote
Old 04-29-04, 06:12 AM   #2
LOE
Registered User
 
Join Date: Apr 2004
Posts: 5
Default Re: Problem with installing lan/network driver

This package contains drivers and documentation for the nForce and nForce2 chipsets. It also contains instructions for configuring the IDE and USB hardware correctly. The audio driver is based the i810 audio driver; the GPL licence for that driver is included.
unsatisfied dependencies
/bin/sh , /bin/sh
depends
/bin/sh , /bin/sh , rpmlib(PayloadFilesHavePrefix) (<= 4.0-1), rpmlib(CompressedFileNames) (<= 3.0.4-1)


This is from the rpm info

..and...what should I do with this file

NVIDIA_nforce-1.0-0261.tar.gz ?!?
LOE is offline   Reply With Quote
Old 05-01-04, 01:33 PM   #3
blueworm
[DEADAGAIN]blueworm
 
blueworm's Avatar
 
Join Date: Mar 2003
Posts: 416
Default Re: Problem with installing lan/network driver

Code:
tar -zxvf NVIDIA_nforce-1.0-0261.tar.gz
cd nforce/nvnet
make 
make install
modprobe nvnet
__________________
Registered linux user #271604 Get Counted! http://counter.li.org/
lianLi PC60, OCZ powerStream 520W PSU, Asus P5N-E SLI, Core 2 duo E6550, 2Gb GEIL, XFX 8800GT, TB SantaCruz
blueworm is offline   Reply With Quote
Old 05-03-04, 06:07 AM   #4
LOE
Registered User
 
Join Date: Apr 2004
Posts: 5
Default Re: Problem with installing lan/network driver

Well I managed to get the network running, but now I got a problem with nvaudio - on linux startup I get an error when modprobe nvaudio.o a several times... that something's wrong with the configuration/IRQ or something
LOE is offline   Reply With Quote
Old 05-03-04, 06:33 AM   #5
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Problem with installing lan/network driver

You should only use the nvnet driver from the nforce driver package as other drivers are already builtin into the kernel. (for newer kernels there's even a hacked opensource nvnet driver)

The audio driver you need is i810_audio.o and it is already installed on your system.
Thunderbird is offline   Reply With Quote
Old 05-03-04, 06:56 AM   #6
LOE
Registered User
 
Join Date: Apr 2004
Posts: 5
Default Re: Problem with installing lan/network driver

root@hellspawn:~# modprobe i810_audio
/lib/modules/2.4.22/kernel/drivers/sound/i810_audio.o.gz: init_module: No such device
/lib/modules/2.4.22/kernel/drivers/sound/i810_audio.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.22/kernel/drivers/sound/i810_audio.o.gz: insmod /lib/modules/2.4.22/kernel/drivers/sound/i810_audio.o.gz failed
/lib/modules/2.4.22/kernel/drivers/sound/i810_audio.o.gz: insmod i810_audio failed



and this is for the nvaudio :
root@hellspawn:~# insmod /lib/modules/2.4.22/kernel/drivers/sound/nvaudio.o
/lib/modules/2.4.22/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_probe_codec
/lib/modules/2.4.22/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_dac_rate
/lib/modules/2.4.22/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_adc_rate


root@hellspawn:~# modprobe nvaudio
/lib/modules/2.4.22/kernel/drivers/sound/nvaudio.o: init_module: No such device
/lib/modules/2.4.22/kernel/drivers/sound/nvaudio.o: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.22/kernel/drivers/sound/nvaudio.o: insmod /lib/modules/2.4.22/kernel/drivers/sound/nvaudio.o failed
/lib/modules/2.4.22/kernel/drivers/sound/nvaudio.o: insmod nvaudio failed
LOE is offline   Reply With Quote
Old 05-08-04, 06:18 AM   #7
Panarello
Registered User
 
Join Date: May 2004
Posts: 2
Default Re: Problem with installing lan/network driver

Hi LOE what you do to work your lan? what is your motherboard?
Panarello is offline   Reply With Quote
Old 07-11-04, 02:33 PM   #8
acidfourtyfive
Registered User
 
Join Date: Jul 2004
Posts: 2
Default Re: Problem with installing lan/network driver

I'm having the same problem. I don't quite understand what happened between the first post and second post. Anyway I'm going to go look for that tarball or gzip or whatever.

I'm what you might call a n00b <<

how did you get the package unpacked?

I found the tarball on the nvidia site...damn rpms :P I don't know why the RPM's didn't work but I'll look into it later when I need it again :P for now I have to start working on wlan mwahahah one step further

Last edited by acidfourtyfive; 07-11-04 at 04:38 PM.
acidfourtyfive is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphics driver installation problem (your comments will be highly appreciated) apuurboo NVIDIA GeForce 400/500 Series 0 06-16-12 07:35 AM
Graphics driver installation problem (your comments will be highly appreciated) apuurboo NVIDIA GeForce 400/500 Series 0 06-13-12 07:58 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Problem with Ethernet (nvnet) driver for RH 7.3 bernz NVIDIA Linux 4 08-05-02 10:18 AM
download problem with linux NVIDIA driver packages Timo NVIDIA Linux 7 07-31-02 09:22 AM

All times are GMT -5. The time now is 12:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.