Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-16-02, 05:50 PM   #1
cmarrin
Guest
 
Posts: n/a
Default XFree86 crash using PBuffers

I have a nforce 420D system running a Linux 2.4.x kernel and XFree86 4.2.x. I have a large OpenGL app which runs just fine. I run the X server at 1280x1024, 32 (or 24) bit. My app runs in a 640x480 window. I am creating a 640x480 PBuffer like this:

config = glXChooseFBConfig(...);
glxCreatePBuffer(..., config[0], ...);

The attrs I am passing to chooseFBConfig are causing it to return a single config, one that is compatible with the display window. When I do a queryDrawable on this pbuffer, it tells me that it is indeed a 640x480 buffer.

When I attempt to do a glXMakeContextCurrent() on this buffer, the XServer crashes with a segfault.

When I configure the X server for a 640x480 display instead of 1280x1024, everything works fine. On the higher res mode, if I create a 256x256 PBuffer, everything also works fine. A slightly larger PBuffer (300x300) crashes.

If you assume that the entire display is 32 bits, is doublebuffered and has a 32 bit zbuffer, then a 1280x1024 display uses around 15MB. A 256x256 pbuffer would use just under 1MB. A 300x300 pbuffer would push memory usage just over 16MB.

Looking at the X server's log and at the bios, it looks like there is 32MB allocated to the graphics chip. So it kind of seems like the system thinks there is 32MB of graphics memory but there is actually only 16MB.

Has anyone seen anything like this? I have looked around to try to find places that deal with allocating system memory to the graphics chips, but have found nothing of value. I even tried setting "VideoMem 16384" in my XF86Config file, but that seems to have no effect.

Any clues?
  Reply With Quote
Old 10-16-02, 08:18 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Please send a description and a sample app (if possible) to linux-bugs@nvidia.com.

Thanks!

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 10-18-02, 08:00 AM   #3
cmarrin
Guest
 
Posts: n/a
Default

Thanks, I did. I submitted a test case which crashes the X server, but requires a larger pbuffer (2Kx2K) to do it. I did not play with it to see how small a pbuffer would crash it. But I assume it requires a larger one than my app needed because I am using additional graphics memory for textures, etc.

Any idea on when I might see a response about this bug?
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 12:14 PM

All times are GMT -5. The time now is 06:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.