Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-05-04, 09:47 AM   #1
can564
Registered User
 
Join Date: May 2004
Posts: 7
Default How to nForce2 driver install

I am new to Linux but this is what I am trying to do.

I am using Fedora core 1 on my nForce2 AK79G-max motherboard.Fedora could not find my ethernet adapter.So I went to Nvidia and downloaded drivers in a tar and rpm format.There where not any Fedora specific drivers so I download the source rpm and kernel tar files.

I got the rpm and unzipped tar files on my desktop in Fedora.I decide to try the rpm first.I double clicked on it and nothing seemed to happen.I rebooted and my ethernet adapter was not detected.

Is there supposed to be a dialogue box when you use a rpm?How can I tell if it did anything?

Next I moved on to the tar files.The whole ball of wax has a make file.Then each folder(e.g. net,audio,etc) has it's own make file.Seeing as my primary concern is being able to get on the web I choose the net folder and clicked on the make file.I thought it would make drivers.Instead it just opened the make file in a text format.

Therefore:

1)How can I see if the RPM actually did anything?

2)How can I use the net folders make file to install drivers.

3)If the drivers do install will rebooting detect the ethernet adapter?Will it show up as a device in my network settings?
can564 is offline   Reply With Quote
Old 05-06-04, 05:31 AM   #2
can564
Registered User
 
Join Date: May 2004
Posts: 7
Default Re: How to nForce2 driver install

I found and copied this post.I realize many people are way past this proplem,but maybe it will help someone.The following is what I found on www.linuxquestions.org :

I think pretty much everyone with an NForce2 has this problem

Download and install nVidia's unified driver http://www.nvidia.com/object/linux_nforce_1.0-0261 (get the source tarball, not the rpm) and do the following steps:

1) tar xvfz nforce.tar.gz
2) cd /nforce/nvnet/
3) make && make install

Load up a text editor and open "/etc/modules.conf". Even if the file is empty, add the following line without the quotations: "alias eth0 nvnet" (not sure if this does anything, but you can also add the line "options nvnet optimization = 1")

6) netconfig
7) modprobe nvnet


After this you should be set. If you don't have the nVidia unified driver installed, go ahead and do that too (from either the source you have downloaded or the rpm if you feel better about it).

I think I read further in the post it was important to get the .rpm and right click and install it first even though it appeared to do nothing when I did this.Then move on to the .tar file directions.For me the modprobe nvnet failed to locate the nvnet module.But upon reboot it did detect my onboard LAN.Hope this helps somebody.
can564 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
How to install my nvdia driver... danyal_r NVIDIA Linux 2 10-11-02 12:06 PM
Getting bizarre errors with driver install clutch NVIDIA Linux 1 09-14-02 09:53 PM
NVIDIA driver doesn't install successfully on RH 7.3 Sunni NVIDIA Linux 3 08-28-02 02:30 PM

All times are GMT -5. The time now is 02:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.