Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-11-04, 03:45 PM   #1
Mr Marmalade
Refrigerated User
 
Mr Marmalade's Avatar
 
Join Date: Jul 2003
Location: Scotland.
Posts: 40
Default nvidia gf4mx440 PCI quake2

i gave up trying to get my AGP GF2 to work and went and got a GF4MX-440 PCI. my motherboards AGP chipset is unstable in linux, and pretty bad in windows. anyway, its a dual boot system and ive got my GF4 to work nicely at a stupidly high resoultion at a good framerate in windows (40-50ish, which is fine for a k6-2 500, 192mb ram).
the problem is running Quake2 in linux, and all openGL things, like GL screensavers. they stutter/pause a bit, and Q2 crashes eventually as it gets so upset at running so bad. i'm using the 5336 drivers, on slack9.1, a clean install; and the desktop works fine with the nvidia driver running.
i've just tried using the "sh ... --extract-only" option and change the AGP variable from 7 to 1, as i think that disables agp. does anyone know if the drivers automatically take care of this? (i never finished trying this as i can't remember how to then install it, i managed it when i was compiling for the aliagp workaround stuff!) its be a bit silly if the drivers were primarily designed for AGP cards.
i've also made sure the desktop bpp was set at 16-bit as i thought the running of a 32bit desktop with a 16bit Quake2 window might have caused it, but setting the desktop bpp to 16bit didnt help (is Quake2 16-bit only? i think it is...).
any ideas about whats causing this would be greatly appreciated, but i dont mean there'll be a cash reward or anything...
__________________
My Photos: http://photobucket.com/albums/v643/visual_etc/
PC: 486sx 25MHz, 4MB RAM, 1MB VLB Gfx.
Mr Marmalade is offline   Reply With Quote
Old 05-11-04, 04:18 PM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: nvidia gf4mx440 PCI quake2

As I read it you want to use the Geforce4MX Pci for linux and the Gf2 for windows. If that's the case then you don't need to play with AGP at all (if you leave the gf2 unconfigured / unused in Linux). I'm not fully sure what the problem is then except for stability problems.
Thunderbird is offline   Reply With Quote
Old 05-11-04, 06:59 PM   #3
Mr Marmalade
Refrigerated User
 
Mr Marmalade's Avatar
 
Join Date: Jul 2003
Location: Scotland.
Posts: 40
Default Re: nvidia gf4mx440 PCI quake2

i've only got gf4 in my system. using it for both win & linux. just need the gf4 to work in linux better.
__________________
My Photos: http://photobucket.com/albums/v643/visual_etc/
PC: 486sx 25MHz, 4MB RAM, 1MB VLB Gfx.
Mr Marmalade is offline   Reply With Quote
Old 05-12-04, 03:08 PM   #4
Mr Marmalade
Refrigerated User
 
Mr Marmalade's Avatar
 
Join Date: Jul 2003
Location: Scotland.
Posts: 40
Default Re: nvidia gf4mx440 PCI quake2

i found the bit to disable the AGP in the driver, just by passing Option "NvAGP" "0" in the XF86Config file (i wrongly thought i had to edit the os-registry.c file), but this still didnt fix it. i even commented-out the AGP modprobe part in /etc/rc.d/rc.modules, to stop that part of AGP. but still, Quake2 runs jerky, with a few messy frames, and then exits "Received signal 6, exiting..."

it's not a stabiliy problem, my pc is as stable, probably more stable than ever right now, even windows hasnt given me an error yet (or at least no stabilty-related ones)!!!

any other ideas?
__________________
My Photos: http://photobucket.com/albums/v643/visual_etc/
PC: 486sx 25MHz, 4MB RAM, 1MB VLB Gfx.
Mr Marmalade is offline   Reply With Quote
Old 05-13-04, 06:18 AM   #5
rednuht
GeForce FX5600 (1.0-5336)
 
rednuht's Avatar
 
Join Date: Sep 2003
Location: uk
Posts: 164
Default Re: nvidia gf4mx440 PCI quake2

from the readme

Problems will arise if applications use the wrong version of a library.
This can be the case if there are either old libGL libraries or stale
symlinks left lying around. If you think there may be something awry
in your installation, check that the following files are in place
(these are all the files of the NVIDIA Accelerated Linux Driver Set,
plus their symlinks):

/usr/X11R6/lib/modules/drivers/nvidia_drv.o

/usr/X11R6/lib/modules/extensions/libglx.so.x.y.z
/usr/X11R6/lib/modules/extensions/libglx.so -> libglx.so.x.y.z

/usr/lib/libGL.so.x.y.z
/usr/lib/libGL.so.x -> libGL.so.x.y.z
/usr/lib/libGL.so -> libGL.so.x

/usr/lib/libGLcore.so.x.y.z
/usr/lib/libGLcore.so.x -> libGLcore.so.x.y.z

/lib/modules/`uname -r`/video/nvidia.o, or
/lib/modules/`uname -r`/kernel/drivers/video/nvidia.o

Installation will also create the /dev files:

crw-rw-rw- 1 root root 195, 0 Feb 15 17:21 nvidia0
crw-rw-rw- 1 root root 195, 1 Feb 15 17:21 nvidia1
crw-rw-rw- 1 root root 195, 2 Feb 15 17:21 nvidia2
crw-rw-rw- 1 root root 195, 3 Feb 15 17:21 nvidia3
crw-rw-rw- 1 root root 195, 255 Feb 15 17:21 nvidiactl

If there are other libraries whose "soname" conflicts with that of
the NVIDIA libraries, ldconfig may create the wrong symlinks. It is
recommended that you manually remove or rename conflicting libraries
(be sure to rename clashing libraries to something that ldconfig will
not look at -- we have found that prepending "XXX" to a library name
generally does the trick), rerun 'ldconfig', and check that the correct
symlinks were made. Some libraries that often create conflicts are
"/usr/X11R6/lib/libGL.so*" and "/usr/X11R6/lib/libGLcore.so*".

If the libraries checks out, then verify that the application is using
the correct libraries. For example, to check that the application
/usr/X11R6/bin/gears is using the NVIDIA libraries, you would do:

$ ldd /usr/X11R6/bin/gears
libglut.so.3 => /usr/lib/libglut.so.3 (0x40014000)
libGLU.so.1 => /usr/lib/libGLU.so.1 (0x40046000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x40062000)
libc.so.6 => /lib/libc.so.6 (0x4009f000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x4018d000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40196000)
libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x401ac000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x401c0000)
libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x401cd000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x401d6000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x402ab000)
libm.so.6 => /lib/libm.so.6 (0x4048d000)
libdl.so.2 => /lib/libdl.so.2 (0x404a9000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x404ac000)

Note the files being used for libGL and libGLcore -- if they are something
other than the NVIDIA libraries, then you will need to either remove the
libraries that are getting in the way, or adjust your ld search path.
If any of this seems foreign to you, then you may want to read the man
pages for "ldconfig" and "ldd" for pointers.
rednuht is offline   Reply With Quote
Old 05-13-04, 04:19 PM   #6
Mr Marmalade
Refrigerated User
 
Mr Marmalade's Avatar
 
Join Date: Jul 2003
Location: Scotland.
Posts: 40
Default Re: nvidia gf4mx440 PCI quake2

i went through all those files, and they're all there, and all have the same installation timestamp. the only difference i have is this;

"crw-rw-rw- 1 root root 195, 0 Feb 15 17:21 nvidia0
...
crw-rw-rw- 1 root root 195, 3 Feb 15 17:21 nvidia3 <<<*
crw-rw-rw- 1 root root 195, 255 Feb 15 17:21 nvidiactl"

>>>* (this goes all the way up to 7 on my PC). i dont know why. i've tried both the 5336 & 4496 dirvers. the 4496 drivers additionally make some of the Q2 textures wonky and then crashed as per the 5336 drivers. i use the "nvidia-installer --uninstall" to remove them and even rebooted the pc between each stage.

i don't have GLX gears installed, but i ran some of the other oGL screensavers (euphoria & gravity, i think) and they keep skipping frames/stuttering.

i couldn't do the $ ldd /usr/local/games/quake2/quake2 ,... well i could but it only showed three lines of this sort of stuff;

"libglut.so.3 => /usr/lib/libglut.so.3 (0x40014000)
libGLU.so.1 => /usr/lib/libG.......etc." (from the bit you pasted, not my PC).

i even tried "$ldd /usr/local/games/quake2/quake2 +set vid_driver glx +set gl_driver libGL.so.1.0.4996", but that just confused it as the exrta bits obviously arent ldd parameters. that command is what i would use to select the libGL.so.1.0.4496 file since the default Q2 tarball has all sorts of Mesa & 3dfx files which i deleted as the nvidia files are surely newer.

i got q2 to work fine on another pc by having the q2 directory files the way they are, i dont think they're the problem (the other machine is a gf2 in an agp port).

hail me the linux retard; will i ever get Q2/openGL stuff to work on my PC?
__________________
My Photos: http://photobucket.com/albums/v643/visual_etc/
PC: 486sx 25MHz, 4MB RAM, 1MB VLB Gfx.
Mr Marmalade is offline   Reply With Quote
Old 05-13-04, 04:49 PM   #7
blueworm
[DEADAGAIN]blueworm
 
blueworm's Avatar
 
Join Date: Mar 2003
Posts: 416
Default Re: nvidia gf4mx440 PCI quake2

I swap you for a voodoo banshee wich works fine in quake2 and quake3...
__________________
Registered linux user #271604 Get Counted! http://counter.li.org/
lianLi PC60, OCZ powerStream 520W PSU, Asus P5N-E SLI, Core 2 duo E6550, 2Gb GEIL, XFX 8800GT, TB SantaCruz
blueworm is offline   Reply With Quote
Old 05-13-04, 06:43 PM   #8
Mr Marmalade
Refrigerated User
 
Mr Marmalade's Avatar
 
Join Date: Jul 2003
Location: Scotland.
Posts: 40
Default Re: nvidia gf4mx440 PCI quake2

i've got voodoo2 SLI's, but i couldn't get them to work either.
quake2 and me have serious issues.
__________________
My Photos: http://photobucket.com/albums/v643/visual_etc/
PC: 486sx 25MHz, 4MB RAM, 1MB VLB Gfx.
Mr Marmalade is offline   Reply With Quote

Old 05-13-04, 07:03 PM   #9
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: nvidia gf4mx440 PCI quake2

It might be a stupid question, but are you sure AGP is disabled? What do you see when you do

# cat /proc/drivers/nvidia/agp/status

And, just to be on the safe side, could you post your X log?
hppnq is offline   Reply With Quote
Old 05-14-04, 01:36 AM   #10
blueworm
[DEADAGAIN]blueworm
 
blueworm's Avatar
 
Join Date: Mar 2003
Posts: 416
Default Re: nvidia gf4mx440 PCI quake2

Quote:
Originally Posted by Mr Marmalade
i've got voodoo2 SLI's, but i couldn't get them to work either.
quake2 and me have serious issues.
How are you trying to install quake2 from source or a binary?
__________________
Registered linux user #271604 Get Counted! http://counter.li.org/
lianLi PC60, OCZ powerStream 520W PSU, Asus P5N-E SLI, Core 2 duo E6550, 2Gb GEIL, XFX 8800GT, TB SantaCruz
blueworm is offline   Reply With Quote
Old 05-14-04, 03:26 PM   #11
Mr Marmalade
Refrigerated User
 
Mr Marmalade's Avatar
 
Join Date: Jul 2003
Location: Scotland.
Posts: 40
Default Re: nvidia gf4mx440 PCI quake2

Here's my XF86Config (just the important bits i think & edited):

*********
Section "Module"
Load "dbe".
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
Load "type1"
Load "speedo"
Load "glx"
EndSection

Section "Device"
Identifier. "StandardVGA"
VendorName. "Unknown"
BoardName. "Unknown"
Driver "vga"
EndSection

Section "Device"
Identifier "Nvidia GeForce"
Driver "nvidia"
Option "NoLogo" "1"
Option "CursorShadow" "1"
Option "NvAGP" "0"
vendorname ""
boardname ""
EndSection
*********

I'm installing Q2 from CD, then working with;
quake2-3.20-glibc-i386-unknown-linux2.0.tar
I remove the following files from the directory;
libMesaGL.so.2.6 (and its two links)
lib3dfxgl.so
(i just copy /usr/lib/libGL.so.1.0.5336 into q2's directory and run q2 with it as the gl_driver).

*********
q2 isn't alone in its slowness, euphoriaGL screensaver has pauses in it.
i found this link last night;
http://www-106.ibm.com/developerwork...ary/l-hw2.html
and did $ cat /proc/interrupts
i got the following (again edited);

0: timer
1: keyboard
2: cascade
5: NE2000
8: rtc
9: EMU10K1
10: usb-ohci
14: ide0
15: ide1

there was no entry for a nvidia device as shown in the page i linked, which is maybe worrying. i made sure my bios was assigning an IRQ to PCI & that PnP Aware OS was disabled (i got a kernel panic when i tried to install the nvidia driver without 'IRQ Assigned to PCI' enabled in the BIOS), i tried to reinstall them since X didnt load under this setting.

I also did "$ cat /proc/driver/nvidia/agp/status" but got no such directory or filename. note there was no "drivers" directory, only "driver".

To disable AGP further i commented-out the modprobe (agpgart or something) line for it in /etc/rc.d/rc.modules.

I think i'll go play with the PCI latency in the BIOS, setpci & lspci -v...
Any other suggestions?

heh, & i really like this little smiley;
__________________
My Photos: http://photobucket.com/albums/v643/visual_etc/
PC: 486sx 25MHz, 4MB RAM, 1MB VLB Gfx.
Mr Marmalade is offline   Reply With Quote
Old 05-14-04, 03:59 PM   #12
Mr Marmalade
Refrigerated User
 
Mr Marmalade's Avatar
 
Join Date: Jul 2003
Location: Scotland.
Posts: 40
Default Re: nvidia gf4mx440 PCI quake2

ok, i've now tried various things.
in bios set pci latency to 248, no change.
flicked between pic & agp as being the primary display (even although i have no agp card in my system).
when i did the "$ cat /pric/interrupts" i wasn't in X, when i did it in X i saw the nvidia has IRQ 11.
i did "$ cat /proc/driver/nvidia/agp/host-bridge" and got;

Host Bridge: ALi Corporation M1541
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 2x 1x
Registers: 0x1b... blah ...000.

still. none of those helped...

Last edited by Mr Marmalade; 05-14-04 at 06:51 PM.
Mr Marmalade is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia 302.17 OpenGL not working 6200 PCI Archmbc NVIDIA Linux 1 06-18-12 12:23 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM

All times are GMT -5. The time now is 05:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.