Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-16-04, 08:40 AM   #1
Mistobaan
Registered User
 
Join Date: Apr 2004
Posts: 7
Exclamation Problems with FX5200 kern 2.6.5

Hi to all!!

I have a singular problem:
when xfree starts it gives to me a black screen.
I allegate my XFConfig and the log with startx -logverbose 5

Any Ideas?
Mistobaan is offline   Reply With Quote
Old 04-16-04, 08:46 AM   #2
Mistobaan
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Problems with FX5200 kern 2.6.5

using attachments
Attached Files
File Type: txt XF86Config.txt (17.4 KB, 179 views)
File Type: txt XFree86.0.txt (25.6 KB, 147 views)
Mistobaan is offline   Reply With Quote
Old 04-16-04, 08:48 AM   #3
Mistobaan
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Problems with FX5200 kern 2.6.5

More configuration try this time with frequencies changed.

The Monitor is an Acer AL1721
Attached Files
File Type: txt XF86Config.last.txt (17.4 KB, 143 views)
File Type: txt Log.last.txt (25.9 KB, 112 views)
Mistobaan is offline   Reply With Quote
Old 04-16-04, 10:20 AM   #4
pzgren
Registered User
 
pzgren's Avatar
 
Join Date: Jan 2004
Posts: 107
Default Re: Problems with FX5200 kern 2.6.5

Hi,
back to 1995? ... Setting mode "640x480" ;-)
Which braindead tool sets your nice Flatpanel to: hsync range of 28.00-33.00kHz

and as you know your monitor do not apply refresrates 60 is enough. Switch to 17'LCD default mode 1280x1024, to get an sharper picture, if that is what ACER suggests in the handbook and look there for the HorizSync! 32~80 kHz I think.
Here is my cut working XF86Config with nVidia drivers, nV AGP, Hyundai Flatpanel Imagequest L70S

------------------------------------------------
Code:
...
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Hyundai"
	ModelName    "LCD L70S"
	HorizSync    31.0 - 80.0
	VertRefresh  60.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "ASUS"
	BoardName   "NVIDIA GeForce FX 5700"
	Option	    "NvAGP" "1"
	Option 	    "NoBandWidthTest" "1"
	Option	    "DPMS" "on"
	Option	    "CursorShadow" "on"
#	Option	    "IgnoreDisplayDevices" "TV"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     16
	SubSection "Display"
		Depth     16
		Modes    "1280x1024" "1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes    "1280x1024" "1024x768" "800x600"
	EndSubSection
EndSection

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
-------------------------------------------------------

Do not apply it. You must specify in the "ServerLayout" the right names like
"Default Layout" etc. for tyour devices.
And do not try all this frequency hell. Delete this. Its from older times or older monitors. They talk now with the DDC. And do not use dfp in the driver config, its only for a real digital Flatpanel connected to the DVI. Yours is analog.

Marcus
__________________
Fedora Core 6
Notebook: DELL Inspiron 9400 - Core Duo T2400 - 17" WUXGA 7800 Go 256MB - 2 GB DDR2 667 MHz -
PC: AMD64 3200 - 1 GB Infi. PC400 - MSI K8N Neo Platinum NForce3 250GB - 80GB SATA Samsung - SB Live! 5.1 - GF 6600GT AGP
pzgren is offline   Reply With Quote
Old 04-16-04, 11:52 AM   #5
Mistobaan
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Problems with FX5200 kern 2.6.5

oops
Many thanks
I'll try to cheat with your configuration..
I'll tell you
Mistobaan is offline   Reply With Quote
Old 04-16-04, 12:51 PM   #6
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Problems with FX5200 kern 2.6.5

Hi,

you should add 'Load "ddc"' to your Modules section in XF86Config.

This way X will not try to torture your display with not possible resolutions/frequencies...
energyman76b is offline   Reply With Quote
Old 04-19-04, 05:19 AM   #7
Mistobaan
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Problems with FX5200 kern 2.6.5

Quote:
Originally Posted by energyman76b
Hi,

you should add 'Load "ddc"' to your Modules section in XF86Config.

This way X will not try to torture your display with not possible resolutions/frequencies...

Great Tip! Thanks.

pzgren I tried your configuration and didn't work, but after removing
comments from
# Option "IgnoreDisplayDevices" "TV"
It started!!

Ok now I can login in X... but it not very fast... I have like refresh problems
when I move frames.... any further tip?


Thanks in Advance
Mistobaan is offline   Reply With Quote
Old 04-19-04, 08:30 AM   #8
pzgren
Registered User
 
pzgren's Avatar
 
Join Date: Jan 2004
Posts: 107
Default Re: Problems with FX5200 kern 2.6.5

The DDC module was before loaded and is default..from your 1. log:
...
(II) Loading /usr/X11R6/lib/modules/libddc.a
...

Do you use KDE? ;-) Look again in your XF86.log if there is something still wrong. In your $HOME dir is the file .xsession-errors. Maybe there is the solution.

Marcus
__________________
Fedora Core 6
Notebook: DELL Inspiron 9400 - Core Duo T2400 - 17" WUXGA 7800 Go 256MB - 2 GB DDR2 667 MHz -
PC: AMD64 3200 - 1 GB Infi. PC400 - MSI K8N Neo Platinum NForce3 250GB - 80GB SATA Samsung - SB Live! 5.1 - GF 6600GT AGP
pzgren is offline   Reply With Quote

Old 04-19-04, 11:05 AM   #9
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Problems with FX5200 kern 2.6.5

Hi,

with 2.6.5 it is 'normal' that windows are have a lagging 'shadow' in the first seconds of running
energyman76b is offline   Reply With Quote
Old 04-21-04, 08:31 AM   #10
Mistobaan
Registered User
 
Join Date: Apr 2004
Posts: 7
Question Re: Problems with FX5200 kern 2.6.5

More hacks done:
Changed
Code:
Option	    "NvAGP" "1"
to
Code:
Option	    "NvAGP" "0"
Seems faster but still is slow on refresh..

I put my Dmesg.. Maybe I have done something wrong...
Attached Files
File Type: txt dmesg.txt (10.8 KB, 102 views)
Mistobaan is offline   Reply With Quote
Old 04-21-04, 12:17 PM   #11
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: Problems with FX5200 kern 2.6.5

Your dmesg doesnot say anything is wrong, try other nvagp modes as If I use 3 and 2 with the 5336 I get slow redraw. The 4620 driver is worth a try.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 04-27-04, 03:48 AM   #12
Mistobaan
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Problems with FX5200 kern 2.6.5

Quote:
Originally Posted by SuLinUX
Your dmesg doesnot say anything is wrong, try other nvagp modes as If I use 3 and 2 with the 5336 I get slow redraw. The 4620 driver is worth a try.
Do you suggest to install the old driver?
Mistobaan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with drivers after 295.40 (OpenSuSE 12.1, GeFroce 7900 GS, Phenom II X4) alawa NVIDIA Linux 0 06-09-12 06:37 PM
Nvidia Problems in Slackware 8.1 xtreme NVIDIA Linux 3 10-01-02 12:03 PM
DirectX 8 problems with GeForce4 Derwin NVIDIA GeForce 7, 8, And 9 Series 19 08-20-02 01:23 AM

All times are GMT -5. The time now is 04:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.