Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-09-04, 04:41 PM   #1
DaveHope
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Debian 2.6.5 nvidia driver issues

Hello all,
having just moved from a working 2.4.* to 2.6.5 I'm having some problems, having reinstalled the nvidia drivers (5336) and editing XF86Config-4 as needed, I'm getting very poor performance (like I was using the non-official driver) looking at my XFree86 log file, I'm seeing the following which could be a cause for concern.
Quote:
(II) LoadModule: "pex5"
(WW) Warning, couldn't open module pex5
(II) UnloadModule: "pex5"
(EE) Failed to load module "pex5" (module does not exist, 0)

(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o": No symbols found

(II) LoadModule: "xie"
(WW) Warning, couldn't open module xie
and the relevant sections of XF86Config file...
Quote:
Section "Module"
Load "glx"
Load "dbe"
Load "extmod"
Load "glx"
Load "pex5"
Load "record"
Load "speedo"
Load "xie"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection
Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "Rotate" # [<str>]
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV11 [GeForce2 MX/MX 400]"
BusID "AGP:1:0:0"
EndSection
X actually works, but like I said, I'm getting VERY poor performancs from glxgears..i.e.
66 frames in 5.0 seconds = 13.200 FPS

Any help here would be appreciated...
DaveHope is offline   Reply With Quote
Old 05-10-04, 04:08 AM   #2
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: Debian 2.6.5 nvidia driver issues

Unless you've also upgraded X, the errors you get should have been there in your previous configuration as well. The speedo error is probably caused by incorrect settings of either your fontpath in XF86Config or the xfs configuration, I can only assume that the pex5 and xie extensions are in fact missing. Please post your XF86Config and the full X log so we can have a look at it.

Have you dealt with the 4K stacks issue, by the way? (Search this forum for more information if necessary.) Also, check whether you are using the libraries that came with the driver, and not the X ones. (See the README included with the driver for a detailed discussion.) Uninstalling the driver completely before re-installing might solve some issues here.
hppnq is offline   Reply With Quote
Old 05-10-04, 04:17 AM   #3
DaveHope
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Debian 2.6.5 nvidia driver issues

Alright, when I get home (4:30 GMT+0 ish) I'll post my X log and XF86Config-4 file. Never heard of the 4k stack issue, will search the forum now..But I don't think so, and yet it worked fine with my 2.4.* kernel (with the deb packages from apt).
DaveHope is offline   Reply With Quote
Old 05-10-04, 04:24 AM   #4
DaveHope
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Debian 2.6.5 nvidia driver issues

Just a quick update after searching, no I have not dealt with the 4k stack issue, I'm using an unmodified stock debian 2.6.5 kernel (2.6.5-1-k7).
DaveHope is offline   Reply With Quote
Old 05-10-04, 04:30 AM   #5
DaveHope
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Debian 2.6.5 nvidia driver issues

One thing has just struck me, with the 2.4 packages I was using (from apt) I had 2 packages, nvidia-kernel-something and NVIDIA-GLX (or similar) I was wondering, with my 2.6 and the nvidia driver I compiled, will I need the NVIDIA-GLX package again? and if so, where can I get it? (the one in apt is at current, specific to the 2.4.* kernel)...
DaveHope is offline   Reply With Quote
Old 05-10-04, 04:48 AM   #6
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: Debian 2.6.5 nvidia driver issues

From what I've heard Debian's apt is exceptionally good, so a simple apt-get nvidia-glx should do the trick. I don't really know though. It *is* a good idea to install this package (again). In principle the Nvidia driver is shipped with the GLX extension and supporting libraries, so you should first check whether everything was installed properly (consult the README that came with the driver).

You should really configure your kernel to use 8K stacks, instead of 4K. There are plenty of pointers on this forum about how to accomplish that. Basically, you will have to reconfigure the kernel using 'make menuconfig' for instance, recompile and install the kernel (and boot it of course). The Nvidia driver will not work (properly), when using 4K stacks. If your kernel is already configured to use 8K stacks, you don't have to do anything, of course.
hppnq is offline   Reply With Quote
Old 05-10-04, 04:57 AM   #7
DaveHope
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Debian 2.6.5 nvidia driver issues

I cannot install the package again as it requires a 2.4.* kernel :/ Any way I can find out if I'm using 4 or 8k stacks?
DaveHope is offline   Reply With Quote
Old 05-10-04, 06:05 AM   #8
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: Debian 2.6.5 nvidia driver issues

I cannot really help you with Debian specific issues, please visit this for a Howto that addresses upgrading to the 2.6 kernel: http://home.comcast.net/~andrex/Debian-nVidia/ (there's a lot more to find on various forums, including this one).

You can check whether your kernel uses 4K stacks by checking your .config:

# grep CONFIG_4KSTACKS /usr/src/linux/.config
CONFIG_4KSTACKS=n

If it says something else, or it says nothing at all, or you have no .config, you will have to configure the kernel, compile and install it. (All this assuming your kernel sources *are* in /usr/src/linux, btw. ;-)

Last edited by hppnq; 05-10-04 at 09:16 AM. Reason: It said: "... your sources are not in /usr/src/linux ...". ;-)
hppnq is offline   Reply With Quote

Old 05-10-04, 09:06 AM   #9
DaveHope
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Debian 2.6.5 nvidia driver issues

Alright, thanks...I'll post my logfiles when i get home and check about this stack issue..
DaveHope is offline   Reply With Quote
Old 05-10-04, 11:18 AM   #10
DaveHope
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: Debian 2.6.5 nvidia driver issues

Ok, now this is very weird indeed...for no valid reason atall, I got home, booted up the machine and fired up glxgears and it works fine, woo! Gotta love that randomness!
DaveHope is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 11:03 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM
Nvidia driver 1.0-3123 VIA 4x issues. dcstimm NVIDIA Linux 8 09-29-02 09:34 PM

All times are GMT -5. The time now is 01:53 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.