Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-13-04, 03:23 PM   #1
cdrradar
Registered User
 
Join Date: Dec 2002
Posts: 17
Default GLX causes Signal 11

FATAL

Any attempt to run any program that uses GLX causes signal 11, causing immediate X shutdown. With TV-OUT enabled, this hangs the system, forcing cold-reboot. This aside, I have disabled TV-OUT in order to diagnose this problem.

glxgears is the test program I have been using. I've read through the README file and followed hints and instructions to repair this problem to the best of my ability, but I've run out of ideas. I'm not going to prejudice anything by posting my own theories - I've attached a .zip file containing just about everything I can think of, including log files, directory contents, and so on.

Distribution: Slackware 9.1
Kernel: linux-2.4.26
X related: Dropline GNOME 2.6.0
XOrg 6.7.0 Gnome 2.6.0
Card chipset: GeForce 4 Ti4200 128M memory
Nvidia driver: 5336

Contents of nvidiabug.zip:
Code:
cdrradar@aribeth:~/nvidiabug$ zip nvidiabug *
  adding: XF86Config.single.nvidia (deflated 68%)
  adding: Xorg.0.log (deflated 79%)
  adding: console.perms (deflated 64%)
  adding: glxgears.ldd (deflated 59%)
  adding: ls-l (deflated 79%)
  adding: xpdyinfo.out (deflated 90%)
Any additional information that's needed, please ask.
Attached Files
File Type: zip nvidiabug.zip (10.7 KB, 208 views)
cdrradar is offline   Reply With Quote
Old 05-13-04, 03:38 PM   #2
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: GLX causes Signal 11

Probably you haven't installed the Nvidia driver correctly. The driver comes with both its own libraries, as well as the X extension. Your X log indicates that you are loading the X provided glx extension -- if the driver is installed properly, it should say something like "vendor=Nvidia" .

Furthermore, the ldd output shows that glxgears is linked with the GLX library provided by X, not the one supplied with the Nvidia driver. The latter should be in /usr/lib/tls (this should be reflected in the ldd output).

Try uninstalling the driver and re-install it from scratch. The README in the driver package provides the exact information regarding GLX, if you follow it everything should be fine.
hppnq is offline   Reply With Quote
Old 05-13-04, 03:43 PM   #3
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: GLX causes Signal 11

Mmmh... From your ls output I gather that you have an unusual setup. ;-) Sorry, I was a bit too quick, I'll take a closer look.

In any case, uninstalling and re-installing won't hurt and it might solve your problem. You do load the wrong extension, even though ls seems to indicate otherwise.

UPDATE: remove /usr/X11R6/lib/modules/extensions/libglx.a or move it to another directory and try running glxgears again. That should probably do it.
hppnq is offline   Reply With Quote
Old 05-14-04, 12:29 AM   #4
cdrradar
Registered User
 
Join Date: Dec 2002
Posts: 17
Thumbs up Re: GLX causes Signal 11

Quote:
Originally Posted by hppnq
Mmmh... From your ls output I gather that you have an unusual setup. ;-) Sorry, I was a bit too quick, I'll take a closer look.

In any case, uninstalling and re-installing won't hurt and it might solve your problem. You do load the wrong extension, even though ls seems to indicate otherwise.

UPDATE: remove /usr/X11R6/lib/modules/extensions/libglx.a or move it to another directory and try running glxgears again. That should probably do it.
root@aribeth:~# cd /usr/X11R6/lib/modules/extensions
root@aribeth:/usr/X11R6/lib/modules/extensions# mv libglx.a a.xlgbil
root@aribeth:/usr/X11R6/lib/modules/extensions# ldconfig

That's what I did, then started X with the given config file. glxgears ran. Full screen, average 370 FPS. I know I can tweak that by not running gnome, probably a couple other tweaks here and there, however that's not the point - point is that the problem's fixed.

Thanks, hppnq.
cdrradar is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 02:24 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
GLX bug? (1.0-3123) marc NVIDIA Linux 2 09-21-02 05:58 PM
Remote Accelerated GLX and Raster Display Oddity dzzero NVIDIA Linux 2 09-18-02 02:59 PM
Problem with GLX(?) Nykolas NVIDIA Linux 4 08-12-02 03:24 PM

All times are GMT -5. The time now is 04:14 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.