Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-15-02, 03:13 AM   #1
Wild-Child
Guest
 
Posts: n/a
Angry NVdriver kernel does'nt load....

Hi friends, i have some trouble in installing my NV drivers, first i want to excuse me for my bad english (i'm french) and for my ignorance about linux (it's the first time i instal it on my comp...)..
So here is my problem, i have followed all steps given later (rpm, edit the config file...), but when i execute the nv_check.sh , all files seems to be present but when it check if the kernel module is loaded it tells me:"
the NVdriver module does not seem to be loader.
The 3d driver will not work without it..
please compile it for your kernel,set it up to insert module on boot then run this script again..."

But as i a totally newbie for linux i don't know what it mean so i would appreciate if someone could tell me step by step what i have to do or what i forgoten in my procesus of installation...
My distri is Mandrake 8.2 and i have Ti 4200 but i think it's no't very important details..

So i thant you in advance for any answer (i checked the faq in the readme but i don't understant anything for the kernel part)...
merci beaucoup
Wild-Child
  Reply With Quote
Old 10-15-02, 09:01 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

To fix that problem in nv_check, do an /sbin/modprobe NVdriver as root. Then rerun the script.

To tell you the truth, I'm not sure why this specific check is in that script -- it is true that nothing will work without that module loaded, but if you're not running X when you run that script, then you don't need the module loaded.

I guess it's more of a fool-proof thing than anything else...

Anyway, if that script runs with no problems after you've modprobe'd NVdriver, then edit /etc/modules.conf and add a line to it:

alias /dev/nvidia* NVdriver

This will make the module load whenever X loads (because the X driver tries to open /dev/nvidia0 and/or /dev/nvidiactl, and when it does that and the files don't exist, the devfsd program that Mandrake is running sends a request off to modprobe asking it to load anything that will provide those device files; adding this line to modules.conf tells modprobe that NVdriver will provide these devices, which it will).

I don't know where you got nv_check.sh from, but you might want to try the version I've hacked on, here. I've added a bunch of checks that the original script didn't do on your config file, and I've also made it valid to have only /dev/nvidiactl and /dev/nvidia0, if you are running devfs. Because if you are, then those are the only device files you need -- however, if you don't have /dev/nvidia[1-3], the original script will puke at that check, and it shouldn't.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-15-02, 03:13 PM   #3
Wild-Child
Guest
 
Posts: n/a
Angry

Ok thanks, i tried what you told me , there was already the line "alias /dev/nvidia* NVdriver " in the module.conf but it doesn"t seem to work, the link for your nv_check.sh doen't work for me and when i checking with the one i have it tells me:"
The Kernel device /dev/nvidia1 does not exist, is not a device or does not have the proper permisions set.This dev entry should have been created when you created the kernel module. if you compiled the module by hand you may have to create this device manually..........."

I don't understand anything because with what you told me evrything soud work...
What i have made wrong?

Thanks for any answer
  Reply With Quote
Old 10-15-02, 10:15 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Whoops, sorry about that, I forgot to change the permissions when I put that script on my web server. That link should work now, and I have to remember to start checking these kinds of things...

The error it's giving you about "/dev/nvidia1" is one of the things that I fixed in the version linked above. It shouldn't matter whether or not nvidia1 is there, if you only have one card (which it seems you do).

If the alias is there and you've run /sbin/depmod -a, then if you reboot (or do an /sbin/modprobe -r NVdriver, either way) and then do an /sbin/modprobe /dev/nvidia0 as root, and then an /sbin/lsmod, does NVdriver show up in the list? If so, then the alias at least is working properly.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-16-02, 06:59 AM   #5
Wild-Child
Guest
 
Posts: n/a
Unhappy

Ok i tried evrythings you told me but when i reboot and i run the nvcheck it desn't work, and if a do the "sbin/modprobe NVdriver and run the nvcheck , the nvcheck tells me that evrything works , but when a reboot the nvcheck tells me that the is a problem with the kernel as at the beginning....

Tell me how do i know that my geforce is really installed? does it tells me in the Hardrak thing?

thanks for helping me
  Reply With Quote
Old 10-16-02, 07:48 AM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

No, harddrake won't recognize this driver. It might recognize this card, though, which means it might try to roll back to the VESA driver. Don't let it.

Mandrake 8.2, huh...

Actually, what happens if you reboot and just try to startx? My guess is that it'll work.

The nv_check says the module isn't loaded, but in fact, you don't need it until the moment you try to start X using Driver "nvidia" in the config file. So this might not be a problem, as long as startx works.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-21-02, 04:23 PM   #7
wolf
Registered User
 
Join Date: Oct 2002
Posts: 5
Default

bwkaz,

let me jump in here. I have exactly the same problem as Wild-Cat. I have followed all of your instructions (because I had pretty much the same problems).

Your version of nv_check.sh tells me everything is fine, but nothing seems to work.
GLX does not load and I do not get the splash screen.

I attach my XF86CONFIG-4

Please help!

BTW: Starting startx after reboooting doesn't do the trick
BTW2: I'm using MDK 9.0
wolf is offline   Reply With Quote
Old 10-21-02, 04:26 PM   #8
wolf
Registered User
 
Join Date: Oct 2002
Posts: 5
Default

Oops, the attachment didn't work...
Attached Files
File Type: txt xf86config-4.txt (2.7 KB, 106 views)
wolf is offline   Reply With Quote

Old 10-21-02, 08:39 PM   #9
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
Option "NvAgp" "X"
Does either commenting this line out, or changing the X to 0, 1, 2, or 3 (the effects of all of these are documented in the README) help?

If not, post your /var/log/XFree86.0.log file as well.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-22-02, 01:59 AM   #10
wolf
Registered User
 
Join Date: Oct 2002
Posts: 5
Default

Changing the NvAgp option didn't do anything. I commented it out again.

I enclose my XFree86.0.log file. Strangely it seems to date from sunday. Although I have launched X (by using startx) quite a couple of times since. Maybe there is another log-file somewhere else!?!
Attached Files
File Type: txt xfree86.0.log.txt (23.4 KB, 105 views)
wolf is offline   Reply With Quote
Old 10-22-02, 09:37 AM   #11
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

It shouldn't be anywhere else... of course, this doesn't mean it isn't anywhere else, but I've never seen it end up anywhere else. Hmm...

What other files are in /var/log?

If you can't find anything that looks promising, it would be possible to (temporarily, of course) replace your XFree86 binary with a script that just echoes its command-line arguments. That way, if your X scripts are telling it to put its logs somewhere else, this would tell you where. Once you know where the file is, you can go back to the real XFree86 binary.

If you want to do this, first mv /usr/X11R6/bin/XFree86 /usr/X11R6/bin/XFree86-old, then create a new file, containing the following:

Code:
#!/bin/sh

echo "\"$0\""

while [ $# -gt 0 ] ; do
    echo "\"$1\""

    shift
done
Make this file executable chmod a+x <filename>, and try running it a couple of times to make sure it works. It should put quotes around each argument. If it seems to work satisfactorily, move it to /usr/X11R6/bin/XFree86, and try to startx again. Nothing will happen, except that you'll get a bunch of arguments in the console. If none of them are the log file, then I'm not sure where it would be. In any case, mv /usr/X11R6/bin/XFree86-old /usr/X11R6/bin/XFree86 will restore your old X binary.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-22-02, 10:09 AM   #12
PaladinCowboy75
Registered User
 
PaladinCowboy75's Avatar
 
Join Date: Oct 2002
Location: Bedford, Texas
Posts: 8
Send a message via AIM to PaladinCowboy75 Send a message via Yahoo to PaladinCowboy75
Default ...

Hey guys.... I'm in the same boat.... MDK 9.0 user with a NVidia kernal not initializing error. tried installing from rpm and src... src won't even build. Had to re-install Linux to get GUI back. Following along with ya'll hoping to get my NVidia drivers working.
__________________
-----BEGIN GEEK CODE BLOCK-----
Version: 3.1
GIT GCS d- s: a- c++ UL P L+ E? W+ N o? k? w+ O- M-- V-- PS
PE+ Y PGP t+ 5 X++ R+ tv- b++ DI++++ D++ G e+ h---- r+++ y+++
------END GEEK CODE BLOCK------
registered Linux user #290975
PaladinCowboy75 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[BUG] nvidia crashes kernel with 'Xid 13' and attempted to yield the CPU while atomic rockob NVIDIA Linux 36 09-26-12 08:48 AM
upgrade to xorg server 1.13 damaged Geforce 7300 GT KDE NVIDIA Linux 2 09-07-12 09:04 AM
Fatal upgrade: from bad (8800 GTS) to worse 9GTX 560 Ti) ssnyder NVIDIA Linux 1 07-01-12 09:14 PM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 05:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM

All times are GMT -5. The time now is 04:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.