Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-16-04, 10:21 AM   #1
jgeorger
Registered User
 
Join Date: Mar 2004
Posts: 7
Default xinerama & 2 Nvidia cards - Help

I just got a dual-Opteron system, Tyan Thunder K8W. Installed Suse 9.0 Pro AMD64. Bought 2 Nvidia cards with express intent of using dvi connectors to 2 Samsung 21.3" LCD's. Got a FX5900 Ultra and a PCI FX5200. Everything seems to be detected by Suse; however, the 2nd monitor (the one hooked to the PCI 5200) never comes on. If, in the bios I change the VGA boot option from AGP to PCI, then the 5200 takes over and the 5900 never does anything. Here is a snippet from the XFree86.0.log file:

(EE) NVIDIA(1): Failed to initialize the NVIDIA graphics device!
(EE) NVIDIA(1): *** Aborting ***

I don't know why it's failing. Any help appreciated...

Thanks,
Joe

And here is my XF86Config file:

# /.../
# SaX generated XFree86 config file
# Created on: 2004-03-16T09:10:49-0500.
#
# Version: 4.7
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.7)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
Option "RandR" "on"
EndSection

Section "Module"
Load "type1"
Load "extmod"
Load "dbe"
Load "glx"
Load "speedo"
Load "freetype"
Load "v4l"
EndSection

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
DisplaySize 360 270
HorizSync 29-95
Identifier "Monitor[0]"
ModelName "1600X1200@60HZ"
Option "DPMS"
VendorName "--> LCD"
VertRefresh 40-62
UseModes "Modes[0]"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
DisplaySize 360 270
HorizSync 29-95
Identifier "Monitor[1]"
ModelName "1600X1200@60HZ"
Option "DPMS"
VendorName "--> LCD"
VertRefresh 40-62
UseModes "Modes[1]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1600x1200" 160.96 1600 1704 1880 2160 1200 1201 1204 1242
EndSection

Section "Modes"
Identifier "Modes[1]"
Modeline "1600x1200" 160.96 1600 1704 1880 2160 1200 1201 1204 1242
EndSection


Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 32
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 8
Modes "1600x1200"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 32
Modes "1600x1200"
EndSubSection
SubSection "Display"
Depth 8
Modes "1600x1200"
EndSubSection
Device "Device[1]"
Identifier "Screen[1]"
Monitor "Monitor[1]"
EndSection


Section "Device"
BoardName "GeForce FX 5900 Ultra"
BusID "5:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
Option "IgnoreEDID"
VendorName "NVidia"
EndSection

Section "Device"
BoardName "0x0322"
BusID "3:10:0"
Driver "nvidia"
Identifier "Device[1]"
Screen 0
Option "Rotate" "off"
Option "IgnoreEDID"
VendorName "NVidia"
Option "ConnectedMonitor" "DFP"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "on"
Screen "Screen[0]"
Screen "Screen[1]" RightOf "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection
jgeorger is offline   Reply With Quote
Old 03-17-04, 09:28 AM   #2
jgeorger
Registered User
 
Join Date: Mar 2004
Posts: 7
Default

I upgraded the Thunder's bios to 1.02. I've also noticed that my AGP is not enabled according to /proc/driver/nvidia/agp/status. Not sure if that is related to my lack of dual-head but I sure would like to have it work as well.

I've also tried using the Int 10 module to softboot the secondary card. No effect. I've eliminated "Option" "DPMS" from both Monitor sections since in the driver README it mentioned having some issue with that....

I am running kernel 2.4.21-102-smp if that matters....

Time for me to email Nvidia directly or what?
jgeorger is offline   Reply With Quote
Old 03-17-04, 09:35 AM   #3
jgeorger
Registered User
 
Join Date: Mar 2004
Posts: 7
Default more system info

I've attached my XFree86.0.log file. I am running the 5332 drivers. The 5900 Ultra is an Asus. Bios: 04.35.20.22.00. The 5200 is a Chaintech. I don't know the bios of that one because it doesn't show up in X..... The Opteron's are 246's.... I think that's about it......
Attached Files
File Type: log xfree86.0.log (36.3 KB, 144 views)
jgeorger is offline   Reply With Quote
Old 05-17-04, 12:45 PM   #4
esterhui
Registered User
 
Join Date: May 2004
Posts: 1
Default Re: xinerama & 2 Nvidia cards - Help

Did you ever find a solution to this? I have also two Nvidia cards and can only get ONE of them running at a time (depending on BIOS init PCI/AGP first).
esterhui is offline   Reply With Quote
Old 05-17-04, 01:51 PM   #5
jgeorger
Registered User
 
Join Date: Mar 2004
Posts: 7
Default Re: xinerama & 2 Nvidia cards - Help

Nope. I can't think of anything else to do. I did get Twinview working but that means one of my monitors is hooked to the db15. I'm thinking about getting a Quadro or FX makes a 5700 Ultra that has 2 dvi ports.
jgeorger is offline   Reply With Quote
Old 05-18-04, 12:05 PM   #6
skinny_p
Registered User
 
Join Date: Dec 2003
Location: France
Posts: 8
Default Re: xinerama & 2 Nvidia cards - Help

Section "Device"
BoardName "GeForce FX 5900 Ultra"
BusID "5:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
Option "IgnoreEDID"
VendorName "NVidia"
EndSection

Section "Device"
BoardName "0x0322"
BusID "3:10:0"
Driver "nvidia"
Identifier "Device[1]"
Screen 0
Option "Rotate" "off"
Option "IgnoreEDID"
VendorName "NVidia"
Option "ConnectedMonitor" "DFP"
EndSection

Both video card same screen 0?

here my xf86config-4 with one card 2 screens
and take a look at Section "ServerLayout"
may be =)


# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "/usr/X11R6/lib/modules/extensions/libglx.so"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor0"
VendorName "Generic"
ModelName "1600x1200 @ 74 Hz"
HorizSync 31.5-82
VertRefresh 50-90

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1280x1024 @ 60 Hz"
HorizSync 31.5-64.3
VertRefresh 50-70

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "nvidia0"
VendorName "NVidia"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Screen 0
BusID "1:0:0"
Option "DPMS"
Option "IgnoreEDID" "1"
#Option "TwinView"
#Option "SecondMonitorHorizSync" "31.5-64.3"
#Option "SecondMonitorVertRefresh" "50-70"
#Option "MetaModes" "1600x1200,1280x1024"
Option "CursorShadow" "1"
Option "ConnectedMonitor" "CRT, CRT"
Option "NvAGP" "2"
Option "DigitalVibrance" "2"
Option "CursorShadowAlpha" "64"
Option "CursorShadowYOffset" "2"
Option "CursorShadowXOffset" "4"
EndSection

Section "Device"
Identifier "nvidia1"
VendorName "NVidia"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Screen 1
BusID "1:0:0"
Option "DPMS"
Option "IgnoreEDID" "1"
Option "CursorShadow" "1"
Option "ConnectedMonitor" "CRT, CRT"
Option "NvAGP" "2"
Option "DigitalVibrance" "0"
Option "CursorShadowAlpha" "64"
Option "CursorShadowYOffset" "2"
Option "CursorShadowXOffset" "4"
EndSection

Section "Screen"
Identifier "screen0"
Device "nvidia0"
Monitor "monitor0"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1600 1200
EndSubsection

Subsection "Display"
Depth 15
Virtual 1600 1200
EndSubsection

Subsection "Display"
Depth 16
Virtual 1600 1200
EndSubsection

Subsection "Display"
Depth 24
Virtual 1600 1200
EndSubsection
EndSection

Section "Screen"
Identifier "screen1"
Device "nvidia1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen 0 "screen0"
#Option "Xinerama"
Screen 1 "screen1" RightOf "screen0"
EndSection
skinny_p is offline   Reply With Quote
Old 05-18-04, 02:01 PM   #7
jgeorger
Registered User
 
Join Date: Mar 2004
Posts: 7
Default Re: xinerama & 2 Nvidia cards - Help

Thanks I never noticed that. Not sure if that is the cause of my problems since I did try many many variations. However I will try it when I get a chance and reply here with my results.
jgeorger is offline   Reply With Quote
Old 05-19-04, 03:10 PM   #8
jgeorger
Registered User
 
Join Date: Mar 2004
Posts: 7
Default Re: xinerama & 2 Nvidia cards - Help

Okay I made the change to Screen 1 in the 2nd device category to no effect. The thing is, I only get one monitor up even at boot. I am not sure the video card is being turned on in the bios. Under the advanced menu there is a agp/pci selection "select boot from agp or pci". Depending on which one I select controls which video card is used, and the other is never used (the other monitor never goes on).
jgeorger is offline   Reply With Quote

Old 05-19-04, 08:34 PM   #9
skinny_p
Registered User
 
Join Date: Dec 2003
Location: France
Posts: 8
Default Re: xinerama & 2 Nvidia cards - Help

Section "Device"
BoardName "GeForce FX 5900 Ultra"
BusID "5:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
Option "IgnoreEDID"
VendorName "NVidia"
EndSection

Section "Device"
BoardName "0x0322"
BusID "3:10:0"
Driver "nvidia"
Identifier "Device[1]"
Screen 1
Option "Rotate" "off"
Option "IgnoreEDID"
VendorName "NVidia"
Option "ConnectedMonitor" "DFP"
EndSection

You forgot this section

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "on"
Screen 0 "Screen[0]"
Screen 1 "Screen[1]" RightOf "Screen[0]"
EndSection
skinny_p is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
NVIDIA could rule if they really wanted to Vid_craze NVIDIA GeForce 7, 8, And 9 Series 25 08-16-02 05:24 PM

All times are GMT -5. The time now is 04:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.