Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-20-04, 09:14 PM   #1
exitchannel
Registered User
 
Join Date: May 2004
Posts: 1
Default Can't Load nvidia.o on RHEL AS kernel 2.4.9-e.34

I can't get a custom built Nvidia module to load once it has been built.

This is for a AsusAsusTek V9570/TD AGP 256MB video card (FX 5700)

Here is the pertinent part of the nvidia-installer.log

---------------------------------------------------------------------
ld -r -o nv-linux.o nv.o os-agp.o os-interface.o os-registry.o
ld -r -o nvidia.o nv-linux.o nv-kernel.o
-> done.
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.o'. This is most likely
because the kernel module was built using the wrong kernel source files.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
'--kernel-source-path' commandline option.
-> Kernel module load error: ./usr/src/nv/nvidia.o: unresolved symbol
irq_stat_R05b229ca
./usr/src/nv/nvidia.o: unresolved symbol mem_map_R55dd8c2c
./usr/src/nv/nvidia.o: unresolved symbol highmem_start_page_R09852238
./usr/src/nv/nvidia.o: unresolved symbol proc_root_driver_R47caae92
./usr/src/nv/nvidia.o: unresolved symbol remove_proc_entry_Rd057a152
./usr/src/nv/nvidia.o: unresolved symbol init_mm_R061f3b76
./usr/src/nv/nvidia.o: unresolved symbol create_proc_entry_Rf42ad457
./usr/src/nv/nvidia.o: unresolved symbol __pollwait_R600a3056
./usr/src/nv/nvidia.o: unresolved symbol remap_page_range_Rb6903136
./usr/src/nv/nvidia.o: unresolved symbol register_chrdev_R7ed3659d
./usr/src/nv/nvidia.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. The module may be trying to access
GPLONLY symbols but the problem is more likely to be a coding or
user error. Contact the module supplier for assistance, only they
can help you.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
----------------------------------------------------------------------------

Here is my /usr/src directory

lrwxrwxrwx 1 root root 16 May 20 11:45 linux -> linux-2.4.9-e.34
lrwxrwxrwx 1 root root 16 May 20 10:43 linux-2.4 -> linux-2.4.9-e.34
drwxr-xr-x 17 root root 4096 May 20 14:05 linux-2.4.9-e.34
drwxr-xr-x 7 root root 4096 May 17 05:12 redhat


Here is uname -r

2.4.9-e.34

Installed the kernel source from

kernel-source-2.4.9-e.34.i386.rpm

And here is my /boot directory

-rw-r--r-- 1 root root 5824 Jun 24 2001 boot.b
-rw-r--r-- 1 root root 612 Jun 24 2001 chain.b
drwxr-xr-x 2 root root 1024 May 20 14:59 grub
-rw-r--r-- 1 root root 537517 May 17 04:44 initrd-2.4.9-e.34.img
lrwxrwxrwx 1 root root 14 May 17 04:43 kernel.h -> kernel.h-2.4.9
-rw-r--r-- 1 root root 472 May 17 04:43 kernel.h-2.4.9
drwx------ 2 root root 12288 May 17 04:39 lost+found
-rw-r--r-- 1 root root 23108 Jun 24 2001 message
lrwxrwxrwx 1 root root 22 May 17 04:44 module-info -> module-info-2.4.9-e.34
-rw-r--r-- 1 root root 13599 Dec 10 14:07 module-info-2.4.9-e.34
-rw-r--r-- 1 root root 640 Jun 24 2001 os2_d.b
lrwxrwxrwx 1 root root 21 May 17 04:44 System.map -> System.map-2.4.9-e.34
-rw-r--r-- 1 root root 448948 Dec 10 14:07 System.map-2.4.9-e.34
-rwxr-xr-x 1 root root 2797975 Dec 10 14:07 vmlinux-2.4.9-e.34
lrwxrwxrwx 1 root root 18 May 17 04:44 vmlinuz -> vmlinuz-2.4.9-e.34
-rw-r--r-- 1 root root 1007712 Dec 10 14:07 vmlinuz-2.4.9-e.34

So ...


As far as I can tell I do have a source tree that matches my current kernel that I am booting from.

Are the nVidia drivers even supported in my distro (is there a list of supported kernels/distributions)?

Im not sure I am using the correct .config file in /usr/src/linux. I don't have one in /boot, so I used /usr/src/redhat/SOURCES/kernel-2.4.9-i386.config and did a "make dep" in the source tree. No go.

Any suggestions?

Thanks
exitchannel is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 04:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 11:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 05:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 09:22 PM

All times are GMT -5. The time now is 01:48 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.