Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-23-04, 06:12 PM   #1
Kero Hazel
Registered User
 
Join Date: May 2004
Posts: 2
Default AGP instability with GF4 and P4x400

This makes two Via motherboards that have given me no end of grief... it's the last time I'm ever going non-Intel. But until I get a new mobo, I'm trying to get my AGP working. Using NvAGP hasn't worked for me, and neither has AGPGART. Since my chipset isn't supported by NvAGP, I've been mostly messing with AGPGART.

I get complete lockups as soon as X starts -- sometimes before I even log in, at the xdm screen, sometimes just after my WM starts. I read that having fast AGP writes and SBA enabled can lead to instability. I disabled fast writes in my BIOS, but there was no section related to SBA. The NV docs says to extract the drivers from the .run file and edit os-registry.c, which I did. SBA *should* be disabled. I even went into /etc/modprobe.conf and added this line as someone suggested: "options nvidia NVreg_EnableAGPSBA=0 NVreg_EnableAGPFW=0" but that didn't work either.

Here's what a cat /proc/driver/nvidia/agp/status produces:
Status: Enabled
Driver: AGPGART (inactive)
AGP Rate: 8x
Fast Writes: Disabled
SBA: Enabled

Anyone know how to definitively disable SBA? I don't want to give up on AGP until I've tried disabling that first. If you have advice on getting the P4x400 to work with the GF4 those are welcome too.
Kero Hazel is offline   Reply With Quote
Old 05-23-04, 08:27 PM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: AGP instability with GF4 and P4x400

There are two sections of os-registry.c pertaining to the default SBA setting, one for IA64 and one for x86. Did you edit the right one?

[edit] uh, nm I did not check what arch that board was for before I posted that[/edit]
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.

Last edited by LordMorgul; 05-23-04 at 08:28 PM. Reason: doh!
LordMorgul is offline   Reply With Quote
Old 05-23-04, 10:31 PM   #3
Kero Hazel
Registered User
 
Join Date: May 2004
Posts: 2
Default Re: AGP instability with GF4 and P4x400

Quote:
Originally Posted by LordMorgul
There are two sections of os-registry.c pertaining to the default SBA setting, one for IA64 and one for x86. Did you edit the right one?

[edit] uh, nm I did not check what arch that board was for before I posted that[/edit]
Actually, I edited out them BOTH. When I went to edit the file I saw that x86-based systems automatically have the SBA setting disabled. I thought maybe there was a problem with detection -- maybe the installer thought I had an IA64? -- so I just commented out the whole block and put:
static int NVreg_EnableAGPSBA = 0;

I have no idea why my settings aren't taking hold.
Kero Hazel is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.