Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-14-04, 11:46 PM   #1
newnvuser
Registered User
 
Join Date: May 2004
Posts: 10
Default OpenGL, GF2 okay, GF4 freezes

I've been trying to get UT2004 to work with my GF4 TI4200. It works with my GF2 MX400.

History:
1. Gentoo, vanilla kernel 2.4.26, and nvidia drivers 4496 (-kernel and -glx), GF2 MX400 (MS-8826), the game works.
2. Replace GF2 with GF4 TI4200. When starting UT2004, it freezes during the "the way it's meant to be played" intro. Sometimes, the machine locks up. Gameplay is the same way.
3. Update to nvidia drivers 5336 (-kernel and -glx). Same freezes.
4. Remove "freetype" from XF86Config. No change.
5. Add "ConnectedMonitor DFP" to XF86Config. No change.
6. Add "IgnoreDisplayDevices CRT, TV" to XF86Config. No change.
7. Try "pci=noacpi", "pci=biosirq", and "noacpi" as kernel parameters. No change.

glxinfo always reports that the OpenGL is good. Everything works, except that when the game starts it's intro, it freezes and/or locks up.

Is there anything else I should try? It looks like it's a problems with the drivers when using this video card (TI4200).

It's no fun playing at 20 frames per second or less...


Here's the XF86Config:
Code:
Section "Module"
    Load        "dbe"   # Double buffer extension
    SubSection  "extmod"
      Option    "xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load        "type1"
    Load       "glx"
EndSection

Section "Files"
    RgbPath     "/usr/X11R6/lib/X11/rgb"
    FontPath "unix/:-1"
    FontPath "unix/:7100"
EndSection

Section "ServerFlags"
    Option "OffTime" "10"
    Option "RandR"   "on"
EndSection

Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "Keyboard"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc101"
    Option "XkbLayout"  "us"
EndSection

Section "InputDevice"
    Identifier            "usbmouse"
    Driver                "mouse"
    Option "Protocol"     "ExplorerPS/2"
    Option "Device"       "/dev/input/mice"
    Option "Buttons"      "7"
    Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
  Identifier   "173T"
  HorizSync    30-81
  VertRefresh  56-75
  Option       "DPMS"
EndSection

Section "Device"
    Identifier  "ti4200"
    Driver      "nvidia"
    Option      "NvAGP" "1"
    Option      "NoLogo" "true"
    Option      "ConnectedMonitor" "DFP"
    Option      "IgnoreDisplayDevices" "CRT, TV"
EndSection

Section "Screen"
    Identifier  "Screen 173T"
    Device      "ti4200"
    Monitor     "173T"
    DefaultDepth 24

    Subsection "Display"
        Depth       24
        Modes       "1280x1024"
    EndSubsection

    Subsection "Display"
        Depth       16
        Modes       "1280x1024"
    EndSubsection

    Subsection "Display"
        Depth       8
        Modes       "1280x1024"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 173T" 0 0
    InputDevice "usbmouse" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection
XFree86.0.log:
Code:
XFree86 Version 4.3.0.1
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.23_pre8-gss-r2 i686 [ELF] 
Build Date: 18 February 2004
	Before reporting problems, check http://www.XFree86.Org/
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Fri May 14 22:21:10 2004
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 173T" (0)
(**) |   |-->Monitor "173T"
(**) |   |-->Device "ti4200"
(**) |-->Input Device "usbmouse"
(**) |-->Input Device "Keyboard1"
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc101"
(**) XKB: model: "pc101"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "unix/:-1,unix/:7100"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "OffTime" "10"
(**) Option "RandR" "on"
(++) using VT number 7

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Module ABI versions:
	XFree86 ANSI C Emulation: 0.2
	XFree86 Video Driver: 0.6
	XFree86 XInput driver : 0.4
	XFree86 Server Extension : 0.2
	XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 1.0.0
	Module class: XFree86 Font Renderer
	ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 1.0.0
	ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x8000002c, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 10de,01e0 card 0000,0000 rev c1 class 06,00,00 hdr 80
...
(II) PCI: 02:00:0: chip 10de,0253 card 0000,0000 rev a3 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,2), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
	[0] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[b]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:1:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:8:0), (0,1,1), BCTRL: 0x0002 (VGA_EN is cleared)
(II) Bus 1 I/O range:
	[0] -1	0	0x0000c000 - 0x0000cfff (0x1000) IX[b]
(II) Bus 1 non-prefetchable memory range:
	[0] -1	0	0xde000000 - 0xdfffffff (0x2000000) MX[b]
(II) PCI-to-PCI bridge:
(II) Bus 2: bridge is at (0:30:0), (0,2,2), BCTRL: 0x000a (VGA_EN is set)
(II) Bus 2 non-prefetchable memory range:
	[0] -1	0	0xdc000000 - 0xddffffff (0x2000000) MX[b]
(II) Bus 2 prefetchable memory range:
	[0] -1	0	0xd4000000 - 0xdbffffff (0x8000000) MX[b]
(--) PCI:*(2:0:0) nVidia Corporation NV25 [GeForce4 Ti 4200] rev 163, Mem @ 0xdc000000/24, 0xd4000000/26, 0xd8000000/19
(II) Addressable bus resource ranges are
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[b]
	[1] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) OS-reported resource ranges:
...
(II) PCI Memory resource overlap reduced 0xd0000000 from 0xd3ffffff to 0xcfffffff
(II) Active PCI resource ranges:
...
(II) Active PCI resource ranges after removing overlaps:
...
(II) OS-reported resource ranges after removing overlaps with PCI:
...
(II) All system resource ranges:
...
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 1.0.0
	Module class: XFree86 Server Extension
	ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 1.0.0
	Module class: XFree86 Server Extension
	ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 1.0.2
	Module class: XFree86 Font Renderer
	ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.5336
	Module class: XFree86 Server Extension
	ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.5336
	Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 1.0.0
	Module class: XFree86 XInput Driver
	ABI class: XFree86 XInput driver, version 0.4
(II) NVIDIA XFree86 Driver  1.0-5336  Wed Jan 14 18:30:46 PST 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 02:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
...
(II) resource ranges after probing:
...
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 0.1.0
	ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "true"
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Option "ConnectedMonitor" "DFP"
(**) NVIDIA(0): Option "IgnoreDisplayDevices" "CRT, TV"
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(**) NVIDIA(0): ConnectedMonitor string: "DFP"
(--) NVIDIA(0): Linear framebuffer at 0xD4000000
(--) NVIDIA(0): MMIO registers at 0xDC000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce4 Ti 4200
(--) NVIDIA(0): VideoBIOS: 04.25.00.29.00
(--) NVIDIA(0): VideoRAM: 65536 kBytes
(II) NVIDIA(0): Using ConnectedMonitor string "DFP-0"
(--) NVIDIA(0): Display device DFP-0: maximum pixel clock at  8 bpp: 350 MHz
(--) NVIDIA(0): Display device DFP-0: maximum pixel clock at 16 bpp: 350 MHz
(--) NVIDIA(0): Display device DFP-0: maximum pixel clock at 32 bpp: 350 MHz
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 1.0.0
	ABI class: XFree86 Video Driver, version 0.6
(II) NVIDIA(0): 173T: Using hsync range of 30.00-81.00 kHz
(II) NVIDIA(0): 173T: Using vrefresh range of 56.00-75.00 Hz
(II) NVIDIA(0): Clock range:  12.00 to 350.00 MHz
(II) NVIDIA(0): Not using default mode "640x350" (vrefresh out of range)
...
(WW) NVIDIA(0): Not using mode "700x525" (height 1050 is larger than
(WW) NVIDIA(0):      EDID-specified maximum 1024)
(**) NVIDIA(0): Validated modes for display device DFP-0:
(**) NVIDIA(0):      Default mode "1280x1024": 135.0 MHz, 80.0 kHz, 75.0 Hz
(**) NVIDIA(0):      Default mode "1280x1024": 108.0 MHz, 64.0 kHz, 60.0 Hz
...
(**) NVIDIA(0):      Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) NVIDIA(0): Display dimensions: (340, 270) mm
(--) NVIDIA(0): DPI set to (95, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 1.0.0
	ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 0.1.0
	ABI class: XFree86 Video Driver, version 0.6
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
...
(II) NVIDIA(0): AGP 4X successfully initialized
(II) NVIDIA(0): Setting mode "1280x1024"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(**) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing extension GLX
(**) Option "Protocol" "ExplorerPS/2"
(**) usbmouse: Protocol: "ExplorerPS/2"
(**) Option "CorePointer"
(**) usbmouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Buttons" "7"
(**) usbmouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "6 7"
(**) usbmouse: ZAxisMapping: buttons 6 and 7
(**) usbmouse: Buttons: 7
(II) Keyboard "Keyboard1" handled by legacy driver
(II) XINPUT: Adding extended input device "usbmouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) usbmouse: ps2EnableDataReporting: succeeded
Could not init font path element unix/:7100, removing from list!
(II) 3rd Button detected: disabling emulate3Button
newnvuser is offline   Reply With Quote
Old 05-17-04, 12:00 PM   #2
newnvuser
Registered User
 
Join Date: May 2004
Posts: 10
Default Re: OpenGL, GF2 okay, GF4 freezes

Bump
newnvuser is offline   Reply With Quote
Old 05-18-04, 07:31 AM   #3
rednuht
GeForce FX5600 (1.0-5336)
 
rednuht's Avatar
 
Join Date: Sep 2003
Location: uk
Posts: 164
Default Re: OpenGL, GF2 okay, GF4 freezes

do u have problems with oth opengl apps ?
rednuht is offline   Reply With Quote
Old 05-18-04, 04:46 PM   #4
newnvuser
Registered User
 
Join Date: May 2004
Posts: 10
Default Re: OpenGL, GF2 okay, GF4 freezes

Quote:
Originally Posted by rednuht
do u have problems with oth opengl apps ?
I don't do much with other apps that require OpenGL. glxgears seems happy (~3900 fps), and the output from glxinfo is below.

Are there other OpenGL apps that I can test?

Code:
name of display: :0.0
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0  screen: 0
direct rendering: No
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
    GLX_ARB_multisample
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce4 Ti 4200/AGP/SSE/3DNOW!
OpenGL version string: 1.4.1 NVIDIA 53.36
OpenGL extensions:
    GL_ARB_imaging, GL_EXT_blend_color, GL_EXT_blend_minmax,
    GL_ARB_multitexture
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x21 24 tc  0 32  0 r  y  .  8  8  8  0  0 24  8 16 16 16 16  0 0 None
0x22 24 dc  0 32  0 r  y  .  8  8  8  0  0 24  8 16 16 16 16  0 0 None
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x24 24 tc  0 32  0 r  .  .  8  8  8  0  0 24  8 16 16 16 16  0 0 None
0x25 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x26 24 tc  0 32  0 r  y  .  8  8  8  0  0 16  0 16 16 16 16  0 0 None
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  0 16 16 16 16  0 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  0  0 16  0 16 16 16 16  0 0 None
0x29 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  0 16 16 16 16  0 0 None
0x2a 24 tc  0 32  0 r  y  .  8  8  8  0  0  0  0 16 16 16 16  0 0 None
0x2b 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 None
0x2c 24 tc  0 32  0 r  .  .  8  8  8  0  0  0  0 16 16 16 16  0 0 None
0x2d 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 None
0x2e 24 tc  0 32  0 r  y  .  8  8  8  0  0 24  8 16 16 16 16  0 0 Ncon
0x2f 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Ncon
0x30 24 tc  0 32  0 r  y  .  8  8  8  0  0 24  8 16 16 16 16  0 0 Ncon
0x31 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Ncon
0x32 24 tc  0 32  0 r  y  .  8  8  8  0  0 16  0 16 16 16 16  0 0 Ncon
0x33 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  0 16 16 16 16  0 0 Ncon
0x34 24 tc  0 32  0 r  y  .  8  8  8  0  0 16  0 16 16 16 16  0 0 Ncon
0x35 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  0 16 16 16 16  0 0 Ncon
0x36 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x37 24 dc  0 32  0 r  .  .  8  8  8  0  0 24  8 16 16 16 16  0 0 None
0x38 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x39 24 dc  0 32  0 r  y  .  8  8  8  0  0 16  0 16 16 16 16  0 0 None
0x3a 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  0 16 16 16 16  0 0 None
0x3b 24 dc  0 32  0 r  .  .  8  8  8  0  0 16  0 16 16 16 16  0 0 None
0x3c 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  0 16 16 16 16  0 0 None
0x3d 24 dc  0 32  0 r  y  .  8  8  8  0  0  0  0 16 16 16 16  0 0 None
0x3e 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 None
0x3f 24 dc  0 32  0 r  .  .  8  8  8  0  0  0  0 16 16 16 16  0 0 None
0x40 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 None
0x41 24 dc  0 32  0 r  y  .  8  8  8  0  0 24  8 16 16 16 16  0 0 Ncon
0x42 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Ncon
0x43 24 dc  0 32  0 r  y  .  8  8  8  0  0 24  8 16 16 16 16  0 0 Ncon
0x44 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Ncon
0x45 24 dc  0 32  0 r  y  .  8  8  8  0  0 16  0 16 16 16 16  0 0 Ncon
0x46 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  0 16 16 16 16  0 0 Ncon
0x47 24 dc  0 32  0 r  y  .  8  8  8  0  0 16  0 16 16 16 16  0 0 Ncon
0x48 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  0 16 16 16 16  0 0 Ncon
newnvuser is offline   Reply With Quote
Old 05-18-04, 10:25 PM   #5
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: OpenGL, GF2 okay, GF4 freezes

Well it seems that you do have a problem, as your glxinfo output states that you don't have direct rendering enabled. (Which seems weird as the rest of if look ok)

This is a snippet of my glxinfo output:-

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes << This line here...
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control

As you can see from the output that in mine it states that I do infact have direct rendering enabled.

Are there any errors in X startup?? I'm going to have another look at your XF86Config files etc. And see if I can see anything that I may have missed.

Wolf
Wolfman [TWP] is offline   Reply With Quote
Old 05-19-04, 02:51 AM   #6
newnvuser
Registered User
 
Join Date: May 2004
Posts: 10
Default Re: OpenGL, GF2 okay, GF4 freezes

Quote:
Originally Posted by Wolfman [TWP]
Well it seems that you do have a problem, as your glxinfo output states that you don't have direct rendering enabled.
Ok, I fixed that. I was missing a symbolic link for one of the libraries in the nvidia directory (as described in the nvidia-glx readme). Now, glxinfo shows "direct rendering: Yes"

I do not see any warnings or errors in my XFree86.log. (well, "larger than EDID-specific maximum", etc)

The glx readme says that I should see "NVIDIA-GLX" in the xdpyinfo output. I don't. I do see "GLX" and "NV-GLX", as it also suggests.

The game behaves the same as before.

Anything else?

Thanks for the help.
newnvuser is offline   Reply With Quote
Old 05-19-04, 10:52 AM   #7
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: OpenGL, GF2 okay, GF4 freezes

What are the server flags section for??? I don't see that in my XF86Config.. (I'm running Redhat Enterprise 3 WS).
As that's the only thing out of the ordinary that I see different in your XF86Config file. (Apart from the layout being completely different that is)

I don't see NVIDIA-GLX either, but UT2004 runs perfectly on my system. (As does Quake, Q2, Q3, Descent III, NWN etc) I have a FX-5950Ultra on my system.

Wolf
Wolfman [TWP] is offline   Reply With Quote
Old 05-19-04, 02:13 PM   #8
newnvuser
Registered User
 
Join Date: May 2004
Posts: 10
Default Re: OpenGL, GF2 okay, GF4 freezes

Quote:
Originally Posted by Wolfman [TWP]
What are the server flags section for???
Code:
man XF86Config


SERVERFLAGS SECTION
       The  ServerFlags  section is used to specify some global X server options.
...
       Option "OffTime"  "time"
              sets the inactivity timeout for the "off" phase of DPMS mode.
...
The man pages doesn't have anything for "RandR", but I think that one is pretty obvious.

I'll try removing those when I am at the machine to see if there is any difference.

Could the problem be related to the card, ie features the are or are not present in a TI4200 that are different than an MX400 or FX-5950Ultra, that are used by the game? Is there any way to disable certain features (like removing the interface from the source code that gets compiled when the driver is installed)?
newnvuser is offline   Reply With Quote

Old 05-19-04, 11:43 PM   #9
newnvuser
Registered User
 
Join Date: May 2004
Posts: 10
Default Re: OpenGL, GF2 okay, GF4 freezes

Quote:
Originally Posted by newnvuser
I'll try removing those when I am at the machine to see if there is any difference.
No difference.

I double-checked the kernel configuration. No frame buffer support. I tried with "noacpi" on the bootup command line. Same result every time: long freezes in the game.

I'll try some other games/opengl apps later...
newnvuser is offline   Reply With Quote
Old 05-19-04, 11:50 PM   #10
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: OpenGL, GF2 okay, GF4 freezes

For the sake of curiosity, I added the Server stuff to my XF86Config file, and didn't see any change. So these settings shouldn't affect you.

What do the output's of the following commands say on your system??

cat /proc/driver/nvidia/cards/0

cat /proc/driver/nvidia/agp/card

cat /proc/driver/nvidia/agp/host-bridge

cat /proc/driver/nvidia/agp/status

In the first output, if there are some missing info, then it usually means that there is a card detection problem. (ie, doesn't show IRQ or Card BIOS info)

Will see what they say, and move on from there..

Wolf
Wolfman [TWP] is offline   Reply With Quote
Old 05-20-04, 06:19 PM   #11
newnvuser
Registered User
 
Join Date: May 2004
Posts: 10
Default Re: OpenGL, GF2 okay, GF4 freezes

Quote:
Originally Posted by Wolfman [TWP]
What do the output's of the following commands say on your system??
Code:
axp nvidia # pwd
/proc/driver/nvidia
axp nvidia # cat cards/0
Model:           GeForce4 Ti 4200
IRQ:             12
Video BIOS:      04.25.00.29.00
Card Type:       AGP
axp nvidia # cat agp/card
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       4x 2x 1x
Registers:       0x1f000217:0x1f000104
axp nvidia # cat agp/host-bridge
Host Bridge:     PCI device 10de:01e0 (nVidia Corporation)
Fast Writes:     Not Supported
SBA:             Supported
AGP Rates:       4x 2x 1x
Registers:       0x1f000207:0x00000104
axp nvidia # cat agp/status
Status:          Enabled
Driver:          NVIDIA
AGP Rate:        4x
Fast Writes:     Disabled
SBA:             Disabled
axp nvidia #
newnvuser is offline   Reply With Quote
Old 05-22-04, 10:04 AM   #12
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: OpenGL, GF2 okay, GF4 freezes

Hmmm. That's really odd, it all looks ok. I have noticed that you have it setup to use the Nvidia AGP driver... What happens when you select the AGPgart driver?? (NvAGP=2 or just # out that line)

Also, do you have the latest Nforce drivers installed??? (Noticed that from the AGP/PCI bridge being Nvidia)

That's about all that I can think of. (I don't have access to a Nforce MBRD, mine are AMD , and VIA chipsets mainly)

Wolf
Wolfman [TWP] is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL book Airstrip1 Software Development 2 08-12-12 09:55 AM
Do I need to reinstall NVIDIA driver if I upgrade from GF2 Pro to GF4 Ti? ant NVIDIA Linux 1 09-30-02 07:39 AM
crashes and freezes Lethal Weapon NVIDIA Linux 9 09-27-02 09:23 PM
GeForce4 image quality - need some HONEST opinions ErrorS NVIDIA GeForce 7, 8, And 9 Series 24 08-22-02 07:39 AM
Dual Monitor cards GF2 or GF4 Geoinfo SRL NVIDIA Linux 15 08-06-02 05:48 AM

All times are GMT -5. The time now is 09:47 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.