Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-27-04, 07:18 PM   #13
ghostwalker
Registered User
 
Join Date: Sep 2003
Location: Tacoma, WA
Posts: 76
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Make agpgart as a modules so you have the option to load it. But, before you do that comment out the NVagp and see what result you get then. You will be using the agpgart of the system.
ghostwalker is offline   Reply With Quote
Old 05-28-04, 05:14 AM   #14
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

I reformatted today. SuSE9.0 with Kernel 2.4.21-99.
Tried Drivers 4496 and 5336 with NVidias and the System-internal AGPGart ...
the MAX FPS i get in glxgears is with NV-AGPGart on 16 Bit with 4996 is ............ 2800
So there should only be two possibilitys:
a) Wrong Configuration on my BIOS or
b) the complete Hardware is CRAP or defected ...
ZicoTheTux is offline   Reply With Quote
Old 05-28-04, 05:26 AM   #15
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Type in the console

Code:
cat /proc/driver/nvidia/cards/0
and

Code:
cat /proc/driver/nvidia/agp/status
What are the readouts?
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 05-28-04, 05:52 AM   #16
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

cat /proc/driver/nvidia/cards/0
Model: Unknown
IRQ: 11
Video BIOS: 04.35.20.38.00
Card Type: AGP

cat /proc/driver/nvidia/cards/0

Status: Enabled
Driver: NVIDIA
AGP Rate: 4x
Fast Writes: Disabled (Comment by me: in BIOS ENABLED)
SBA: Disabled
ZicoTheTux is offline   Reply With Quote
Old 05-28-04, 06:18 AM   #17
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Strange, everything seems to be in order and there is nothing out of place, maybe a bios issue. Here is mine.


Code:
Status:          Enabled
Driver:          AGPGART
AGP Rate:        8x
Fast Writes:     Disabled
SBA:             Enabled
Code:
Model:           GeForce FX 5900 Ultra
IRQ:             11
Video BIOS:      04.35.20.22.06
Card Type:       AGP
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 05-28-04, 06:21 AM   #18
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

You have to tell the nvidia module to enable Fast Writes and SBA. By default, the driver turns these off, because of possible stability problems, IIRC. (Check the README that comes with the driver for an explanation.)

You can turn them on by specifying

options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1

in /etc/modprobe.conf (or /etc/modules.conf for older kernels).
hppnq is offline   Reply With Quote
Old 05-28-04, 06:23 AM   #19
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Fast writes dont make much difference at all and doesnot explain his problem.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 05-28-04, 06:25 AM   #20
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

I was referring to his comment, of course.
hppnq is offline   Reply With Quote

Old 05-28-04, 06:53 AM   #21
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

So i added options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1 to modprobe.conf - since i have nothing to loose

Status: Enabled
Driver: NVIDIA
AGP Rate: 4x
Fast Writes: Enabled
SBA: EnabledC

Model: GeForce FX 5900 XT
IRQ: 16
Video BIOS: 04.35.20.38.00
Card Type: AGP

glxgears says... 2558 FPS .... hmmm nice try
Any other ideas? ....
ZicoTheTux is offline   Reply With Quote
Old 05-28-04, 07:01 AM   #22
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

You're not running a kernel with debugging turned on, are you? (Yeah, I know it's unlikely to be related to your problem, but you never know. ;-)
hppnq is offline   Reply With Quote
Old 05-28-04, 07:36 AM   #23
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Kernel debugging in 2.4 = on
Kernel Debugging in 2.6 = off
same results ...

*sigh* this performance-"black-hole" must be somwhere ... something...
ZicoTheTux is offline   Reply With Quote
Old 05-28-04, 10:19 AM   #24
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Hi,

you could post your complete kernel-config. That would be nice.
energyman76b is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM

All times are GMT -5. The time now is 05:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.