Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-30-04, 02:37 PM   #37
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

[edit] nm you said earlier that you tried this already [/edit]
Have you tried running apggart for the agp driver rather than nvagp? Typically nvagp has been the 'catchall' solution for people... but in the latest 2.6 kernels agpgart actually performs better for my machine. It is worth trying both if one or the other doesn't cause blank screens.
The Option NvAGP controls which is requested (the log says nvagp is succeeding for you). Try setting this to 2.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 05-30-04, 03:20 PM   #38
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Hi,

which version of nvidia kernel modules is used and which version of the libgl part are you using? Don't say 'I installed..' check it, please.
Dmesg tells you, the module version. Some ls/find on /usr/lib and /usr/X11R6/ will show you, if there are stale libGL files that are doing some harm.

Oh, and with 2.6 you have to load two modules for agpgart, instead of one. You should do this, prior loading the nvidia-modul.
energyman76b is offline   Reply With Quote
Old 05-30-04, 03:37 PM   #39
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Ok i recompiled DRM OUT of the Kernel, tool even KErnel debugging out and will try NvAGP "2" with the agpgart and the via-agp module (this I have already tried ) . Next reboot....

Hmmm with that Version of the NVidia Kenrel Module ... i simply don't know... i JUST installed NVIDIA-Linux-x86-1.0-5336-pkg1.run ... NV says the needed Kernel Module is content of that package ...

libGL .. i hope i tell you right ...
In Yast2 i see libGL is part of XFree86-mesa wich is Version 4.3.0.1-21 (god my english is worse)
In /usr/lib the libGLcore is a link for libGLCore.so.1.0.5336 (seems the NVidia)
ZicoTheTux is offline   Reply With Quote
Old 05-30-04, 04:17 PM   #40
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Hi,

your libGL must be the nvidia version!
It seems, that you are using, xfree libGL, (too lazy to read the complete thread again) instead of nvidia libGL.

You should have something like this in your /usr/lib (or where SuSE installs this libs):
lrwxrwxrwx 1 root root 21 16. Apr 04:24 libGLcore.so -> libGLcore.so.1.0.5336
lrwxrwxrwx 1 root root 21 16. Apr 04:24 libGLcore.so.1 -> libGLcore.so.1.0.5336
-rwxr-xr-x 1 root root 4954300 16. Apr 04:24 libGLcore.so.1.0.5336
-rw-r--r-- 1 root root 739 16. Apr 04:24 libGL.la
lrwxrwxrwx 1 root root 17 16. Apr 04:24 libGL.so -> libGL.so.1.0.5336
lrwxrwxrwx 1 root root 17 16. Apr 04:24 libGL.so.1 -> libGL.so.1.0.5336
-rwxr-xr-x 1 root root 367332 16. Apr 04:24 libGL.so.1.0.5336
energyman76b is offline   Reply With Quote
Old 05-30-04, 04:21 PM   #41
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Post the output of "ldd /usr/X11R6/bin/glxgears". It will show the libraries with which glxgears is linked. Next, do an "ls -l'" of the directory where glxgears says your libGL resides and post that too. If all is well, they should be the Nvidia libraries.
hppnq is offline   Reply With Quote
Old 05-30-04, 04:30 PM   #42
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

I do whatever you want as long as it comes to this problem

zico@linux:/usr/lib/tls> ldd /usr/X11R6/bin/glxgears
libGL.so.1 => /usr/lib/tls/libGL.so.1 (0x4002c000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40089000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40097000)
libpthread.so.0 => /lib/i686/libpthread.so.0 (0x40193000)
libm.so.6 => /lib/i686/libm.so.6 (0x401e5000)
libc.so.6 => /lib/i686/libc.so.6 (0x40208000)
libGLcore.so.1 => /usr/lib/tls/libGLcore.so.1 (0x4033b000)
libdl.so.2 => /lib/libdl.so.2 (0x407f0000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
zico@linux:/usr/lib/tls> ls -l
insgesamt 5206
lrwxrwxrwx 1 root root 21 2004-05-28 14:51 libGLcore.so.1 -> libGLcore.so.1.0.5336
-rwxr-xr-x 1 root root 4954300 2004-05-28 14:51 libGLcore.so.1.0.5336
-rw-r--r-- 1 root root 657 2004-05-28 14:51 libGL.la
lrwxrwxrwx 1 root root 10 2004-05-28 14:51 libGL.so -> libGL.so.1
lrwxrwxrwx 1 root root 17 2004-05-28 14:51 libGL.so.1 -> libGL.so.1.0.5336
-rwxr-xr-x 1 root root 367332 2004-05-28 14:51 libGL.so.1.0.5336


looks .... eh .. right?
ZicoTheTux is offline   Reply With Quote
Old 05-30-04, 04:42 PM   #43
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Yeah, it looks like your libraries are ok.

There's another thing you might try, if you're using ACPI. First, boot with the option "pci=noapci", second, with the option "acpi=off", and see if that changes anything. (Chances are your performance will degrade. ;-) You do this, by the way, by either editing the boot command when using grub (press 'e' and append the option to the boot line, then press 'b' to boot), or by appending it to the kernel to boot when using lilo (say, your kernel is called 'linux', press shift at boot time so you get the lilo prompt and enter 'linux pci=noapci', for instance).

At a glance everything else looks okay, I haven't seen any funny stuff. Could you also post an ldd of your UT binary?
hppnq is offline   Reply With Quote
Old 05-30-04, 05:18 PM   #44
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

I already tried these acpi functions...
but HOW does the first option is named?
I know:
pci=noacpi
pic=noapci
what's the right one?
ZicoTheTux is offline   Reply With Quote

Old 05-30-04, 05:23 PM   #45
Kamel
Hardware Mass Murderer
 
Kamel's Avatar
 
Join Date: Oct 2003
Location: Jacksonville, FL
Posts: 1,035
Send a message via ICQ to Kamel Send a message via AIM to Kamel Send a message via MSN to Kamel Send a message via Yahoo to Kamel Send a message via Skype™ to Kamel
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

pci=noacpi if i were guessing, since pic isn't a kernel parameter (if i'm not mistaken that is).
__________________
hardware murdered so far: geforce 5900u, deceised: sat on it. geforce 6600gt deceised: improperly mounted heatsink. 3 asus a7n8x-e deluxe motherboards, deceised: unsure. mobile amd xp2600 processor, deceised: chipped core due to compusa heatsink. dfi lanparty ultra b, deceised: unsure, third memory bank went out. samsung cd burner 48x40x48, deceised: unsure, will only read pressed cd's very slowly. samsung TH552C dvd burner (dual layer), deceised: same as other samsung . 10gb seagate 5200rpm drive, deceised: tried fixing a pin that was pushed into the drive by inserting an ide cable upside down. 40gb maxtor drive, deceised: maxtor manufacturer. 80gb western digital, deceised: unnatural causes. swan xt10, deceised: brutal pre-meditated murder, even video taped (it wasn't y2k compliant). logitech mx510, deceised: death by electricution. ati remote wonder, deceised: death by electricution.
Kamel is offline   Reply With Quote
Old 05-30-04, 05:31 PM   #46
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

pci=noacpi, of course. ;-) Sorry for the confusion mate.
hppnq is offline   Reply With Quote
Old 05-30-04, 05:36 PM   #47
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

Once more info before i reboot... is that all ok?

zico@linux:~> cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 8
model name : AMD Athlon(tm) XP 2400+
stepping : 1
cpu MHz : 2000.378
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
bogomips : 3923.96

zico@linux:~> cat /proc/cpufreq
minimum CPU frequency - maximum CPU frequency - policy

here is said: apic .. perhaps i even should try pci=noapic
ZicoTheTux is offline   Reply With Quote
Old 05-30-04, 05:42 PM   #48
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: UT2004 & glxgears - HORRIBLE FPS Rates

No, pci=noacpi is the one you want. ;-)
hppnq is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-31-02 12:59 AM

All times are GMT -5. The time now is 05:34 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.