Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-02-04, 04:05 PM   #1
Jesper_DK
Registered User
 
Join Date: Jun 2004
Posts: 17
Question Xfree fails to load with 5336 drivers.

Hi people

My X fails to load with 5336 drivers installed via the official installation interface. I am on a unstable debian. here is what the Xfree log contains (no errors before):
----------------------
[i](II) NVIDIA(0): NVIDIA GPU detected as: GeForce3
(--) NVIDIA(0): VideoBIOS: 03.20.00.10.00
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol xf86XvMCDestroyAdaptorRec from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbPictureInit from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbValidateGC from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbGCPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbCreateGC from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbCreateWindow from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbCloseScreen from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol xf86XvMCCreateAdaptorRec from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 7. Server aborting
-------------------------------------

I have searched high and low for an answer but have not found any.
I thougth that my xfree-config could be the problem, so here is the essential stuff from that :
--------------------------------------------
Section "Module"
#Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
#Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
----
Section "Device"
Identifier "Nvidia Geforce3"
Driver "nvidia"
--------------------------------

The opensource nv driver works fine, but i would like some 3D graphics (tuxracer).

Thanks in advance

./Jesper
Jesper_DK is offline   Reply With Quote
Old 06-02-04, 05:18 PM   #2
thomas21
Registered User
 
thomas21's Avatar
 
Join Date: Apr 2004
Posts: 35
Default Re: Xfree fails to load with 5336 drivers.

Hi Jesper,

Some questions:
- did you compile the kernel yourself ?
- which kernel are you using (uname -a) ?
- if using a standard Debian kernel package, did you install the kernel header package also
(before installing the nVidia drivers) ?
- what hardwarde are you installing on (Pentium / AMD) ?

I also use Debian unstable and have no problems installing the 5336 drivers (Debian install or nVidia install on 2.4 and 2.6 kernels) on my Pentium III and IV system (altough my new AMD64 gives problems, but that's an other story)
thomas21 is offline   Reply With Quote
Old 06-02-04, 07:27 PM   #3
utanja
Debian All the Way
 
Join Date: May 2004
Location: Salzburg Austria & Orlando Florida
Posts: 59
Default Re: Xfree fails to load with 5336 drivers.

i am running the NVIDIA drivers on 2.6.6 unstable with out a problem...
__________________
utanja
i am female and i don't do windows.. and i don't do macs ..i fly a Lear Jet
"Wer fremde Sprachen nicht kennt, weiss nichts von seiner eigenen."
- Goethe, Maximen und Reflexionen
Intel 3I-core 2d.gen -3.1GHz;8 gig ram;PureDebian SID[3.2[custom kernel] 8 Debian workstations
plus HP Win7 64bit Wireless Laptop Network/Citrix/NX/VMware
Mozilla/Firebird browsers
my american friends call me tonya

Last edited by utanja; 06-07-04 at 06:09 PM.
utanja is offline   Reply With Quote
Old 06-03-04, 06:12 AM   #4
Jesper_DK
Registered User
 
Join Date: Jun 2004
Posts: 17
Default Re: Xfree fails to load with 5336 drivers.

Hi

Thomas21 >
The kernel is the default 2.4 kernel with debian. (2.4.18-bf2.4).
My CPU is a Pentium III 800 Mhz. With a Geforce 3, 64 MB version.
The Kernel headers have been installed, and linked properly. The only thing the driver said was that the kernel was kompiled with another version of gcc than the one i used, but this shoudnt be a problem.

utanja>
Thats just great...

Thanks guys.

./Jesper
Jesper_DK is offline   Reply With Quote
Old 06-04-04, 10:08 AM   #5
thomas21
Registered User
 
thomas21's Avatar
 
Join Date: Apr 2004
Posts: 35
Default Re: Xfree fails to load with 5336 drivers.

Hi Jesper,

Did you also install the kernel-source package for this kernel ?

Please check this and also check if the "/usr/src/linux" link points to this kernel source directory.
(should be something like " /usr/src/kernel-source-2.4.18-bf2.4")

If all ok, then try the nvidia-install again (if fail, attach the "/var/log/nvidia-installer.log" file.

Or, if you want to do it the Debian way
I prefer this, ok initial you have to invest some time but after that it's very easy to maintain, check this out:

http://home.comcast.net/~andrex/Debi...tallation.html

Oh, by the way the gcc version can be a problem, which version do you use ?
You may also consider installing a newer 2.4 kernel, (like 2.4.26).

good luck !

Last edited by thomas21; 06-04-04 at 10:19 AM.
thomas21 is offline   Reply With Quote
Old 06-13-04, 07:11 AM   #6
Jesper_DK
Registered User
 
Join Date: Jun 2004
Posts: 17
Default Re: Xfree fails to load with 5336 drivers.

Hi Thomas

Thanks, for the reply, sorry about the late answer, it has been great weather in denmark, so I have been in the parks drinking beers. Anyways...

I installed both the kernel-headers and kernel-sources, but was told to link /usr/src/linux to the kernel-headers, and that also worked during the nvidia install.
You tell me to link the kernel sources ?.

btw. I needed to make this link before the install worked
Code:
ln -s /usr/src/kernel-headers-2.4.18-bf2.4/ /lib/modules/$(uname -r)/build
I tryed rerunning the nvidia-installer without effect. It still states that my GCC version is different that the one the kernel was compilled with my gcc version is "gcc version 3.3.3 (Debian 20040429)"

I realy dont know what causes this, I have used these drivers several times before, there never was any troubles....

Thanks

./Jesper
Jesper_DK is offline   Reply With Quote
Old 06-13-04, 07:31 AM   #7
utanja
Debian All the Way
 
Join Date: May 2004
Location: Salzburg Austria & Orlando Florida
Posts: 59
Default Re: Xfree fails to load with 5336 drivers.

basically the older kernel was compiled with an older GCC compiler and all modules must be compiled with the same compiler...

i would suggest upgrading your kernel to 2.4.6 as well as an entire system upgrade

apt-get dist-upgrade.

apt-get install kernel-image-2.4.6
and
apt-get install kernel-headers-2.4.6

now reinstall the nvidia drivers....

you should not have a problem...

oh btw...the weather has been good in Salzburg as well..
__________________
utanja
i am female and i don't do windows.. and i don't do macs ..i fly a Lear Jet
"Wer fremde Sprachen nicht kennt, weiss nichts von seiner eigenen."
- Goethe, Maximen und Reflexionen
Intel 3I-core 2d.gen -3.1GHz;8 gig ram;PureDebian SID[3.2[custom kernel] 8 Debian workstations
plus HP Win7 64bit Wireless Laptop Network/Citrix/NX/VMware
Mozilla/Firebird browsers
my american friends call me tonya
utanja is offline   Reply With Quote
Old 06-13-04, 07:57 AM   #8
Jesper_DK
Registered User
 
Join Date: Jun 2004
Posts: 17
Default Re: Xfree fails to load with 5336 drivers.

Hi utanja

Well nice to hear that Germans also has been blessed with good weather, never been to Salzburg though, only Berlin, but that was realy nice... Anyways

Im gonna do what you suggested, hope fully im able to give you a reply within a couple of hours... if not something went horroply wrong.

Thanks a bunch

./Jesper
Jesper_DK is offline   Reply With Quote

Old 06-13-04, 08:09 AM   #9
utanja
Debian All the Way
 
Join Date: May 2004
Location: Salzburg Austria & Orlando Florida
Posts: 59
Default Re: Xfree fails to load with 5336 drivers.

Quote:
Originally Posted by Jesper_DK
Hi utanja

Well nice to hear that Germans also has been blessed with good weather, never been to Salzburg though, only Berlin, but that was realy nice... Anyways

Im gonna do what you suggested, hope fully im able to give you a reply within a couple of hours... if not something went horroply wrong.

Thanks a bunch

./Jesper
jesper......i am austrian.....and live in austria...salzburg is in austria...

ok....good luck.....the early debian kernels where compiled with GCC2.9 i think and that is your problem...
__________________
utanja
i am female and i don't do windows.. and i don't do macs ..i fly a Lear Jet
"Wer fremde Sprachen nicht kennt, weiss nichts von seiner eigenen."
- Goethe, Maximen und Reflexionen
Intel 3I-core 2d.gen -3.1GHz;8 gig ram;PureDebian SID[3.2[custom kernel] 8 Debian workstations
plus HP Win7 64bit Wireless Laptop Network/Citrix/NX/VMware
Mozilla/Firebird browsers
my american friends call me tonya
utanja is offline   Reply With Quote
Old 06-13-04, 09:48 AM   #10
Jesper_DK
Registered User
 
Join Date: Jun 2004
Posts: 17
Default Re: Xfree fails to load with 5336 drivers.

Hi again

Ups, sorry, i thougth Salzburg was in germany......

Well, as you can see im back i X and i am running with Nvidia drivers.

Thanks a bunch !!.

./Jesper
Jesper_DK is offline   Reply With Quote
Old 06-13-04, 10:43 AM   #11
utanja
Debian All the Way
 
Join Date: May 2004
Location: Salzburg Austria & Orlando Florida
Posts: 59
Default Re: Xfree fails to load with 5336 drivers.

Quote:
Originally Posted by Jesper_DK
Hi again

Ups, sorry, i thougth Salzburg was in germany......

Well, as you can see im back i X and i am running with Nvidia drivers.

Thanks a bunch !!.

./Jesper
glad to have you with us....and i guess from you post..everything is in order..
__________________
utanja
i am female and i don't do windows.. and i don't do macs ..i fly a Lear Jet
"Wer fremde Sprachen nicht kennt, weiss nichts von seiner eigenen."
- Goethe, Maximen und Reflexionen
Intel 3I-core 2d.gen -3.1GHz;8 gig ram;PureDebian SID[3.2[custom kernel] 8 Debian workstations
plus HP Win7 64bit Wireless Laptop Network/Citrix/NX/VMware
Mozilla/Firebird browsers
my american friends call me tonya
utanja is offline   Reply With Quote
Old 06-16-04, 04:36 PM   #12
thomas21
Registered User
 
thomas21's Avatar
 
Join Date: Apr 2004
Posts: 35
Default Re: Xfree fails to load with 5336 drivers.

Quote:
Originally Posted by Jesper_DK
Hi Thomas

Thanks, for the reply, sorry about the late answer, it has been great weather in denmark, so I have been in the parks drinking beers. Anyways...

I installed both the kernel-headers and kernel-sources, but was told to link /usr/src/linux to the kernel-headers, and that also worked during the nvidia install.
You tell me to link the kernel sources ?.

btw. I needed to make this link before the install worked
Code:
ln -s /usr/src/kernel-headers-2.4.18-bf2.4/ /lib/modules/$(uname -r)/build
I tryed rerunning the nvidia-installer without effect. It still states that my GCC version is different that the one the kernel was compilled with my gcc version is "gcc version 3.3.3 (Debian 20040429)"

I realy dont know what causes this, I have used these drivers several times before, there never was any troubles....

Thanks

./Jesper
Hi Jesper,

Glad you got it working.
(and yes you are right about the "/usr/src/linux" link)

Utanja,

Big thanx

Regards,
Ton
// By the way, weather in Amstelveen //
thomas21 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 08:03 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Mandrake 9 and nVidia drivers HunterA3 NVIDIA Linux 9 10-09-02 02:54 AM

All times are GMT -5. The time now is 03:01 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.