Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-17-02, 05:18 PM   #1
darkchiild
Guest
 
Posts: n/a
Default X crashes, no errors.

Problem:

After running startx, the screen goes black for about 30 seconds, then a red ansi block appears in the upper left hand corner. After that it's a hard crash. Can't do anything but reboot.

Installation:

I used the tar files to install

NVIDIA_GLX-1.0-3123.tar.gz and
NVIDIA_kernel-1.0-3123.tar.gz

Everything seemed to install successfully, the kernel module loaded properly, etc.

I edited the XF86Config file as specified in the docs, and even played with things a little to no avail (changing resolution, depths, etc).

Errors:

The don't appear to be an error or warning messages in the X log file. I tried using the -logverbose option specified in the docs eg:

XFree86 -logverbose

Not sure if that's what's supposed to do it or not, I'm still fairly new to linux. In any event, it just seems to stop processing half way through. No errors or anything.

Hardware:

Athlon 1800XP
Asus A7V w/ Ali Chipset rev 1006
RH8.0 knl ver: 2.4.18-14
XFree v 2.2 Gnome

BTW, I tried setting the AGP 'fast write' (turbo doesn't exist) in the BIOS to off already. Didn't do the trick.

I'm at a dead end. I've tried everything i can think of I read through the docs, and there doesn't seem to be anything else that applies to me. I scanned the newsgroups, and nothing there... So here I am. Any help anybody can throw my way would be greatly appreciated.

Going to attach X logs.
Attached Files
File Type: txt xfree86.0.log.txt (20.6 KB, 123 views)
  Reply With Quote
Old 10-17-02, 07:23 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

According to your log, you aren't loading glx. I don't know if it will help with this problem, but you might try it.

I think the problem where the log seems cut off is because it isn't getting written out to the actual disk before the lockup (or the reset, if you're hitting reset pretty fast). Try waiting a bit longer (if you're already waiting like 30 seconds or so, then this isn't a good solution), or try hitting Alt-SysRq-S (SysRq is your print screen key, or at least, it should be), waiting a while (20 seconds or so), then Alt-SysRq-B. If the Alt-SysRq-B doesn't reset your box, then the first combination (which is supposed to sync your disks) didn't do its thing either, and you might as well just hit reset.

Which AGP implementation are you using? agpgart, or NvAgp?

Does dropping the AGP rate down to 2x help?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-17-02, 07:42 PM   #3
chrono86
Registered User
 
Join Date: Oct 2002
Posts: 13
Default

I GET THE SAME EXACT PROBLEM. Except that my screen doesn't go red, it flashes 3 blues then hangs. My log file doesn't record any errors and it makes no FREAKING sense. I tried EVERYTHING with nothing but a pointlessly reinstalled GNU/Linux system to show for it. Our Hardware isn't that similar i have:

AMD K6-2 350MHz
Geforce 2 MX 400 SDRAM 64MB
VIA 829C*** chipset'
and everything else doesn't matter.

since you are using an athlon processor, it might be that mem=nopentium line you can add, but you might have tried that already. Maybe its the AGPX rate like bkwaz said, although I'm not sure how to find out what rate and agp card is running at (anyone have a tip for that?) oh yeah, also when you ran the "nv" driver before, did XFree86 run? nice to know someone else is sharing my problem. my post was at http://www.nvnews.net/vbulletin/show...?threadid=2742
-rian

Last edited by chrono86; 10-17-02 at 07:50 PM.
chrono86 is offline   Reply With Quote
Old 10-18-02, 08:42 AM   #4
darkchiild
Guest
 
Posts: n/a
Default Solution... Sort of

Well thanks for the suggestions ppl. It turns out that changing the AGP from 4X to 1X in the bios did the trick. I'm able to load Xwindows w/ the nVidia drivers....

Thing is this doesn't strike me as a viable solution to the problem. I don't want to suffer a performance hit when booting into windows for gaming, etc. and I'd rather like to be able to have 4X support in linux as well.

I was thinking if I used NvAGP that may help? Also, I'm not sure how to find out if agpgart is statically compiled into the kernel, etc. It doesn't show with lsmod.

I tried flashing the bios too to rev 1009, but that didn't do any good. I also didn't see anything in the bios after upgrading which mentioned IO recovery time (this was mentioned in the docs for Ali chipsets running rev 1009 bios).

So here are my remaining questions/concerns:

If I AM running agpgart, is there any way to force AGP 1X mode so I don't have to recompile my kernel to use nvagp to set it in the xf86config?

How do I find out what's statically compiled into the kernel? Specifically agpgart? (Remember I'm a stoopid newbie)

Why don't I have this problem when using the default Xwindows drivers (this is more a curiosity than anything else) ?

Are there any possible work arounds so I don't have to use 1X mode at all? (besides buying another motherboard)

Why does Ali have to suck so bad?

Thanks again to anybody with answers.
  Reply With Quote
Old 10-18-02, 08:56 AM   #5
chrono86
Registered User
 
Join Date: Oct 2002
Posts: 13
Default

Hey you can dynamically change your agp rate when GNU/Linux load so that it can stay 4x in your BIOS. Here is one little tidbit from the README:

AGP Rate

You may want to decrease the AGP rate setting if you are seeing
lockups with the value you are currently using. You can do so
with the NVreg_ReqAGPRate NVdriver module parameter.

If you are inserting the module manually:

insmod NVdriver NVreg_ReqAGPRate=2 # force AGP Rate to 2x
insmod NVdriver NVreg_ReqAGPRate=1 # force AGP Rate to 1x

If you are using modprobe (/etc/modules.conf):

alias char-major-195 NVdriver
options NVdriver NVreg_ReqAGPRate=2 # force AGP Rate to 2x
options NVdriver NVreg_ReqAGPRate=1 # force AGP Rate to 1x

I'm a Linux newbie too, so don't know how to do any of that stuff, but if you say changing your AGP rate lower works, then it should work for me! This is just one step closer to the solution of my problem, except my motherboard's bios doesn't allow you to change your AGP rate (although i know my agp card is running at 66Mhz, does that mean 1x? anyone?). I'm sure someone who knows about Modules and such will reply with the answer, thanks again!
-rian
chrono86 is offline   Reply With Quote
Old 10-18-02, 12:47 PM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

I'm not sure how to check agpgart, unless you want to look at your kernel-source directory. Do a find /usr/src/linux-<version> -name .config to figure out where the right file is, and open it up in an editor. Assuming /usr/src/linux-<version> matches your running kernel, then if agpgart is compiled into your kernel, you'll find a line that says:

CONFIG_AGP=y

If it says CONFIG_AGP=m instead, then it was compiled as a module. If it says # CONFIG_AGP is not set, then agpgart wasn't compiled -- but I think this is unlikely.

As for why you don't have the problem with the "nv" drivers, I don't know. It's probably something having to do with the fact that "nv" doesn't support 3D, though -- it's probably putting a lot less stress on your AGP chipset. Maybe.

chrono86 -- the way you pass those options to the module, is almost always by editing the /etc/modules.conf file. Pick one of the options NVdriver xxxxxx lines, and add it to /etc/modules.conf. Then run /sbin/depmod -a (to update dependencies), and either reboot or log out of X, remove the NVdriver, and restart X to test. You can check X's log to see which AGP rate it ended up using.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-18-02, 04:14 PM   #7
darkchiild
Guest
 
Posts: n/a
Default More questions

I had a look at the file in question, and it appears that agpgart is being loaded as a module. However it still doesn't show up when doing an lsmod (even when doing it from Xwindows in a terminal window).

You'd think I'd be able to see it if it were loaded right? In any event, where might I be able to find that in the slew of startup config files that linux has to disable it? Or how could I even disable it manually?

Chrono86: I saw what you suggested in the docs, and even tried it however, it didn't work. I'm assuming because the kernel is already looking to agpgart for this setting?

Perhaps I should just give up and get a decent motherboard?
  Reply With Quote
Old 10-18-02, 04:51 PM   #8
darkchiild
Guest
 
Posts: n/a
Default argh

Well, after playing around with things a little more I discovered that agpgart wasn't being loaded, and X is using the NVdrivers.

For some reason however, X still crashes when I specify 1X mode in the modules.conf file. I checked the X logs, and it did say it was running in 1X mode. Problem is that even after specifying that (and it appears to be working), if I change the AGP mode to 4X in the bios, X still crashes on startup.

I tried loading agpgart as a module too, but that didn't seem to do any better than the nVidia drivers...

It's looking more and more like I'm just going to have to get a new mobo to get things working the way I want. Well, thanks for the help anyhow. At least now I KNOW I'm screwed.
  Reply With Quote

Old 10-18-02, 05:14 PM   #9
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Buggy motherboard BIOS perhaps? Maybe enabling 4x is triggering some bug?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-18-02, 05:33 PM   #10
chrono86
Registered User
 
Join Date: Oct 2002
Posts: 13
Default

ahh, this is my last question. How do i start the agpgart module (that is only if i have it installed in my kernel) and 2, when you said earlier bwkaz to "...remove the NVdriver..." what exactly do you mean remove? can't i just add those option lines to the /etc/module.conf (hehe i got to know that file today after getting my sound card to work) file and restart my system? thanks again, and hopefully i get my video card running finally.
-rian
chrono86 is offline   Reply With Quote
Old 10-18-02, 07:07 PM   #11
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Yes, you can just restart, that will work fine.

You can load agpgart by doing an /sbin/modprobe agpgart as root. But you'll probably want to make sure X isn't running when you do this, because if it is, then NvAgp has probably been loaded already.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-19-02, 12:43 PM   #12
chrono86
Registered User
 
Join Date: Oct 2002
Posts: 13
Default

okay i don't get it. NOW i've tried EVERYTHING. So my first approach was to load agpgart when i start my computer (by the way i have an MVP3 chipset, and i found out that CONFIG_AGP=m and theres a whole lot more CONFIG_AGP's like CONFIG_AGP_AMD and they are all set to yes.) so i edited my modules.conf and i found "alias */dev/nvidia NVdriver" in there, i took that out because i didn't know what that was for i also set the XF86Config-4 Screen section with "Option "NvAgp" "2"". SO i rebooted and i expected agpart to load automatically. When i did a lsmod, agpgart wasn't listed there. I had always got the impression that the nvidia driver for X starts the agp modules (be it NvAgp or AGPGART) automatically, so i thought that is what was going to happen. So i started X, and same problem. IN the log file it said at the end "Failed to verify AGP Usage" also in my kernel's error file it said "BLAH BLAH: AGPGART: FAILED TO USE write combining MTRR" and in the log file for X i noticed it said "(WW) System does not support changing MTRR". So what the hell is MTRR and what does it have to do with blinking blue lights. I figured i can just recompile the driver to use NvAgp instead of AGPGART by putting "make NVdriver BUILD_PARAMS=NOAGPART" but even then i'm still confused about a couple of things:

What was the NVdriver line in the modules.conf originally? was that NvAgp or the NVdriver, and if it was the NVdriver, why does it need to be loaded at startup?

How come agpgart or NVdriver don't show under lsmod when you load them in modules.conf, but do show up when you do modprobe agpgart or modprobe NVdriver?

that's it for now, if someone sees any fault in my original setup please tell me, i really am frustrated and i want to get this thing to work. thanks
-rian
chrono86 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphic errors and hangs after standby reini122 NVIDIA Linux 4 05-07-12 03:37 AM
Graphical errors: broken card? lapino NVIDIA GeForce 7, 8, And 9 Series 0 05-03-12 01:20 PM
Crashes now? Imperito NVIDIA Linux 4 10-09-02 11:23 PM
crashes and freezes Lethal Weapon NVIDIA Linux 9 09-27-02 08:23 PM
Getting bizarre errors with driver install clutch NVIDIA Linux 1 09-14-02 09:53 PM

All times are GMT -5. The time now is 05:18 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.